nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   no screens found (http://www.nvnews.net/vbulletin/showthread.php?t=12783)

tenfelipe 06-02-03 09:44 PM

no screens found
 
1 Attachment(s)
Hi! I'm trying to use nvidia driver to my Gforce 2 MX 400, n I'm getting this message when I try startx or kde commad:

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Well, this happends before I install nvidia drive and make changes in XF86Cfg-4 described at README.

If I use the normal nv drive, theres no problem (but also there's no nvidia drv :D ). But if I put the nvidia drv, it gives me this message...

I'm using Conectiva Linux 9.0
GForce 2 MX 400 64Mb

Here goes my logs n XFconf files
the .nvidia is just to handle with them, but i'm trying normaly with XF86Config-4

tenfelipe 06-02-03 09:46 PM

XF86Config-4
 
1 Attachment(s)
and here goes the other

bwkaz 06-03-03 05:42 PM

Before you can use the Driver "nvidia" line in XF86Config-4, you need to have the nvidia kernel module (which is actually something different, go figure...) working correctly.

Try doing an /sbin/modprobe nvidia as root before you do your startx as your normal user (do this from a text-mode console login), and see if that helps at all.

If it says "no module found", or something like that, then you haven't installed the drivers yet, or haven't installed them properly -- try rerunning the NVIDIA-Linux-whatever.run file.

tenfelipe 06-03-03 10:25 PM

Well, I uninstaled my kernel n instaled it again, and now, when I run the driver .run prog, it gives me a message whith problems with depmod like this:
executing: '/sbin/depmod -aq'...
depmod: /lib/modules/2.4.21-28872cl/modules.dep.rpmsave is not an ELF file
depmod: /lib/modules/2.4.21-28872cl/modules.generic_string.rpmsave is not an
ELF file
depmod: /lib/modules/2.4.21-28872cl/modules.isapnpmap.rpmsave is not an ELF
file
depmod: /lib/modules/2.4.21-28872cl/modules.pcimap.rpmsave is not an ELF fil
e
depmod: /lib/modules/2.4.21-28872cl/modules.usbmap.rpmsave is not an ELF fil
e
ERROR: Failed to execute `/sbin/depmod -aq`: depmod:
/lib/modules/2.4.21-28872cl/modules.dep.rpmsave is not an ELF file
depmod: /lib/modules/2.4.21-28872cl/modules.generic_string.rpmsave is
not an ELF file
depmod: /lib/modules/2.4.21-28872cl/modules.isapnpmap.rpmsave is not an
ELF file
depmod: /lib/modules/2.4.21-28872cl/modules.pcimap.rpmsave is not an ELF
file
depmod: /lib/modules/2.4.21-28872cl/modules.usbmap.rpmsave is not an ELF
file



What am I supposed to do??:confused:

tenfelipe 06-04-03 10:20 AM

Problem soved
 
Hi! Fortunatly, I solved the problem

The error is that the option "set IRQ for VGA" was disabled in my BIOS". I saw this possibility looking at the other threds.

The problem with the installation, I donŽn no what is, but I think that files were created when I uninstalled my kernel. Well, anyway, I tested my drivers with nvidia-installer --sanity and it sad that everything is ok...


Well, anyway, thanks for attention!

bwkaz 06-04-03 08:48 PM

You can blow away those .rpmsave files. They all get regenerated whenever you run depmod -a anyway.

But it works without, so so much the better.


All times are GMT -5. The time now is 04:06 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.