nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem with SuSE 8.2 Athlon Kernel and nVidia Driver (http://www.nvnews.net/vbulletin/showthread.php?t=12875)

frankk 06-04-03 12:45 PM

Problem with SuSE 8.2 Athlon Kernel and nVidia Driver
 
1 Attachment(s)
I've got a Problem with the driver-installation. The installation-routine ends unsuccessful and notifies me to have a look an the nvidia-installer.log.

GeForce 2 MX 400
NVIDIA-Linux-x86-1.0-4363
SuSE Linux 8.2
Athlon 1 GHz (Thunderbird)
ASUS A7V

davej 06-04-03 05:08 PM

I've got a similar-ish setup (athlon, SuSE 8.2, same nvidia driver) to you and the standard installatin worked OK.

I noticed from your log file that you'd selected expert mode and entered a path for the kernel include dir. The automatically selected include dir from my log file is /lib/modules/2.4.20-4GB-athlon/build/include which is different to your path.

Although both paths include symbolic links which mean they end up pointing to the same directory, I think the full path name might be significant when it tries to identify which kernel version the driver has been compiled for. Try just using the standard installation or specifying the path mentioned above.

I also had problems booting after installing the driver and had to set ACPI=OFF when booting up but that might be because I've got a Asus A7N8X motherboard. If it happens to you you can select 'safe mode' when you get to the boot menu and delete the option whilst you alter the boot menu.

dave j

frankk 06-05-03 11:52 AM

1 Attachment(s)
Thanks for the tip, but it doesn't work.

I've tried both versions with the same result as before. But I must correct myself, I've got a GeForce 2 GTS, (I think it doesn't matter).
The Kernel is the original, that was installed by SuSE and I didn't do any modification on my System that effect my gcc, libraries or Kernel Source.
Perhaps you have another idea.

frankk

davej 06-05-03 12:51 PM

I compared your new install log to mine and the only differences are:

1. Mine mentions existing version 4349 were yours mentions 4363.

2. I didn't specify the include path and the one it assumed does not have the / at the end like the one you entered - a difference which is carried to all the -I compiler options. But that shouldn't make a difference.

The logs are otherwise identical until yours contains the

ERROR: Unable to load the kernel module 'nvidia.o'

line.

It might be worth going back to the nv driver, removing all traces of nvidia drivers and starting it again with a fresh system - just letting it pick the options.

gerous 06-06-03 11:40 AM

-> Kernel module load error: ./usr/src/nv/nvidia.o: kernel-module version
mismatch
./usr/src/nv/nvidia.o was compiled for kernel version 2.4.20-4GB
while this kernel is version 2.4.20-4GB-athlon.

This is the Line!!! The YaST installer has a BUG
so edit the file:
/usr/src/linux.kversion, and
/usr/src/linux/include/linux/version.h
and change the line wich says:
2.4.20-4GB to 2.4.20-4GB-athlon
Then the installer is able to load the module!
And if you know this "Search" button give it a try.
you would have found many threads including
my one one: "HOWTO install on non standart kernels on suse 8.2"


All times are GMT -5. The time now is 06:59 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.