nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Geforce4 Ti 4200 Issues (http://www.nvnews.net/vbulletin/showthread.php?t=12892)

run_faster 06-04-03 08:33 PM

Geforce4 Ti 4200 Issues
 
1 Attachment(s)
I'm sure that this is nothing no one hasn't seen before, but i've read through the README (I could've missed something I suppose) and I'm still stuck.

My specs:
A7N8X mobo
Athlon 2600+ processor
Debian (Woody), apt-get upgrade has successfully been run, so 4.something is the version of XFree.
Using the latest nvidia-kernel-src/glx packages from debian

Download and such during installation went fine. Now when I'm trying to startx I get the

"No screens found"

Which seems like it has meant different things to different people. Yes, I do have a screens section in my XF86Config-4, with display sections and everything.

My lspci and XFree logs are attached. (lspci is after the xfree log)

Blackbox is installed and waiting on xdm, so there will be a window manager.

When I do startx, I get a couple flickers, and then the no screens found.

Only thing of note other than at the end (the no screens found) is the attempt (failed ) to load the APM module.


Thanks for the help.

run_faster 06-04-03 08:39 PM

whopps
 
1 Attachment(s)
Sorry, not very clever of me not to acttach my config file... i did attach log and lspci though...

bwkaz 06-04-03 09:45 PM

Re: Geforce4 Ti 4200 Issues
 
Quote:

Originally posted by run_faster
Using the latest nvidia-kernel-src/glx packages from debian
Actually, no, you're not. Well, maybe you're using the latest ones that Debian has available for your installation of Debian, but according to your log file, that version is 1.0-2880. Which is about two years old, IIRC. And I see that your version of X is about two years old as well (version 4.1.0.1). That driver version has very little support (if any) for the GeForce4's, and none whatsoever for the AGP 8x ones.

Upgrade to 4363 -- and instead of using Debian packages, use the nVidia installer off the driver download page.

run_faster 06-04-03 11:30 PM

Ha, it works!
 
Well, now it works. Thanks for the advice.

So, just for everyone else.

Changed my /etc/apt/sources.list to all testing instead of stable. Then I downloaded the unstable versions of the debian packages for nvidia-kernel-src, and glx. Then i followed the nonexistant readme (I have no idea why one wasn't installed with the package).

for those who care:
tar -xzvf the kernel tar that you got, in /usr/src
then make-kpkg modules_image in your source directory
then go find the .deb that was created with the modules_image in it, dpkg -i that.

reboot (sadly, this was important).

now, /usr/src/NVIDIA_glxwhatever
dpkg-buildpackage -us -uc

Then dpkg -i that (its in /usr/src)

when that fails, reboot! (I got some unmet dependancies, and did an apt-get -f install to one of them)

Then it worked.

run_faster 06-11-03 09:45 AM

anyone find this helpful?
 
If anyone found this helpful, let me know. Thanks.


All times are GMT -5. The time now is 06:46 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.