nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   problems with 71.86.09 (legacy) for FreeBSD (http://www.nvnews.net/vbulletin/showthread.php?t=129830)

greba 03-10-09 04:49 PM

problems with 71.86.09 (legacy) for FreeBSD
 
Hi there!
I've got problems with 71.86.09 (The same goes to 71.86.08). When I try launch X, it crashes with following:
(II) Loading /usr/local/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/local/lib/xorg/modules/drivers//nvidia_drv.so: Undefined symbol "AllocateScreenPrivateIndex"
(EE) Failed to load /usr/local/lib/xorg/modules/drivers//nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available.

Fatal server error:
no screens found

It is odd about nvidia module 'cause nvidia is loaded.
[greba:/root]# kldstat
Id Refs Address Size Name
1 18 0xc0400000 3d3340 kernel
2 1 0xc07d4000 517c atapicam.ko
3 1 0xc07da000 3f2860 nvidia.ko
4 3 0xc0bcd000 30ffc linux.ko
5 1 0xc0bfe000 8d678 acpi.ko
6 1 0xc301a000 7000 linprocfs.ko

Well, I tried unload nvidia and then load it again, but kernel panic accured, in that case...

xorg.conf:

Section "Module"
Load "dbe" # Double buffer extension
Load "glx"

SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

Load "freetype"
EndSection


Section "Files"

# FontPath "/usr/local/lib/X11/fonts/webfonts/"
FontPath "/usr/local/lib/X11/fonts/bitstream-vera/"
FontPath "/usr/local/lib/X11/fonts/misc/"
FontPath "/usr/local/lib/X11/fonts/terminus-font/"
FontPath "/usr/local/lib/X11/fonts/TTF/"
FontPath "/usr/local/lib/X11/fonts/OTF/"
FontPath "/usr/local/lib/X11/fonts/100dpi/"
FontPath "/usr/local/lib/X11/fonts/75dpi/"
FontPath "/usr/local/lib/X11/fonts/local/"

EndSection


Section "ServerFlags"

EndSection


Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"

Option "AutoRepeat" "500 30"

Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

EndSection


Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto" # Auto detect
Option "Device" "/dev/sysmouse"

Option "ZAxisMapping" "4 5 6 7"

Option "Emulate3Buttons" "false"

EndSection


Section "Monitor"

Identifier "SAMSUNG SyncMaster 755dfx"

HorizSync 31.5 - 79.0
VertRefresh 40-150
DisplaySize 270 203
EndSection


Section "Device"
Identifier "Standard VGA"
VendorName "Unknown"
BoardName "Unknown"

Driver "vga"

EndSection


Section "Device"
Identifier "NVIDIA GeForce 2Ti"
Driver "nvidia"
Option "NvAGP" "1"

EndSection


Section "Screen"
Identifier "Screen 1"
Device "NVIDIA GeForce 2Ti"
Monitor "SAMSUNG SyncMaster 755dfx"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection


Section "ServerLayout"

Identifier "Simple Layout"

Screen "Screen 1"

InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection

# Section "DRI"
# Mode 0666
# EndSection

dmesg:
nvidia0: <GeForce2 Ti> on vgapci0
vgapci0: child nvidia0 requested pci_enable_busmaster
vgapci0: child nvidia0 requested pci_enable_io
nvidia0: [GIANT-LOCKED]
nvidia0: [ITHREAD]

and uname -a:
FreeBSD greba.FreeBSD 7.1-RELEASE-p3 FreeBSD 7.1-RELEASE-p3 #2: Tue Mar 10 23:57:08 MSK 2009 root@greba.FreeBSD:/usr/obj/usr/src/sys/MYKERNEL i386

Hope all of this would be useful to resolve that kind of problem.


All times are GMT -5. The time now is 03:51 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.