nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [BUG REPORT] Fonts tearing with kwin4 FX effects turned on (http://www.nvnews.net/vbulletin/showthread.php?t=130117)

artem 03-16-09 01:04 AM

[BUG REPORT] Fonts breakage with kwin4 FX effects turned on
 
3 Attachment(s)
As soon as I enable desktop effects in KDE 4.2.1 KWin window manager, all my fonts start looking like a garbage to the point of being unable to read.

Screenshots of a bug and KWin options (quite default) are attached.

GPU: nVidia Corporation C51PV [GeForce 6150] (rev a2)
MB: ASUS M2NPV-VM ACPI BIOS Revision 0901
Drivers: 180.37 (all others too).

artem 03-17-09 04:39 AM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
Can anyone else confirm this bug?

artem 03-20-09 12:41 AM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
1 Attachment(s)
Still happens with 185.13. even without kwin effects :(

Fackamato 03-20-09 03:15 AM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
What distribution are you using?

artem 03-20-09 04:35 AM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
Fedora 10 with all updates installed.

artem 03-23-09 01:06 PM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
Bump.

kriko 03-23-09 01:37 PM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
I saw this too - it mostly happens after using intensive openGL applications.
I can reproduce it most times by:
- enabling effects
- starting Google earth
- use it a bit
- closing google earth

fonts will be smeared after that. Geforce 7600GT @ 1600x1200.
I think this started to appear after using InitialPixmapPlacement=2.

So try:
nvidia-settings -a InitialPixmapPlacement=1
or 0.

artem 03-25-09 02:40 AM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
I don't use any performance related hacks to run X.org with NVIDIA (after all I have GeForce 6xxx which has never had any serious performance problems aside from being terribly slow in all heavy OpenGL applications ;) ), but I will certainly try your suggestion.

kriko 03-25-09 04:40 AM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
It's not a performance "hack" it is being used by nvidia in recent drivers, but I'm not sure.
If IPP is set to 2 then it uses graphic card memory to cache fonts, but it seems to do it badly in some cases.
Please report back if it works.

artem 03-25-09 05:27 AM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
1 Attachment(s)
With IPP=1.

Now testing with IPP=0.

kriko 03-25-09 06:12 AM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
What about ipp 0?
try also "-a GlyphCache=0"

artem 03-25-09 07:47 AM

Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on
 
1 Attachment(s)
With IPP=0 this problems causes less effects, but still it's here.


All times are GMT -5. The time now is 07:29 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.