nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   shutting down Xserver does not give a terminal screen (http://www.nvnews.net/vbulletin/showthread.php?t=13021)

witthoet 06-07-03 06:12 PM

shutting down Xserver does not give a terminal screen
 
I have my system configured to start at run level 3. When I log in I then manually start X("startx") and have no problems. However when I try to shut down "X" by either logging off or pressing the ALT-BACKSPACE sequence, my display show "unable to display this resolution".

I have a clean install of RH9.0 and have upgraded everything including the Kernal. Following is the output of my "uname -a":

Linux gordito 2.4.20-18.9 #1 Thu May 29 07:08:16 EDT 2003 i686 i686 i386 GNU/Linux

My system is:

Dell dimension 8200 w/512meg
Nvidia Gforce 420 w/video out 64meg
using the 1.0-4363 driver
Philips DVDRW/CDRW
HP Deskjet 932C

Does anyone have any idea why my system will not allow me to return to the console after I shut down X?

fyi when I open a console window while in X it works fine.

TIA

Tim

Mattman 06-09-03 08:20 AM

After much pain and agony. i found the answer to this one. the nvidia drivers dont like kernels with framebuffer for some reason, somone mentioned it on another forum, i recompiled the kernel without framebuffer and it works great.

bwkaz 06-09-03 05:27 PM

Without framebuffer worked for you? That's odd -- most of the people that I remember reporting issues like this (blank screen or no signal or something upon exiting X) weren't using the framebuffer. Turning it on fixed it for them...

Plus, I use it with FB on, too, without issues.

Hmm... well, I suppose if it worked for you, then it worked for you. But it does sound a little strange.

hj_18 06-09-03 07:33 PM

i have the same problem
 
i install 4363 in turbolinux8wks , my graphic card is MSI GF4MX440 , with PHILIPS 107P4 . when i startx , it works well , glxgear reports up . but when i quit to virtual consonle, the characters become a mess--each like a small snake. someone suggested use nvtv to push the button 'tv-off' and so on, but for me ,it doesn't work , and i toggle the FB on or off when the machine boot(vesafb option in grub.conf and setup the grub again), but it still fail. how can i do.

witthoet 06-11-03 12:32 PM

I will try with the FB on and off and see what happens.

Thanks for the help.

Tim


All times are GMT -5. The time now is 02:48 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.