nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Unusable 3D acceleration after Fedora 10 upgrade (http://www.nvnews.net/vbulletin/showthread.php?t=131080)

dragontome 04-03-09 06:46 PM

Unusable 3D acceleration after Fedora 10 upgrade
 
I am hoping someone may have knowledge that I have not be able to locate anywhere else on the web. I have recently upgraded from Fedora 9 to 10. Prior to the upgrade I had decent 3D rendering using a 2.6.26... rev. kernel and the proprietary nVidia drivers from RPMFusion version 173.xx. It was enough to enjoy Second Life much of the time. 3D applications (including Second Life) will run now, but at a very low frame rate. I have used the Unigine Tropics demo for testing and in the more complex/detailed renderings I get about 5 fps. I have also noted my CPU temp climbs now while attempting 3D rendering whereas it did not before.

I am currently on a kernel rev. 2.6.27.21 and nVidia drivers 180.29. I have verified no errors in my Xorg log and that it shows the following excerpt:
Quote:

(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode
(II) NVIDIA(0): "CRT-0:nvidia-auto-select+1680+0,CRT-1:nvidia-auto-select+0+0"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
I have also verified that direct rendering is enabled by using:
Quote:

$ glxinfo | grep direct
direct rendering: Yes
I have read through the nVidia documentation and verified that I have no stale simlinks and also used ldd to verify the correct, nVidia libs are loaded for glxgears.
Quote:

$ ldd /usr/bin/glxgears
linux-gate.so.1 => (0x0022f000)
libGL.so.1 => /usr/lib/nvidia/libGL.so.1 (0x033a9000)
libm.so.6 => /lib/libm.so.6 (0x005fb000)
libc.so.6 => /lib/libc.so.6 (0x00485000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x007b5000)
libGLcore.so.1 => /usr/lib/nvidia/libGLcore.so.1 (0x04f1d000)
libnvidia-tls.so.1 => /usr/lib/nvidia/tls/libnvidia-tls.so.1 (0x00ceb000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x008f0000)
libdl.so.2 => /lib/libdl.so.2 (0x00626000)
/lib/ld-linux.so.2 (0x0045c000)
libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x007b1000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x008b8000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x008de000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x008d6000)
My xorg.conf is fairly simple:
Quote:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder63) Thu Feb 5 00:19:09 PST 2009

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules/extensions"
ModulePath "/usr/lib/xorg/modules/fonts"
ModulePath "/usr/lib/xorg/modules/multimedia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "LG"
ModelName "LG W2252"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7600 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "1"
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT-0: nvidia-auto-select +1680+0, CRT-1: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
I am quite stumped and would appreciate any insight someone might have.
Thanks.

Big P 04-03-09 09:13 PM

Re: Unusable 3D acceleration after Fedora 10 upgrade
 
First you should install the latest stable drivers (180.44), and if you still experience an issue post an nvidia-bug-report as shown in the sticky posts.

kwizart 04-04-09 04:14 AM

Re: Unusable 3D acceleration after Fedora 10 upgrade
 
If you have Geforce 7xxx you can also give a try on kmod-nvidia-173xx (you need to remove xorg-x11-drv-nvidia first, install kmod-nvidia-173xx and reboot).

There is two reasons I could expect:
the 180xx driver seems to requires sse to be available on the cpu (check with cat /proc/cpuinfo ). Some on this forum reported that support for some card have been dropped with the lastest driver of the main series (but was more reports against 180.44 and is the reason why RPM Fusion doens't ship it yet ).

kailed 04-04-09 05:49 AM

Re: Unusable 3D acceleration after Fedora 10 upgrade
 
Quote:

Originally Posted by dragontome (Post 1975177)
I am currently on a kernel rev. 2.6.27.21 and nVidia drivers 180.29.

Same here on openSUSE with Nvidia-180.29 kernel 2.6.27.*. 7600 GT.
All fine with 180.18, .22, .37.
So change nvidia driver, try 180.44. Fallback to 180.37 if you still have issue.
Bye.

dragontome 04-04-09 07:18 AM

Re: Unusable 3D acceleration after Fedora 10 upgrade
 
1 Attachment(s)
Thanks for the replies, however various versions of the driver do not change the behaviour. I have used both the RPMFusion 173xx drivers as well as the actual .run pkg from nVidia for 180.44 and 177.82. All work just fine for all other video elements, just not accelerated 3D. I have not yet tried 180.37 as it doesn't seem to be available from the nVidia driver download pages.

kwizart: My /proc/cpuinfo flags are as follows (indicating sse is available):
Quote:

flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext 3dnowext 3dnow up
I have attached an nvidia-bug-report.

Dragoran 04-04-09 07:32 AM

Re: Unusable 3D acceleration after Fedora 10 upgrade
 
Try passing nopat to the kernel.

dragontome 04-04-09 08:17 AM

Re: Unusable 3D acceleration after Fedora 10 upgrade
 
I have been doing that since Fedora 9 (kernel 2.6.26...) and it solved a different issue of very 'jerky' performance not consistent, persistent low fps.


All times are GMT -5. The time now is 09:53 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.