nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia drivers stoped working with "upgrade" to gcc 3.3 and 2.4.21-rc7 (http://www.nvnews.net/vbulletin/showthread.php?t=13112)

Arwing 06-09-03 04:50 PM

nvidia drivers stoped working with "upgrade" to gcc 3.3 and 2.4.21-rc7
 
1 Attachment(s)
I "upgraded" Slackware 9 with gcc 3.3 and also kernel v 2.4.21-rc7 (so that the kernel would compile). I also built X 4.3 from source (because it seems to look better than the Slackware package). I compiled the nvidia drivers from the source packages (with IGNORE_CC_MISMATCH=1 set, so they would compile), and they don't work. This config....

Arwing 06-09-03 04:53 PM

1 Attachment(s)
...produces this log file. The nv driver works, and before i "upgraded" everything worked fine. geforce 4 ti4600 & athlon xp2400+

Please help!

bwkaz 06-09-03 05:37 PM

First:

Never, ever, ever use IGNORE_CC_MISMATCH. Recompile your kernel with the system compiler instead, and boot into it, so that /proc/version's gcc version matches what cc -v says.

Second:

Your log file is loading about 15 different XFree86 drivers (none of them, incidentally, are the nvidia one). None of them can find any hardware, or something, so you get the "no screens found" error. If this is actually the right config file that you posted, it's only referencing one nvidia driver (nvidia_drv.o), but that driver isn't ever getting loaded.

When you configured X before compiling it, you did select support for dynamic loading of modules, correct? (you need to edit the config/cf/host.def file after you copy config/cf/xf86site.def over it, BTW).

Are you sure this config file (the one you posted) is /etc/X11/XF86Config?

Are you sure this log is from the most recent attempt at running X?

Arwing 06-09-03 09:21 PM

I fixed the cc mismatch, by fixing some symlinks and kicking myself a few times (not recompiling the kernel). I then recompiled everything for good measure ;) , and it all worked. The compilers wern't acctually mismatched, they just thought they were, which was why i just set the ignore. But i re-symlinked cc to the new gcc, and it worked perfectly.

Thanks for your help.

BTW that was the correct pairing of config and log. I saw how fscked up the log was. That was what made me decide to acctually post.

Thank you much

bwkaz 06-10-03 05:17 PM

The nVidia Makefile uses cc, not gcc, so even if your gcc command would have resolved to the right version, you could still see problems at runtime (and the Makefile will also complain about the version mismatch) if cc didn't resolve to the right version.

So the driver is working now, then? Or not?

Arwing 06-12-03 04:03 PM

it works wonderfully. I didn't reply for a while because i was playing SOF

bwkaz 06-12-03 05:23 PM

OK, cool. :)


All times are GMT -5. The time now is 09:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.