nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Acer TM 630, no hotkey switching, only fb resolution on CRT (http://www.nvnews.net/vbulletin/showthread.php?t=13120)

ecos 06-09-03 06:29 PM

Acer TM 630, no hotkey switching, only fb resolution on CRT
 
1 Attachment(s)
Hi,
on my Acer TravelMate 634 I can get the flat panel (1400x1050) to work and use an external monitor connected to the CRT connector, *but*:

1. hotkey switching (pressing Fn+F5 - I suppose that's how it should work?) doesn't do anything, not even in non-X mode. Probably this is somehow done by the OS when running windows - which I haven't tried and don't plan to. Switching the TFT panel off (Fn+F6) works, after switching back on in terminal mode I see the same content on both screens, but this doesn't work in X.
Starting with 4363 switching the TFT off and on again while in X creates a "blue" screen (no sync problems, only blue colored). Switching from X to the text terminal and back again restores the screen content.

Do you plan to provide a program to manually switch output channels? (nv-tv-out works great doing this with TV out).

2. when switching on the CRT display using twinview it works but only when I configure the vesa framebuffer into the kernel and only with the resolution selected when booting the system (I've read in the docs that it isn't possible to change vesafb's resolution later on - ?). It seems the content is written to a larger area (no panning), but I only get the resolution selected in the boot options (which is annoying if you try to use beamers with different capabilities).

3. When switching from X to text terminal the TFT flickers, after switching it off and on again (Fn+F6) I get a perfectly stable picture. Any registers not restored correctly?

Model: GeForce2 GO (AGP)
Video Bios: 03.11.01.53.10
Driver Version: 1.0-4363 (Same problems from 1.0-4191 on which was the first I've tried; only the "blue screen when switching back on in X" problem wasn't there before 4363 as far as I remember)
Linux 2.4.20 w/ ACPI patch

Hotkey (or similar) switching at runtime and changing resolution would be *very* important for me - any plans?
Otherwise: good driver, great performance!

ecos 06-12-03 02:39 AM

Help!
 
Is there anything I can try? Any ideas??


All times are GMT -5. The time now is 03:48 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.