nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Can't set the resolution of 1366x768 (http://www.nvnews.net/vbulletin/showthread.php?t=131408)

vladoboss 04-11-09 11:43 AM

Can't set the resolution of 1366x768
 
I use Mandriva PWP 2009.0 X86_64, with 173.14.12 version of nvidia drivers. I can't get the resolution 1366x768 which I set in Mandriva Control center. It alway fall back to 1280x720. This is what I get in Xorg.0.log:

(--) NVIDIA(0): Connected display device(s) on GeForce FX 5200 at PCI:1:0:0:
(--) NVIDIA(0): Philips 191EW (CRT-0)
(--) NVIDIA(0): Philips 191EW (CRT-0): 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1366x768"; removing.
(WW) NVIDIA(0): No valid modes for "1360x765"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1280x720"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 720
(--) NVIDIA(0): DPI set to (79, 79); computed from "UseEdidDpi" X config

In xorg.conf file I have this settings for resolution:

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Philips 191EW"
HorizSync 30-83
VertRefresh 56-76
Option "PreferredMode" "1366x768"

# Monitor preferred modeline (59.8 Hz vsync, 47.7 kHz hsync, ratio 16/9, 84 dpi)
ModeLine "1366x768" 85.5 1366 1436 1579 1792 768 771 774 798 +hsync +vsync

I have dual boot on this machine, and Windows XP have no problem getting this resolution. I read on some forums that nvidia drivers for linux don't support resolutions which can't be divided with 8, is that true?

Klaviator 04-26-09 04:04 PM

Re: Can't set the resolution of 1366x768
 
Hi!

I've got just the same problem with my GeForce FX5500 and brand new Kubuntu 9.04, using a Fujitsu Siemens Amilo L 3190T as my display:
I can set resolutions like 1360x768 and 1368x768, but there's no way to get 1366x768 working. This is really annoying, as the screen is never 100% sharp with those resolution values.

Is there any possibility to adjust the driver so I can use this resolution (it's the native res. of my display)? I'm using driver version 173.14.18, the newest one from the NVIDIA website - will this feature perhaps be added in future versions of this driver?

I already tried adding some modelines to my xorg.conf, but without success (except that I'm now able to choose the 1368 one). Is it really true, that the resolution value must be a multiple of 8?

Windows XP hasn't got any problems with offering the native display resolution, so I guess this must be some driver issue. Any ideas?

Greetings
Klaviator

bacon12 04-26-09 10:36 PM

Re: Can't set the resolution of 1366x768
 
"1366x768" 85.5 1360 1440 1552 1792 768 771 777 795 +hsync +vsync

Try using that one and see if it will work.

reseter 04-27-09 02:20 AM

Re: Can't set the resolution of 1366x768
 
put

Option "METAMODES" "DFP: 1360x765"

in the "SCREEN" section of your xorg.conf as described in

ftp://download.nvidia.com/XFree86/Li...hapter-13.html

should do it!

C7M 04-27-09 06:58 AM

Re: Can't set the resolution of 1366x768
 
The display setup in your distro doesn't work correctly anymore after you installed nvidia drivers.
You should run nvidia-settings as root, go to tab 'X Server Display Configuration' and click 'Save to X Configuration File'.
Then try restarting X, you should seen list of available resolutions in that tab.
If you don't see the resolution you need post your bug report.

Klaviator 04-27-09 03:58 PM

Re: Can't set the resolution of 1366x768
 
Thank you so much, reseter & bacon12 - I tried both of your suggestions and now it's perfect!!

(nana2)

However, I still wonder how this can be possible, as I'm running my display on a resolution named "1360x768" now, allthough image is quite sharp. Has this something to do with display frequencies forced by that modeline I added?

Greetings
Klaviator


All times are GMT -5. The time now is 12:31 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.