nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   180.50 -> 180.51 differences (http://www.nvnews.net/vbulletin/showthread.php?t=131672)

artem 04-17-09 05:22 PM

180.50 -> 180.51 differences
 
180.51 additions:
  • Fixed an interaction problem that could corrupt the EDID of the Fujitsu Technology Solutions Celsius H270 notebook's internal flatpanel.
  • Fixed a bug that could interfere with the detection of display devices attached to secondary GPUs when first starting X after cold boots.
  • Fixed a problem that could result in temporary stalls when moving OpenGL application windows on GeForce 8 and later GPUs.
  • Fixed a bug that prevented VGA fonts from being saved/restored correctly on GeForce 8 and later GPUs.

180.50 major bug is that "this NVIDIA Linux graphics driver release does not work on GeForce 6 and 7 series GPUs."

In three days two drivers releases! Viva, NVIDIA!

kernelOfTruth 04-17-09 05:43 PM

Re: 180.50 -> 180.51 differences
 
1 Attachment(s)
in addition to that it also seems to work fine in 99% of the cases

meaning:

despite the libGL.so problem still occuring it's somewhat usable now (crazy) :clap2:

perhaps the bug-report gives you guys a clue why the crashing of that apps is occuring

from what I saw it seems to happen with thunderbird and firefox (compiled) linked against cairo with glitz-support which is (still ?!) needed for compiz-fusion to work and is supposed to be fixed by re-compiling cairo without the glitz-support

besides that also multiget crashes which I've never seen crash before (due to the nvidia driver) and I don't know what role libGL.so plays in that case

I was running an xfce4 (4.6) desktop with compiz(-fusion) and emerald

interestingly kde4-apps don't seem to crash anymore (opengl compositing is enabled for those so it's good news),

I didn't have the chance to test kde4 full-blown desktop with opengl compositing (which used to crash) since currently trunk has some compilation problems and therefore I can't get it to run (pykde4 / kdebindings)

if that helps others:

I changed the USE-flag from gnome to -gnome (system-wide) and re-compiled all packages affected / whole world -> and that seemed to make a change, too (could also be placebo and due to the big changes in the new nvidia driver)

anyways :beer: thanks ! (urock)

perfectska04 04-17-09 09:31 PM

Re: 180.50 -> 180.51 differences
 
It's a bit unrelated, but since we're talking about driver differences... Do the 180.50 and 180.51 drivers have the "allows pixmaps smaller than 32x32 pixels to be placed in video memory." feature found in 185.19?

That feature has greatly improved my laptop's performance, but I'd rather use something more stable like 180.51 if that driver also has it.

kernelOfTruth 04-18-09 04:55 AM

Re: 180.50 -> 180.51 differences
 
I don't know what was different yesterday from today but I'm still (again) getting tons of those libGL.so general protection errors

besides that can anyone confirm that VirtualBox doesn't work when 180.51 is loaded ?

for me it just sat there with a window and blank (no) content

anyways I'm back to 180.29 :(

thanks

edit:

it seems to be a an specific problem to VirtualBox it also doesn't load with 180.29

version in question is 2.2.0

Dragoran 04-18-09 04:58 AM

Re: 180.50 -> 180.51 differences
 
Quote:

Originally Posted by kernelOfTruth (Post 1985870)
from what I saw it seems to happen with thunderbird and firefox (compiled) linked against cairo with glitz-support which is (still ?!) needed for compiz-fusion to work and is supposed to be fixed by re-compiling cairo without the glitz-support

It was never needed by compiz nor compiz-fusion. XGL required glitz to work but it did not require cairo's glitz backend.

kernelOfTruth 04-18-09 05:24 AM

Re: 180.50 -> 180.51 differences
 
Quote:

Originally Posted by Dragoran (Post 1986101)
It was never needed by compiz nor compiz-fusion. XGL required glitz to work but it did not require cairo's glitz backend.

unfortunately the ebuilds say something other :o,

but I'll give it a try

thanks :)

Dragoran 04-18-09 05:29 AM

Re: 180.50 -> 180.51 differences
 
Quote:

Originally Posted by kernelOfTruth (Post 1986103)
unfortunately the ebuilds say something other :o,

So they are broken.

I maintain compiz-fusion in fedora and we do not even have cairo with glitz support available ;)

kernelOfTruth 04-18-09 11:00 AM

Re: 180.50 -> 180.51 differences
 
Quote:

Originally Posted by Dragoran (Post 1986106)
So they are broken.

I maintain compiz-fusion in fedora and we do not even have cairo with glitz support available ;)

you were right something was pretty much screwed up in my system now it seems to accept cairo without glitz support

I guess this means (welcome) for me :p

so all of those dependencies are re-compiled right now ...

thanks

kernelOfTruth 04-19-09 04:24 AM

Re: 180.50 -> 180.51 differences
 
NEWS:

1) I re-compiled cairo without glitz (-glitz in its use-flags) and immediately after that cairo

2) following after that I re-compiled all of pango's and cairo's dependencies (equery d cairo; equery d pango) and now no more general protection or segfault anymore :)

so for those gtk-apps (could also be kde-apps with gnome-support compiled in) causing lots of libGL.so general protection messages in the logs and crashing (somehow being triggered by drivers from nvidia >180.29 to 180.51 right now)

this fixed it (nana2)

firefox and mozilla-thunderbird are now working fine, too (just as I posted somewhere else in this forum that compiling cairo without glitz use-flag would fix it) - no more crashing

instruction how to fix it:

those encountering those crashes and running compiz-fusion from desktop-effects overlay do the steps above (cairo without glitz; pango and cairo deps; eventually also kde-apps with gnome-support or others with gnome-support) and the following:

change:

Quote:

DEPEND="${RDEPEND}
>=dev-util/intltool-0.35
>=dev-util/pkgconfig-0.19
>=sys-devel/gettext-0.15
x11-libs/cairo[glitz]
gnome? ( gnome-base/gconf )
"
to
Quote:

DEPEND="${RDEPEND}
>=dev-util/intltool-0.35
>=dev-util/pkgconfig-0.19
>=sys-devel/gettext-0.15
x11-libs/cairo
gnome? ( gnome-base/gconf )
"
(glitz useflag dependency removed) in the compiz-plugins-extra-0.8.2 and re-digest

(ebuild compiz-plugins-extra-0.8.2 digest)

then re-emerge compiz-plugins-extra and any other remaining packages depending on cairo or pango

that should get your system in a working (non-crashing) state :nana: :naughty:

pavlinux 04-19-09 07:30 AM

Re: 180.50 -> 180.51 differences
 
Difference :)

in downgrade gtkperf on 80 points

Code:

GtkPerf 0.40 - Starting testing: Sun Apr 19 16:31:10 2009

GtkEntry - time:  0,62
GtkComboBox - time: 19,29
GtkComboBoxEntry - time: 14,97
GtkSpinButton - time:  3,61
GtkProgressBar - time:  2,26
GtkToggleButton - time:  5,83
GtkCheckButton - time:  4,65
GtkRadioButton - time:  4,97
GtkTextView - Add text - time: 105,23
GtkTextView - Scroll - time: 15,02
GtkDrawingArea - Lines - time:  4,88
GtkDrawingArea - Circles - time:  5,24
GtkDrawingArea - Text - time:  6,75
GtkDrawingArea - Pixbufs - time:  1,64
 ---
Total time: 194,96

Total time: 135,78
Total time: 154,32
Total time: 168,18


Same bench, with 180.50 - Total time: 114,52


All times are GMT -5. The time now is 02:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.