nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Do I Need To Reinstall Red Hat 9? (http://www.nvnews.net/vbulletin/showthread.php?t=13169)

Crox 06-10-03 04:08 PM

Do I Need To Reinstall Red Hat 9?
 
I have properly installed the untarred kernel and GLX. When I looked at the XF86-Config, I fel unsure because there were many entries under device about the Intel 810, so I did nothing thinking I'd come back later and take care of it after visiting a board or 2 and trying to learn what to do about the Intel 810. Now then dual boot will not boot into any kernel. I use a GRUB loader.

Do I need to re-install Red Hat 9?

LordMorgul 06-10-03 04:20 PM

If you have little experience with linux it may be your easiest option to regain a working system, if you perform an upgrade install over your system, or simply fresh install if you don't have important files to lose.

If you'd like to work on fixing it, I'm sure many here will give you a hand, but it may be a slow process over forums. First step would probably be posting here your grub config from /etc/grub.conf (or if you've created a /boot partition it should be linked to /boot/grub/grub.conf).

also, use your cd to boot into rescue mode and retrieve the boot log from a failed kernel boot, do this right after you've tried to boot into a kernel that recently worked. The boot log should be at /var/log/boot.log.

If you retrieve that log, also retrieve the XFree86 log at /var/log/XFree86.0.log and post them here. It is really impossible for anyone on a forum to help you much without access to those logs.

bwkaz 06-10-03 05:25 PM

Intel 810? Do you have an onboard video card?

If so, do you also have an nVidia video card? If not, these drivers won't work at all for you (you need nVidia hardware, and AFAIK the Intel onboard video is definitely not nVidia)...

I'm thinking, however, that you had an Intel onboard graphics chip when you installed RH the first time, then either disabled it or installed the nVidia card without disabling it. If that's the case, disable the onboard graphics from your BIOS setup screens, and comment out the 810-related stuff in XF86Config (it's not needed anymore).

Otherwise, a reinstall would (probably) fix it, and if you do install with the nVidia card in there, it won't put anything i810-related in the config file to begin with.

Crox 06-10-03 05:28 PM

Upgrade
 
Is it possible to "upgrade" to Red Hat 8.0?

Crox 06-10-03 05:39 PM

Intel 810
 
I have not installed NVIDIA card. Did not know one was required. Win XP probably uses the 810 on the dual boot.

If I can get out of the mess, I'll look at an NVIDIA card. Please help me out without a reinstall.

bwkaz 06-11-03 07:31 PM

... Why were you looking at nVidia's drivers then, if you don't have an nVidia card?

*shrug* whatever.

Anyway, you should still be able to boot to runlevel 3 (text login). At the grub menu, hit whatever key is used to edit the kernel command line (I think it's the 'e' key, but I don't use grub so I don't know for sure). Once you can edit the command line, go to the end of it and add a space and the number 3.

Hit whatever key boots that kernel (ideally, that would be enter, but as I said, I don't use grub so I don't know), and you should be able to get to a login screen. Log in as root, and delete the /lib/modules/$(uname -r)/kernel/drivers/video/nvidia.o file.

Then, try to make uninstall in the GLX package directory (if you still have it -- if not, re-decompress the GLX tarball that you used originally). If that doesn't work, then just manually delete the following files:

/usr/X11R6/lib/modules/extensions/libglx.so*
/usr/X11R6/lib/modules/drivers/nvidia_drv.o
/usr/lib/libGLcore*
/usr/lib/libGL.so.1.0-4363 and any files that are symlinks to it

(that's not everything, but it's close enough).

Then rerun /sbin/ldconfig (still as root).

Then, edit your XF86Config file to go back to using the old driver (probably "i810").

Try to start X up (with, amazingly enough, the startx command ;)). If it doesn't work, then copy /var/log/XFree86.0.log over to somewhere else and attach it to your next post. If it does work, log out of it and shutdown -r now to reboot.

Crox 06-11-03 08:41 PM

Thanks
 
Thanks for responding. I have already reinstalled Red Hat 9 & am working on fine tuning.

Best regards,

Walter


All times are GMT -5. The time now is 12:35 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.