nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Sluggish Performance and Tearing up on Linux x86_64 RHEL 5.3 (http://www.nvnews.net/vbulletin/showthread.php?t=131730)

ameza 04-19-09 09:26 AM

Sluggish Performance and Tearing up on Linux x86_64 RHEL 5.3
 
Hi all,

First, please note that benchmarking is very subjective and that I have took all possible measures to get same results... So, no flaming war on window_ manager type, Linux distribution and etc... Lets focus on the issue!

Ok, the weird performance problem is on both 180.XX and 185.XX series... I am experiencing that very weird problem on RedHat Enterprise Linux 5.3 (64bit) that make me wonder if it might be related to the NV driver on Linux.

All benchmarks that I ran, on several machines running the EXACT same NV Cards with same Driver version, point to something very fishy about the ability for the NV driver to tolerate hard X11 abuse. What I mean by abuse... Well, lets take the simple but very useful (in some very specific cases) wm_torture test from RasterMan (E Window Manager).

The result from that two part benchmarks shows the ability of a given X11 window_manager to handle LOTS of X Window creating and removal. It is measured in Window Map Response and Window Throughput per sec. Here is an example of what it gives:

Dual Xeon E5410 on Tyan Tempest i5400XT motherboard w/ 8GB RAM and Quadro FX1700 (1920x1200) (RHEL 5.3)
Quote:

$./wm_torture -t map_response -wm 5Dwm -v 1.3.1
Results for: 5Dwm - 1.3.1
Test: map_response
MIN: 0.013216s, MAX: 0.048219, AVG: 0.013934

$ ./wm_torture -t map_throughput -wm 5Dwm -v 1.3.1
Results for: 5Dwm - 1.3.1
Test: map_throughput
WIN/SEC 72.144945


So the same benchmark ran on a Dell Precision T5400 w/ 8GB RAM and Quadro FX1700 (1920x1200) (RHEL 5.3)

Quote:

Results for: 5Dwm MaXX Desktop DR3 - 1.3.1
Test: map_response
MIN: 0.006005s, MAX: 0.006804, AVG: 0.006127

Results for: 5Dwm MaXX Desktop DR3 - 1.3.1
Test: map_throughput
WIN/SEC 153.554882

This is twice as fast!!! The two systems are both using the i5400 chip-set, 64bit OS, same driver, same FX1700 and same xorg.conf settings... I tried with and without every possible tweak in the xorg.conf file... I have tried EVERYTHING to pin point the problem ! It is not a xorg.conf or system issue!

This difference is speed is also true in OPENGL based tesing (Frame per sec.). I also see some weird fluctuation in CUDA 2.1 bandwidth test sample program.. But, the smokeparticle demo runs at more that 80fps!!

I ran ramsmp benchmark test and as far as all system goes, they are properly running and configured... I am getting very FAST results !

Finally, what make me also believe that there is something wrong with the NV driver is that I am experiencing some pixels tearing-up when I drag let say a window across the Desktop... It is like if there is a timing or choking of something in the pipeline somewhere! Wish I could capture that on video...

So please help, cause I have to build 10 of those Dual Xeon systems for my customers sad.gif

I have documented that problem like mad, so documentation and logs is available on request...

Regards,

A happy NV user for a very long time

ameza 04-19-09 09:30 AM

Re: Sluggish Performance and Tearing up on Linux x86_64 RHEL 5.3
 
more on the subject...

I have a QuadCore Q6700 system that I overclock to 3.33Ghz and slow down to 2.33 to match the two Xeon based systems and I do get VERY close (almost identical) results...

I also own two ASUS 9800GTX+ that I used on all three (3) systems to test if it was a Quadro FX1700 only issue, it is not... And even more weirder, I get the same 75-/+ Win/Sec,mark with that 9800GTX+ ! Which is unrealistic since that card is twice as fast (on a gamer perspective)

thanks again!


All times are GMT -5. The time now is 12:31 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.