nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Video Haltiness Multiple Times/Second (http://www.nvnews.net/vbulletin/showthread.php?t=131822)

Quantumstate 04-21-09 09:48 AM

Video Haltiness Multiple Times/Second
I can hardly watch H.264/AVC MKV programs (transcoded from ATSC mpeg2), as multiple times/second it halts for a fraction and then resumes. One core of my 2GHz dual-core is pegged with a thread of mythfrontend, and there are two other mythfrontend threads consuming another 15% or so of the other core. I'd like to use VDPAU, although this video card is the Quadro 1600, which seems to get little benefit from VDPAU; and VDPAU is intolerant of stream problems.

I was running driver 180.44 and with that the video was halting every 5 seconds or so for a second, but on 185.19 it's gotten atrocious. (64bit) It most happens when there's lots of video information in the frame, or on pans. When at least 20% of the screen is one color I get smooth playback, as with borders or on that Nova Exxon commercial. In the terminal window where I run mythfrontend I get tons of these:

2009-04-21 07:39:24.069 NVP: prebuffering pause
2009-04-21 07:39:25.178 NVP: prebuffering pause
2009-04-21 07:39:25.743 NVP: prebuffering pause
2009-04-21 07:39:26.996 NVP: prebuffering pause
2009-04-21 07:39:27.862 [ac3 @ 0x7fd1957d87d0]frame CRC mismatch
2009-04-21 07:39:27.904 NVP: prebuffering pause
2009-04-21 07:39:28.822 NVP: prebuffering pause
2009-04-21 07:39:29.510 NVP: prebuffering pause
2009-04-21 07:39:30.474 NVP: prebuffering pause
2009-04-21 07:39:31.593 NVP: prebuffering pause
2009-04-21 07:39:32.672 NVP: prebuffering pause
2009-04-21 07:39:33.892 NVP: prebuffering pause
2009-04-21 07:39:34.346 NVP: prebuffering pause
2009-04-21 07:39:34.900 NVP: prebuffering pause
2009-04-21 07:39:35.370 NVP: prebuffering pause
2009-04-21 07:39:35.941 NVP: prebuffering pause
2009-04-21 07:39:36.311 NVP: prebuffering pause
2009-04-21 07:39:36.882 NVP: prebuffering pause

Running MythTV-fixes with VDPAU patch 20405. Myth profile is vdpau/vdpau/vdpau with interlaced Advanced1x, although the video is deinterlaced H.264/AVC HD in mkv. Deinterlaced H.264/AVC SD videos play just fine. As soon as a transcode job is done I'll post a clip. I tried to post a bugreport, but the forum complains that, "The message you have entered is too short. Please lengthen your message to at least 1 characters." WTH?


display: :0  screen: 0
API version: 0
Information string: Unknown

Video surface:

name  width height types
420    4096  4096  NV12 YV12
422    4096  4096  UYVY YUYV

Decoder capabilities:

name          level macbs width height
MPEG1            0  8192  2048  2048
MPEG2_SIMPLE      3  8192  2048  2048
MPEG2_MAIN        3  8192  2048  2048
H264_MAIN        41  8192  2048  2048
H264_HIGH        41  8192  2048  2048
VC1_SIMPLE        1  8190  2048  2048
VC1_MAIN          2  8190  2048  2048
VC1_ADVANCED      4  8190  2048  2048

Output surface:

name              width height nat types
B8G8R8A8          8192  8192    y  Y8U8V8A8 V8U8Y8A8
R10G10B10A2      8192  8192    y  Y8U8V8A8 V8U8Y8A8

Bitmap surface:

name              width height
B8G8R8A8          8192  8192
R8G8B8A8          8192  8192
R10G10B10A2      8192  8192
B10G10R10A2      8192  8192
A8                8192  8192

Video mixer:

feature name                    sup
INVERSE_TELECINE                y
NOISE_REDUCTION                  y
SHARPNESS                        y
LUMA_KEY                        y

parameter name                  sup      min      max
VIDEO_SURFACE_WIDTH              y        1    4096
VIDEO_SURFACE_HEIGHT            y        1    4096
CHROMA_TYPE                      y
LAYERS                          y        0        4

attribute name                  sup      min      max
BACKGROUND_COLOR                y
CSC_MATRIX                      y
NOISE_REDUCTION_LEVEL            y      0.00    1.00
SHARPNESS_LEVEL                  y    -1.00    1.00
LUMA_KEY_MIN_LUMA                y
LUMA_KEY_MAX_LUMA                y

Stephen Warren 04-21-09 10:04 PM

Re: Video Haltiness Multiple Times/Second
1) You definitely need to find a way to post the nvidia-bug-report.
2) If you aren't seeing any (CPU usage) benefit from VDPAU, it probably isn't actually being used. Your CPU usage supports this.
3) More recent driver releases should have solved all/most of the issues with corrupt streams. Please try 185.19. If you find any issues, please post sample clips.
4) Is your video file stored/accessed over a network? Either way, the error messages oyu posted sound like a MythTV issue.
5) Try selecting different VDPAU de-interlacers; this should make some difference if VDPAU is in fact being used.

Quantumstate 04-22-09 08:48 AM

Re: Video Haltiness Multiple Times/Second
Thanks Stephen.

1. I tried to post the bug report here again, but the forum takes me back to the edit screen with a blank message saying I can't enter a zero post. It seems it reacts to a too-large message like that. I'll try putting the bug report in its own post.

2. Indeed.

$ mythfrontend
2009-04-22 06:38:51.808 Using runtime prefix = /usr/local
2009-04-22 06:38:52.606 DPMS is active.
2009-04-22 06:38:52.607 Empty LocalHostName.
2009-04-22 06:38:52.607 Using localhost value of Hydra
2009-04-22 06:38:52.619 New DB connection, total: 1
2009-04-22 06:38:52.622 Connected to database 'mythconverg' at host:
2009-04-22 06:38:52.624 Closing DB connection named 'DBManager0'
2009-04-22 06:38:52.628 Primary screen 0.
2009-04-22 06:38:52.630 Connected to database 'mythconverg' at host:
2009-04-22 06:38:53.021 Using screen 0, 1680x1050 at 0,0
2009-04-22 06:38:53.059 New DB connection, total: 2
2009-04-22 06:38:53.062 Connected to database 'mythconverg' at host:
2009-04-22 06:38:53.068 mythfrontend version: 0.21.20080304-1 www.mythtv.org
2009-04-22 06:38:53.068 Enabled verbose msgs:  important general
2009-04-22 06:38:53.094 Connecting to lcd server: localhost:6545 (try 1 of 10)
2009-04-22 06:38:54.076 No theme dir: /home/bill/.mythtv/themes/neon-wide
2009-04-22 06:38:54.097 Primary screen 0.
2009-04-22 06:38:54.098 Using screen 0, 1680x1050 at 0,0
2009-04-22 06:38:54.100 No theme dir: /home/bill/.mythtv/themes/neon-wide
2009-04-22 06:38:54.101 Switching to wide mode (neon-wide)
2009-04-22 06:38:54.135 Using the Qt painter
mythtv: could not connect to socket
mythtv: No such file or directory
2009-04-22 06:38:54.135 lirc_init failed for mythtv, see preceding messages
2009-04-22 06:38:57.259 Loading from: /usr/local/share/mythtv/themes/neon-wide/base.xml
2009-04-22 06:38:57.693 Loading from: /usr/local/share/mythtv/themes/default/base.xml
2009-04-22 06:38:57.831 Registering Internal as a media playback plugin.
2009-04-22 06:38:57.956 MonitorRegisterExtensions(0x100, gif,jpg,png)
2009-04-22 06:38:58.054 No theme dir: /home/bill/.mythtv/themes/neon-wide
2009-04-22 06:39:04.196 XMLParse::LoadTheme using /usr/local/share/mythtv/themes/neon-wide/ui.xml
2009-04-22 06:39:04.931 Connecting to backend server: (try 1 of 5)
2009-04-22 06:39:04.933 Using protocol version 40
2009-04-22 06:39:16.412 TV: Attempting to change from None to WatchingPreRecorded
2009-04-22 06:39:17.323 DPMS Deactivated
2009-04-22 06:39:18.923 AFD: Opened codec 0x24edd40, id(MPEG2VIDEO) type(Video)
2009-04-22 06:39:18.924 AFD: codec AC3 has 6 channels
2009-04-22 06:39:18.928 AFD: Opened codec 0x5cbaca0, id(AC3) type(Audio)
2009-04-22 06:39:18.940 Opening audio device 'default'. ch 2(2) sr 48000
2009-04-22 06:39:18.941 Opening ALSA audio device 'default'.
2009-04-22 06:39:19.674 VideoOutputXv: Desired video renderer 'vdpau' not available.
                        codec 'MPEG2' makes 'opengl,xv-blit,xshm,xlib,' available, using 'opengl' instead.
2009-04-22 06:39:20.132 OSD Theme Dimensions W: 640 H: 480
2009-04-22 06:39:20.401 New DB connection, total: 3
2009-04-22 06:39:20.402 Using realtime priority.
2009-04-22 06:39:20.404 TV: Changing from None to WatchingPreRecorded
2009-04-22 06:39:20.405 Connected to database 'mythconverg' at host:
2009-04-22 06:39:20.526 Failed to approve 'vdpaubasic' deinterlacer
2009-04-22 06:39:20.526 Couldn't load deinterlace filter
2009-04-22 06:39:20.681 OpenGLVideoSync()
2009-04-22 06:39:20.702 Video timing method: SGI OpenGL
2009-04-22 06:39:22.839 Marking recording as unwatched
2009-04-22 06:39:22.840 TV: Attempting to change from WatchingPreRecorded to None
2009-04-22 06:39:22.875 ~OpenGLVideoSync() -- begin
2009-04-22 06:39:22.875 ~OpenGLVideoSync() -- middle
2009-04-22 06:39:22.875 ~OpenGLVideoSync() -- end
2009-04-22 06:39:22.974 TV: Changing from WatchingPreRecorded to None
2009-04-22 06:39:23.159 DPMS Reactivated.
2009-04-22 06:39:24.328 Deleting UPnP client...

3. I am using 185.19, and haven't been able to test any corrupted streams yet. My NX remote server has crapped out on me (HTPC is headless), so I am working on that to get some sample clips up.

4. The fact that I'm working over the network is almost certainly not at issue, as streams generally run ~1Mb.

5. I've tried Advanced 1x first and Temporal 1x first, but it seems that VDPAU isn't even being engaged for some reason.

Quantumstate 04-22-09 08:51 AM

Re: Video Haltiness Multiple Times/Second
1 Attachment(s)
Nope, the forum simply will not accept a message that large.

Hang on, I was trying to post it as <code>. Maybe I can attach...

Quantumstate 04-22-09 10:08 AM

Re: Video Haltiness Multiple Times/Second
I've managed to fix NX ('fixed' font had disappeared), and so I tried to pare down a video to make a sample clip.

Using avidemux on this DishNetwork H.264/AVC transport stream, when I try to save the edited clip it fails with:

KeyFrame error

The beginning frame is not a key frame.
Please move the A marker.
Of course you're supposed to use the double-arrow to go to the next keyframe, so I set the A marker at the beginning, double-arrow a couple times, set the B marker, and Edit|Delete. Saving still fails the same way.

I can only conclude that the double-arrow does not take you to a keyframe in H.264 and thus avidemux is not compatible with this compression.

I tried playing a second or two, stopping, and deleting before this, but that didn't work either. I don't know what to do.

Lost Dog 04-22-09 11:34 AM

Re: Video Haltiness Multiple Times/Second

When you installed the nvidia drivers did you do a full removal of the old ones? I think I remember someone in the past not doing a --uninstall and some old files were left over preventing VDPAU from initializing.

Then again, I may simply have a coffee deficiency.

Quantumstate 04-22-09 11:39 AM

Re: Video Haltiness Multiple Times/Second
Hm, I've never done an --uninstall. I thought the script takes care of that. (it should...)

Better do that now.

Lost Dog 04-22-09 11:50 AM

Re: Video Haltiness Multiple Times/Second

Originally Posted by Quantumstate (Post 1989126)
Hm, I've never done an --uninstall. I thought the script takes care of that. (it should...)

Better do that now.

Yeah, it should but I seem to remember there was one driver revision that had some issues if it was not used.

You may want to compile xine with vdpau or mplayer to see if the issue is mythtv or the vdpau layer itself.

Quantumstate 04-23-09 11:47 AM

Re: Video Haltiness Multiple Times/Second
Does anyone understand why VDPAU would not be engaged by Myth? Happens regardless of whether I'm watching ATSC mpeg2 or H.264, HD or SD, interlaced or progressive. I've recorded and uploaded a 1 minute Dish H.264/AVC test clip here:

Lost Dog 04-23-09 11:55 AM

Re: Video Haltiness Multiple Times/Second
Did you patch/compile mythtv yourself or are you using jyavenard's build?

Maybe the patches errored and you didn't catch it before compile? Did you --enable-vdpau in your ./configure?

I'm grasping at straws here....

Any luck with a xine or mplayer build with vdpau?

Quantumstate 04-23-09 12:05 PM

Re: Video Haltiness Multiple Times/Second
Build Myth myself, with the latest fixes SVN and jyavenard's latest patch plus the R5000 patch. (to record Dish) No errors with the patches, and build goes fine. Yep, --enable-vdpau, but when I run Myth it errors out of vdpau as described above. :headexplode:

Haven't attempted xine or mplayer yet as this weekend I'm ditching the last vestiges of Kubongo, in favor of Debian again as I've run for over a decade.

Lost Dog 04-23-09 08:27 PM

Re: Video Haltiness Multiple Times/Second
I just downloaded the videos and had no issues playing them in xine. The CPU sat about zero while playing them.

All times are GMT -5. The time now is 07:02 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.