nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Quadro FX5600 G-sync II issues. (http://www.nvnews.net/vbulletin/showthread.php?t=132177)

b_i_s_c_u_i_t_s 04-29-09 06:30 AM

Quadro FX5600 G-sync II issues.
I run a cluster of Sun Ultra 40 M2's with 2x2 quad core AMD64, nominally running RHEL5.3, through christie s+3k projectors at 1400x1050x102 with g-sync and crystal eyes.

The graphics are NV Quadro X5600 1.5Tb PCIx I think, single slot, single card, single output to the projectors over VGA.
The dins go to the projectors, and then daisy chain out into the emitters for the IR crystaleyes (5 high range).

Whole system works (ish) with a creeping problem effecting lock across some screens in RHEL5.3. I have diagnosed this as a g-sync framelock issue so I've been working on that.

Two of the systems were refusing to bring up nvidia's control panel, but I could get green lights (across the five screens I'm using) for timing and sync with a server and clients for framelock.. All well and good, but there was clearly still a problem since one screen or another wouldn't be locked at any given time.

With this as the background to the situation, and this driver
NVRM version: NVIDIA UNIX x86_64 Kernel Module 173.01 Development Build (rel/gpu_drv/r173/r173_00-9684) (2252897) (buildmeister@builder62) Thu Feb 21 10:41:56 PST 2008

I opted to update across the system to
NVRM version: NVIDIA UNIX x86_64 Kernel Module 177.70.35 Fri Feb 27 13:11:43 PST 2009

brought up all the nvidia settings panels; still two crashed, so I used

nvidia-settings -c localhost:0 -a localhost:0/FrameLockEnable=1

(from memory) and got green lights on all but stereo (expected since not in stereo at the time?)

then ran up my usual openscenegraph demo and got no shuttering or sereo. It's quadbuffering, but not 3D. The glasses seem to be doing something. Switching intermittently darker too. Not sure...

Next I copied back the old xorg.conf with the christie projector info back over, reset X and tried again.

Still not working.

By now I'm feeling stupid, and a little lost. I seem to be on a bit of a losing streak. Can anyone help with this?

Here's my current xorg.conf, which includes the 'composite disable' which I know causes problems for some.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Fri Feb 27 13:39:43 PST 2009

#Section "Device"
# Identifier "Videocard0"
# Driver "nvidia"
# VendorName "NVIDIA Corporation"
# BoardName "Quadro NVS 110M"

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"

Section "ServerFlags"

# Removed Option "Xinerama" "1"
Option "Xinerama" "0"
Option "BlankTime" "35790"
Option "StandbyTime" "35790"
Option "SuspendTime" "35790"
Option "OffTime" "35790"

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "gb"
Option "XkbModel" "pc105"

Section "Modes"

# Generated using: gtf 1400 1050 112
# 1400x1050 @ 112.00 Hz (GTF) hsync: 125.44 kHz; pclk: 241.85 MHz
Identifier "Modes0"
ModeLine "1400x1050_112.00" 241.85 1400 1512 1664 1928 1050 1051 1054 1120 -hsync +vsync
# Generated by umc:
ModeLine "1400x1050_102.00" 219.664752 1400 1512 1664 1928 1050 1054 1058 1117 -hsync +vsync
# Generated by umc:
ModeLine "1400x1050_96.00" 206.002944 1400 1512 1664 1928 1050 1054 1058 1113 -hsync +vsync
# Generated using: gtf 1400 1050 72
# 1400x1050 @ 72.00 Hz (GTF) hsync: 78.77 kHz; pclk: 149.34 MHz
ModeLine "1400x1050_72.00" 149.34 1400 1496 1648 1896 1050 1051 1054 1094 -hsync +vsync

Section "Monitor"

# Option "DPMS"
Identifier "Monitor0"
VendorName "Christie"
ModelName "Mirage"
UseModes "Modes0"
HorizSync 31.0 - 120.0
VertRefresh 24.0 - 150.0

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 5600"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "3"
SubSection "Display"
Depth 24
Modes "1400x1050_102.00"

Section "Extensions"
Option "Composite" "Disable"

b_i_s_c_u_i_t_s 04-30-09 05:44 AM

Re: Quadro FX5600 G-sync II issues.
tentative bump...

b_i_s_c_u_i_t_s 05-07-09 08:09 AM

Re: Quadro FX5600 G-sync II issues.
OK, I've done an upgrade across the first 5 systems to 64 bit 180.29, which detects the gsync and gives me green lights.
I have to admit to having total ignorance of how the stereo settings are managed under linux. I took delivery of a (as described) buggy pre-installed system.

I'm stuck now because stereo shuttering still isn't working. My cards seem to be nvidia badged reference cards in SUN boxes, so there's no direct support channel I can follow.

Projector timings in the Xorg seem ok, everything is plugged in, the din connector should feed to the shutterglasses, but I have a nagging doubt that there's an options file somewhere that I missed with the last update, and will still be set wrong now. Can anyone suggest the 'usual things' list that I should look to ensure everything is in place for stereo shuttering over din?


b_i_s_c_u_i_t_s 06-11-09 05:25 AM

Re: Quadro FX5600 G-sync II issues.
Well, I'm now on 185.18.14, with the same funky slow frame rate, and lack of stereo signal on the din line... I'm bereft of ideas..

Thankfully nvidia are supporting me directly now, so I have high hopes, but if anyone has any ideas that'd be great.

b_i_s_c_u_i_t_s 09-28-09 05:42 AM

Re: Quadro FX5600 G-sync II issues.
in the end I got an FPGA (with programmer) upgrade to the g-sync's from NVIDIA, which is great, but I still have a slow framerate. What's a test I can do to try to pin this down?

All times are GMT -5. The time now is 10:59 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.