nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Framelock Setup Problems (http://www.nvnews.net/vbulletin/showthread.php?t=132223)

karl.cary 04-30-09 05:25 AM

Framelock Setup Problems
I am having problems setting up framelock with my Qudro FX4800 cards. The problem is twofold:

18 machines each with:
Quadro FX4800 Card
G-Sync II Option Card
CentOS 5.2 32 bit
NVidia driver 180.29
Twinview with output 0 analog and output 1 digital
1400x1050@60 HZ Resolution

Problem 1: Initial Setup
When we go to the nvidia-settings control panel, there is no Framelock window available. Running the command line query for FrameLockEnabled returns that it is not available. From everything we have seen in the manuals and online, there shouldn't be anything else we need to get this available. What are we missing? Is there some type of Xorg flags we have to set or X configuration that has to be set up? The only glimmer of a clue I have been able to find was from this post back in 2006 about Disabling TCP in gdm, which I will be trying later today: http://www.nvnews.net/vbulletin/showthread.php?t=65715

Problem 2: Configuration Files
All 18 of these systems will be booting diskless. We already have a firm system in place for configuration prior to X booting so switching out the proper configuration file so that only one machine is labelled as the master and all the others are joined to the framelock group is not a problem. The problem though is what file(s) do we need to change for this? Where are the settings from the framelock stored at?

Thank you all for looking at this.

b_i_s_c_u_i_t_s 04-30-09 05:42 AM

Re: Framelock Setup Problems
on my systems I had the same problem and ended up with version 177 drivers which support G-Gync, and have the panel, but then lost stereo, as per this post


I think it's possible we're alone on this one as I've shotgunned all the forums and not got anything back yet. Perhaps we can assist one another..

karl.cary 04-30-09 07:24 AM

Re: Framelock Setup Problems
So simply changing the nvidia driver allowed you to see the framelock panel? Unfortunately we are running 32 bit s using that same driver is not an option, but I guess I will go start downloading different drivers and keep trying until I find one that works.

With our we are not going to be using stereo. This is basically for a video wall with overlapping projectors where the output needs to be synced across all machines.

bugspray 04-30-09 09:07 AM

Re: Framelock Setup Problems
Framelock/Genlock support keeps drifting in and out of Nvidia's drivers. The latest cycle seems to be that the GSync card is detected in drivers 177 through 180.29; it disappears in 180.35 and doesn't appear till version 185.18.04. It's possibly sunspot related.

Quadro FX 5600 - GSync detected with 64 bit 180.29.

b_i_s_c_u_i_t_s 04-30-09 12:42 PM

Re: Framelock Setup Problems
terrific, thanks, I'm upgrading now to see if that helps matters.

b_i_s_c_u_i_t_s 04-30-09 01:39 PM

Re: Framelock Setup Problems
OK, I've done a remote upgrade across the first 5 systems, which is enough to test on, but I have to admit to having total ignorance of how the stereo settings are managed under linux. I took delivery of a (as described) buggy pre-installed system. I'll head in tomorrow and fire up the demo, but just to maximise my chances of it succeeding, can anyone suggest the 'usual things' list that I should look into over my remote connection to ensure everything is in place?

Projector timings in the Xorg seem ok, everything will be plugged in, the din connector should feed to the shutterglasses, but I have a nagging doubt that there's an options file somewhere that I missed with the last update, and will still be set wrong now.


karl.cary 05-05-09 08:18 AM

Re: Framelock Setup Problems
Alright so update time. We switched back to the 177 drivers and the framelock panel is there now. After contacting nvidia support and figuring some things out we found out that we will need to configure via the command line to setup everything at startup for us. In doing this we were unable to add anything other than :0.0. Well we found out that there were 2 things stopping us. First is that you need to stop gdm from blocking all X display requests. We did this by adding the line
under the [security] section of /etc/gdm/custom.conf. Second, you need to have xhost setup to accept the server. For right now we are simply doing xhost + but will probably change this to simply adding the servers explicitly to the list of trusted hosts in xhost. There is probably also a better way for that disallowTCP thing, but it works for now. Just note that this has the potential to be a big security hole.

karl.cary 05-10-09 01:50 PM

Re: Framelock Setup Problems
So we are able to setup framelock using the GUI just fine. Everything syncs up as it should and all is good. However we are trying to set it up via the command line so that we can have system configure itself automatically once it all comes up. This fails miserably. If I run the command nvidia-settings -q myserver:0/FrameLockMasterable where myserver is the hostname of my server machine, it returns absolutely nothing. Not true not false, just nothing. What is supposed to be shown here, both if it fails and if it succeeds? I would expect something.

Then when I do nvidia-settings -a myserver:0/FrameLockMaster=0x00000001 to setup CRT-0 as the master, it returns a glibc error. All the previous steps to getting to this point succeed no problem. I can query all of the slave machines and disable framelock on them and everything. It is just setting up the master. And if I go into the gui and assign the master, then I can successfully use the command line to add all the slaves. Is it possible that there is a bug in the driver command that is failing?

I am going to do some more testing and have a whole bunch more information tomorrow when I gain access to the system again.

AaronP 05-10-09 05:00 PM

Re: Framelock Setup Problems
Hi Karl,

You might have better luck emailing linux-bugs@nvidia.com. I don't think the framelock experts hang out on this forum.

b_i_s_c_u_i_t_s 05-11-09 05:19 AM

Re: Framelock Setup Problems
I'm going to try this out for you later on my very similar system, see if I get the same result. I need to wait for some demos in windows to clear first. I'll let you know. If we both have the same problem with different OS's and cards then there's a stronger case to put to nvidia's bugs team I guess.

b_i_s_c_u_i_t_s 05-11-09 07:13 AM

Re: Framelock Setup Problems
nvidia-settings -c=0:0 -q localhost:0/FrameLockMasterable

just come straight back with no error. I'm gonna get all my nvidia-bug files in order and start running this through support. Will keep you posted.

karl.cary 05-13-09 09:11 PM

Re: Framelock Setup Problems
How about when you did a nvidia-settings -a myserver:0/FrameLockMaster=0x00000001 like command? Setting a frame lock master and enabling the test signal via the command line are both returning with the same error for me. If I could enable to the test signal then I could still do it via script by setting up the nvidia-settings-rc. But as it stands now I can set up everything via the rc file and then open the GUI and hit the enable frame lock button.

All times are GMT -5. The time now is 08:14 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.