nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   No HDMI sound on GT 120 with 185.18.08 and 180.44 (http://www.nvnews.net/vbulletin/showthread.php?t=132718)

heiko_jakob 05-09-09 09:19 AM

No HDMI sound on GT 120 with 185.18.08 and 180.44
 
2 Attachment(s)
Hi i can't get HDMI audio on my nvidia GT 120 to work.
I tried almost everythig i could, but without any success.

Anybody can help me with that issue or do the needed drivers simply not exist ?

Regards
Heiko Jakob

HW info:
Asus Aspire X1700
NVidia MCP73 chipset
GeForce GT 120

SW Info:
ubuntu 9.04 ($ uname -a
Linux quark 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux)
alsa:
1.0.18 (ubuntu package) and 1.0.19 (Realtek linux_drivers-5.11) --> both don't show any HDMI audio device. At least 1.0.19 shows me the digital output of the ALC888.
nvidia drivers:
180.44 (ubuntu package) and 185.18.08 ( NVIDIA-Linux-x86_64-185.18.08-pkg2.run ) --> both don't give me a HDMI audio device

My latest configuration is nvidia driver 185.18.08 and realtek alsa 1.0.19.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
heiko@quark:~$ aplay -L
default:CARD=NVidia
HDA NVidia, ALC888 Analog
Default Audio Device
front:CARD=NVidia,DEV=0
HDA NVidia, ALC888 Analog
Front speakers
surround40:CARD=NVidia,DEV=0
HDA NVidia, ALC888 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
HDA NVidia, ALC888 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
HDA NVidia, ALC888 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
HDA NVidia, ALC888 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
HDA NVidia, ALC888 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
HDA NVidia, ALC888 Digital
IEC958 (S/PDIF) Digital Audio Output
null
Discard all samples (playback) or generate zero samples (capture)

heiko_jakob 05-09-09 09:36 AM

Re: No HDMI sound on GT 120 with 185.18.08 and 180.44
 
Oh.
I almost forgot: It works fine on Windows so it must be a software problem.

Regards
Heiko

heiko_jakob 05-09-09 12:44 PM

Re: No HDMI sound on GT 120 with 185.18.08 and 180.44
 
Update

now i've upgraded to a vanilla 2.6.29.3 kernel and alsa 1.0.20 --> Still does'nt work.
But now i can load a module called 'snd-hda-codec-nvhdmi' which changes absolutely nothing for me :-(
All new sw install --> Still does'nt work.

Regards
Heiko

heiko_jakob 05-09-09 01:21 PM

Re: No HDMI sound on GT 120 with 185.18.08 and 180.44
 
Problem SOLVED !!!

The Acer Aspire X1700 simply loops the ALC888 SPDIF to the HDMI Port.
Using the SPDIF as output device results in working HDMI audio.
It finally works :-)

Regards
Heiko


All times are GMT -5. The time now is 12:12 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.