nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   The infamous Error inserting nvidia No Such Device (http://www.nvnews.net/vbulletin/showthread.php?t=133129)

daver208 05-19-09 11:39 AM

The infamous Error inserting nvidia No Such Device
 
1 Attachment(s)
I've tried searching, and though it seems to be a common problem, there doesnt appear to be any solutions. Anyway for reference,

Intel Q6600, 4 GB ram, Evga 9800 gt 1Gb, ubuntu 8.10 x64

Tried using the ubuntu prompted proprietary drivers, but upon reboot , x would crash. So i downloaded the most recent stable version 180.51 and installed. I had to use the script with -k $(uname -r) to get the script to build the kernel module, but thats par for the course. I've tried this with both a previous install, and a fresh install.

Since that time i have tried 180.44, as well as 185.18.08, all with no luck. The installer finishes in each case, but upon reboot it fails to load the kernel module.

A sudo modprobe nvidia results in
FATAL: Error inserting nvidia (/lib/modules/2.6.27-14-generic/kernel/drivers/video/nvidia.ko): No such device

When you look in /var/log/kern.log I noticed the following

NVRM: The NVIDIA GPU 01:00:0 (PCI ID) 10de:0605 installed in this system is not supported by the 180.51 NVIDIA Linux graphics driver release. Please see appendix A - Supported Nvidia GPU products in this releases README......

After checking appendix A it does in fact report that the 9800 GT 0605 IS Supported... I know you can discover all that from the attached log, but I thought it might help someone searching the forums....

Thanks,

Dave

zander 05-19-09 12:20 PM

Re: The infamous Error inserting nvidia No Such Device
 
It looks like two of the GPU's BARs have not been setup correctly and/or confuse the kernel:
01:00.0 VGA compatible controller: nVidia Corporation Device 0605 (rev a2)
Subsystem: eVga.com. Corp. Device c981
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at 12a000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at 128000000 (64-bit, non-prefetchable) [size=32M]
I/O ports at dc80 [size=128]
Expansion ROM at 12b000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 3
Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel <?>
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information <?>
Kernel modules: nvidiafb, nvidia
00: de 10 05 06 07 00 10 00 a2 00 00 03 10 00 00 00
10: 00 00 00 2a 0c 00 00 d0 00 00 00 00 04 00 00 28
20: 01 00 00 00 81 dc 00 00 00 00 00 00 42 38 81 c9
(...)
BAR0, located @ 0x12a000000 according to the kernel, is located @ 0x2a000000, as far as the GPU is concerned (see the BAR0 register @ 0x10 in PCI configuration space). BAR2 is located @ 0x128000000, which is illegal since it's a non-prefetchable BAR (the non-prefetchable memory-behind-bridge registers of upstream bridges cannot support ranges above 4GB).

BAR0 and BAR2 (of current NVIDIA GPUs) need to be located below the 4GB boundary. The BAR1 placement above is fine, provided a 185.18.xx or more recent NVIDIA Linux graphics driver release is used.

daver208 05-22-09 08:59 AM

Re: The infamous Error inserting nvidia No Such Device
 
So I've found reference to this here

https://bugs.launchpad.net/linux/+bug/342926

First of all I'm not certain how to fix this beyond removing 2 GBytes of RAM which isnt an option. Unfortunately this a work PC so the BIOS is anything but extensive so I cant try that work-around. That seems to leave patching the kernel, but they keep mentioning a 256 MB and 512 MB NRVM patch..... Anyway, not knowing what they do, since my card is a 1 Gbyte card 1) will it work? 2) Is this even a viable option? If you have answers I'd appreciate if not I'll go fishing in the forums this weekend.

Thanks,

Dave

zander 05-22-09 11:20 AM

Re: The infamous Error inserting nvidia No Such Device
 
I suppose you could try the 512MB patch (see http://www.nvnews.net/vbulletin/show...1&postcount=24). You should probably check for an updated SBIOS first, though.


All times are GMT -5. The time now is 05:41 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.