nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   185.18.14 Video strange colors (http://www.nvnews.net/vbulletin/showthread.php?t=133613)

Kosimo 05-28-09 08:45 AM

185.18.14 Video strange colors
 
Hello guys, here using Ubuntu Jaunty 9.04 and nVidia 185.18.14 on a Geforce 8400m GT. Everything works perfectly except videos, which all of them have strange colors.
No matter what video player I use, but colors are broken. I've nevr had this problem with any previous release.


Any suggestion?


Thank you

Kosimo 05-28-09 08:58 AM

Re: 185.18.14 Video strange colors
 
1 Attachment(s)
Adding the bug report

Kosimo 05-28-09 09:23 AM

Re: 185.18.14 Video strange colors
 
Here a screenshot of my video output

http://kosimo.googlepages.com/tv3.jpg

Stephen Warren 05-28-09 10:20 AM

Re: 185.18.14 Video strange colors
 
The Xv color adjustments probably are set incorrectly. Run nvidia-settings, go to the "X Server XVideo Settings" page, and adjust the sliders appropriately.

Kosimo 05-28-09 01:42 PM

Re: 185.18.14 Video strange colors
 
Quote:

Originally Posted by Stephen Warren (Post 2017003)
The Xv color adjustments probably are set incorrectly. Run nvidia-settings, go to the "X Server XVideo Settings" page, and adjust the sliders appropriately.

Thanks for answering, but this is not the reason. All levels are default, and by changing them doesn't fix the problem. Here two screenshots.


http://kosimo.googlepages.com/videoerror1.png


http://kosimo.googlepages.com/videoerror2.png

magicmyth 05-28-09 02:33 PM

Re: 185.18.14 Video strange colors
 
Looks like the hue is set wrong. I had a similar issue at one point. Try entering this command into your console:
Code:

xvattr -a XV_HUE -v 0
That will change XV colors on all video apps using it. Odd that changing the values in nvidia-settings did not work for you as that has also fixed my problem in the past.

Stephen Warren 05-28-09 04:34 PM

Re: 185.18.14 Video strange colors
 
It's also possible that the video application itself is manipulating the Xv attributes; check if your application has an internal mechanism to control this.

Kosimo 05-28-09 05:18 PM

Re: 185.18.14 Video strange colors
 
Quote:

Originally Posted by Stephen Warren (Post 2017329)
It's also possible that the video application itself is manipulating the Xv attributes; check if your application has an internal mechanism to control this.

The problem is solved by removing and installing 180.60. Is not an application problem as it happens only using 185.18.14 and also with all video applications, Movie Player, VLC, mplayer...

Now I'm gonna try what magicmyth suggested

dlknight 06-12-09 03:08 PM

Re: 185.18.14 Video strange colors
 
I'm also seeing this on Fedora 10 with Mythtv trunk and software rendering, switching to VDPAU the colours are normal. I have gone back to 180.60 for now.

Stephen Warren 06-12-09 03:19 PM

Re: 185.18.14 Video strange colors
 
Quote:

Originally Posted by Kosimo (Post 2017377)
Now I'm gonna try what magicmyth suggested

Did this help?

If not, can you try using MPlayer again. Specifically, which of the following have the issue:

-vo x11
-vo xv
-vo gl
-vo vdpau

In all cases (even VDPAU), please use SW decoding (e.g. use -vc ffmpeg12 but not either -vc ffmpeg12mc or -vc ffmpeg12vdpau).

Thanks.


All times are GMT -5. The time now is 03:02 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.