nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupts (http://www.nvnews.net/vbulletin/showthread.php?t=133632)

thefirstm 05-28-09 02:37 PM

[regression] Suspend/resume will not work when using 185.18.14 with MSI interrupts
 
1 Attachment(s)
I recently upgraded to the 185.18.14 drivers, and now Resuming from suspend will not work when MSI interrupts are enabled. My card is a GeForce 8600m GT in a Dell Vostro 1500 running Kubuntu 9.10 (development). With regular interrupts, resume continues to work fine.

thefirstm 05-28-09 03:07 PM

Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt
 
2 Attachment(s)
Here are a dmesg and Xorg.0.log taken after the failed resume. (The system still resumes, even though displaying nothing on the screen, so I can SSH in and get the logs.) In the dmesg it says something about uvesafb, which I am using, but even when I use regular textmode the problem still occurs.

cthulhu 05-29-09 03:56 AM

Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt
 
I think the good folks at nvidia would appreciate a bugreport, as described in the sticky...

thefirstm 05-29-09 04:27 AM

Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt
 
Already got one. Its in the Original Post. I just added the second post with more diagnostic data I thought might be useful.

cthulhu 05-29-09 07:32 AM

Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt
 
Doh! It is, sorry I missed that. :headexplode:

Haggy 05-29-09 03:27 PM

Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt
 
Quote:

Originally Posted by thefirstm (Post 2017227)
With regular interrupts, resume continues to work fine.

I have this since i built my current rig with an nvidia 8300 chipset. on resume sata controller (in ahci mode) spits errors like hell and afterwards all filesystem are mounted readonly. using pci=nomsi fixes this. On recent 2.6.29 kernels, using 180.xx drivers those sata errors even appear after a few minutes i leave the machine running, but ONLY if X is running and ONLY if msi interrupts are used. There's a whole thread dealing with this problem, so nvidia please have a look at this, thanks!

ledoc 06-01-09 06:01 PM

Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt
 
Thanks for the heads up. Definitely a big NO GO!


All times are GMT -5. The time now is 06:32 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.