nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Color Profiles Messed-Up for Videos (http://www.nvnews.net/vbulletin/showthread.php?t=133810)

Quantumstate 05-31-09 11:10 AM

Color Profiles Messed-Up for Videos
 
Whenever I watch a video on my projector, whether it's in Kaffeine or Myth, the color profile is messed-up. Red and green are switched, and blue and yellow are switched. My KDE desktop is fine, and when I watch videos in a flat-panel on the same HTPC, same video card, the colors are fine. AND when I watch a video in Myth using the VDPAU profile the colors are fine.

- Colors seem to be derived differently in videos, than for the desktop.
- Colors seem to be derived differently in VDPAU, than software rendering.
- Color profiling seems to be different for the projector, than for regular terminals.
- My projector (Planar PD8150) has four different color spaces you can set, plus Auto. When I set it to REC709 or REC601 the whole desktop goes into the screwy colors; however RGB-PC is fine but bright, and RGB-Video is fine but dark. So I suspect this has something to do with the projector's color profiling and its interaction with X.
- Driver 185.18.10

Any ideas?

Quantumstate 06-02-09 08:22 AM

Re: Color Profiles Messed-Up for Videos
 
Does anyone understand the difference between how color for video is derived, vs how color for the desktop is?

dlknight 06-12-09 02:55 PM

Re: Color Profiles Messed-Up for Videos
 
I get colour problems using software rendering with any driver higher than 180.51. I'm using Mythtv trunk also seeing interlacing issue on video playback which doesn't occurr with 180.51.

Haven't the time at the moment to do a bug report so going to revert back to old driver again...

Maybe this will solve your projector issue too.

Stephen Warren 06-12-09 03:14 PM

Re: Color Profiles Messed-Up for Videos
 
You're probably using the Xv API for videos when not using VDPAU. Can you try using the Xv color adjustment controls in either your video player SW, or nvidia-settings. This should fix it.

dlknight 06-13-09 12:47 PM

Re: Color Profiles Messed-Up for Videos
 
Quote:

Originally Posted by Stephen Warren (Post 2028293)
You're probably using the Xv API for videos when not using VDPAU. Can you try using the Xv color adjustment controls in either your video player SW, or nvidia-settings. This should fix it.

Hi Stephen,

Yes I'm using Xv, running "Nvidia X Server Settings" resolved the issue straight away without me having to change anything apart from saving the new configuration.

After inspecting the old and new configuration files the only setting that has changed is below (which kind of makes sense), any idea why this changed between driver versions?

OLDCONFIG - 0/XVideoTextureSaturation=4096

NEWCONFIG - 0/XVideoTextureSaturation=0

Many Thanks,

Dave K (now running up to date driver 185.18.14).

AaronP 06-13-09 01:30 PM

Re: Color Profiles Messed-Up for Videos
 
We changed some of the Xv attribute ranges due to persistent problems with certain video players getting the defaults wrong.


All times are GMT -5. The time now is 05:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.