nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Cannot install the 180.51/60 drivers under 2.6.29.4 (http://www.nvnews.net/vbulletin/showthread.php?t=133843)

anonmys 06-01-09 09:45 AM

Cannot install the 180.51/60 drivers under 2.6.29.4
 
I am currently running debian testing (squeeze), kernel 2.6.29.4 (vanilla from kernel.org). My motherboard has an integrated graphics card : GeForce 6150SE nForce 430

The 180.51 driver was working well, and for some strange/unknown reason stopped working since last night. I tried recompiling/reinstalling the driver and failed. Checked the site and found a new driver release (180.60). When I tried installing, I get the same error. I am pasting it here :

<a big snip>
...
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Post-install sanity check passed.
-> Shared memory test passed.
-> Running runtime sanity check:
ERROR: The runtime configuration check failed for the library
'libnvidia-tls.so.180.60' (expected: '/usr/lib/tls/libnvidia-tls.so.1',
found: '/usr/lib/libnvidia-tls.so.1'). The most likely reason for this
is that conflicting OpenGL libraries are installed in a location not
inspected by `nvidia-installer`. Please be sure you have uninstalled
any third-party OpenGL and/or third-party graphics driver packages.
-> done.
-> Runtime sanity check failed.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

Can someone give me pointers to get this working?

Regards

sridhar

klemperal 06-01-09 04:01 PM

Re: Cannot install the 180.51/60 drivers under 2.6.29.4
 
Have you tried purging the old driver?
Code:

Sudo aptitude purge nvidia-glx

anonmys 06-01-09 07:52 PM

Re: Cannot install the 180.51/60 drivers under 2.6.29.4
 
Quote:

Originally Posted by klemperal (Post 2020735)
Have you tried purging the old driver?
Code:

Sudo aptitude purge nvidia-glx

Maybe I did not make myself clear. I am not using nvidia-glx from the debian repos. I always use the driver downloaded from the nvidia site and install it.

Regards,

anonmys 06-01-09 09:43 PM

[SOLVED]Re: Cannot install the 180.51/60 drivers under 2.6.29.4
 
I upgraded the xserver to that in unstable. After that, the compilation/installation went off well and I am able to get back my working X.

Thanks for the help.

Regards,

sridhar

tadawson 06-01-09 10:12 PM

Re: Cannot install the 180.51/60 drivers under 2.6.29.4
 
I had that problem not that long ago. I simply removed the library file it was complaining about and all links to it, and reinstalled cleanly.

- Tim

anonmys 06-02-09 01:31 AM

Re: Cannot install the 180.51/60 drivers under 2.6.29.4
 
Quote:

Originally Posted by tadawson (Post 2021026)
I had that problem not that long ago. I simply removed the library file it was complaining about and all links to it, and reinstalled cleanly.

I tried that before positing it here :-) It did not work for me. The strange thing is the installer was creating the tls directory and putting the files that it complains about later. Anyway, I am happy that it could be solved bu upgrading to a later version of xorg.

Regards,

sridhar

tadawson 06-02-09 08:45 PM

Re: Cannot install the 180.51/60 drivers under 2.6.29.4
 
Quote:

Originally Posted by anonmys (Post 2021135)
I tried that before positing it here :-) It did not work for me. The strange thing is the installer was creating the tls directory and putting the files that it complains about later. Anyway, I am happy that it could be solved bu upgrading to a later version of xorg.

Regards,

sridhar

Make sure that there aren't any lingering links, either. Basically, if it says "nvidia" in it in the X library area, it probably needs to go bye-bye before you install . . .

- Tim


All times are GMT -5. The time now is 12:10 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.