nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   180.44 Interupts problem on 2.6.30-rc8 (http://www.nvnews.net/vbulletin/showthread.php?t=134183)

dbbolton 06-08-09 06:15 AM

180.44 Interupts problem on 2.6.30-rc8
 
1 Attachment(s)
I used the kernel source from the Ubuntu Jaunty package nvidia-180-kernel-source to build a module for my custom kernel. First, I applied this patch to the source:

http://www.nvnews.net/vbulletin/showthread.php?t=131597

Then I booted my kernel in single user mode, cd'ed into the source directory, ran 'make module', 'module install', and 'modprobe -v nvidia'. I didn't see any errors. I booted into the normal runlevel after that but got this error from X:

Code:

(II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen" for depth/fbbpp 24/32
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):    enabled.
(EE) NVIDIA(0): The NVIDIA kernel module does not appear to be receiving
(EE) NVIDIA(0):    interrupts generated by the NVIDIA graphics device
(EE) NVIDIA(0):    PCI:1:0:0.  Please see Chapter 8: Common Problems in the
(EE) NVIDIA(0):    README for additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

So I checked the readme:

Code:

This can be caused by a variety of problems, such as PCI IRQ routing errors,
I/O APIC problems or conflicts with other devices sharing the IRQ (or
their drivers).

If possible, configure your system such that your graphics card does not
share its IRQ with other devices (try moving the graphics card to another
slot if applicable, unload/disable the driver(s) for the device(s) sharing the
card's IRQ, or remove/disable the device(s)).

Depending on the nature of the problem, one of (or a combination of) these kernel parameters might also help:
Parameter        Behavior
pci=noacpi        don't use ACPI for PCI IRQ routing
pci=biosirq        use PCI BIOS calls to retrieve the IRQ routing table
noapic        don't use I/O APICs present in the system
acpi=off        disable ACPI

This didn't really help me. I tried adding all four boot options in Grub but that ended up in the same result.

Attached is my bug report file.


All times are GMT -5. The time now is 03:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.