nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nvnet 1.0-0261 / A7N266-VM (http://www.nvnews.net/vbulletin/showthread.php?t=13423)

[)eacon]ndigo 06-15-03 12:13 PM

nvnet 1.0-0261 / A7N266-VM
Running Redhat 9

I installed the nforce-1.0-0261 modules and got horrible performance problems when the Ethernet port was being accessed. Mouse pointer movement was really jerky while the net was being accessed and my website which is served out of this machine was very slow to serve pages (the site does a lot of disk I/O which also seemed to be severely interrupted by network data I/O). The problem went away for a brief time during a long download but quickly returned the next time I loaded a web page.

This problem occured with several Kernel versions up to, and including, 2.4.21.

Now I'm using the nvaudio from 0261 with the nvnet 0256 whith Kernel 2.4.21 and things seem back to normal, but I wonder why the hiccuppy performance with nvnet 0261 and/or has anyone else seen this sort of problem?

bshock13 06-16-03 12:09 AM

yeah i have the same board with redhat 9.0 and have the same problems with 0261 drivers also. I just switched back to the 0256 ones and dont' have that problem anymore? anyone have any ideas, id like to know.

Macrohard 06-27-03 11:10 AM

I have the same board and RH9. However, I can't even get RH to recognize that I have the card on my computer, and thus any connection it uses cannot be activated. I can't access the Internet or my network and it really pisses me off. I have tried both the RH9 .rpm and the Tar ball. The RH9 .rpm (when installed) gives the error:

"nvnet device eth0 does not seem to be present, delaying initalization"

The Tar ball gives numerous errors in its making/compilation and for some reason does not create the nvnet.o file needed to use the card.

Please reply promptly; this is very urgent (primarily b/c I hate using Windows)

...and yes, I am a n00b, so plz don't be harsh.

Hallgeir Lied 07-06-03 02:56 AM

Performance problem with nvnet
I have recently assembled a new computer for the living room based on the Asus A7N266-VM/LAN motherboard. I have tried Knoppix where I could never get the built-in NIC to work although I installed the Nvidia unified driver. After that I am now trying Redhat 9 with the unified driver version 261. I got the same horrible performance as described in this thread. The bad performance was the same with kernels 2.4.20-8 and the upgrade 2.4.20-18.9. The computer was acting as if it was partly frozen whenever the net was being accessed through the nvnet driver. I have now inserted an SMC PCI NIC with a Realtek 8139 chip, and everything works fine. It is irritating though that the built-in NIC on the motherboard does not work well. I urge Nvidia to release information about their hardware so that reliable drivers can be made by the OSS movement, or release their existing drivers as GPL so that drivers can be included in the kernel source and quality controlled by the OSS community.

Daz 07-11-03 09:50 PM

I use the same MB ..with Mandrake 9.1.
I can not get the on board NIC to work.
I seem to have multiple "unknown modules" in most mother boards systems, preventing most things from working.
Although the Gui runs up nice...
I thought I would be smart and get a all in one MB to run a web server with linux... DOH

Botond 11-29-03 04:00 AM

Hi All,
try this in your /etc/modules.conf file and the ...0261 network driver will work fine:
options nvnet optimization=1

(I had the same problem you described above, but now a 2.4.23-rc5 kernel works smoothly with A7N266-VM).
For other valid options see the README file on the driver's page.

dnoyeB 12-21-03 08:00 AM

I been fighting this for about 12 hours straight.

Choppy mouse, file transfers slow to a crawn, unless I insipre some network traffic, then they come back to life. Computer is unuseable when the network is active.

I tried haparm, new kernels, tweeking samba heavily. Finally this stupid NVIDIA driver. How can they not know it breaks RH9 when they specifically make changes for RH9!?!?!

Anyway, I had to get the 256 driver, and plug the nvnet directory into the 261 since the 256 compile does not work on RH9.

Hey look! thats the fix they claimed they put into 261, but I guess not..

Anyway, rockin and rolling again. Wife can get off my back over her 1/2 hour loggons ;)

nry 12-31-03 07:24 AM

Bumping this back up as the same issue is apparent on Fedora Core 1.

Botond's suggestion works for Fedora aswell:


Hi All,
try this in your /etc/modules.conf file and the ...0261 network driver will work fine:
options nvnet optimization=1

(I had the same problem you described above, but now a 2.4.23-rc5 kernel works smoothly with A7N266-VM).
For other valid options see the README file on the driver's page.
Strangely I have the exact same motherboard aswell!



UPDATE: For me, this option gives frequent hard-lockups requiring a hard reset. I usually cannot get back into Fedora as bootup usually locks. Be very careful if you try this!

dnoyeB 01-03-04 01:13 PM

261 nvnet is simply broken, hosed, bad, etc...
After trying the 261 drivers with the specified optimization from the readme file I must conclude that the 261 drivers still stink.

If I try to login at the console, I am met with a terribly long pause for the system to respond to my keystrokes. Once Logged in after I do startx, the desktop often is just frozen. Plus nmbd is hogging lots of CPU time, but unsure if that is totally related eventhough it started at the same time.

I have returned to the 261 w/ 256 nvnet install. That is working quite nicely.

I should also note the the optimizations are the same in 261 and 256, so why should I have to change the mode for 261? No, 261 is broken and should be avoided at all costs. Well, at least the nvnet portion.

NVIDIA, are you listening?

OmegaNine 01-03-04 11:02 PM

Where do I get the old one?
Where cna I get an old ver of the driver?

dnoyeB 01-05-04 08:43 AM

On NVIDIA's site, use the menus and the GO button. Then their will be a link to the archive on the left. If you use the direct link "Linux and FreeBSD Drivers" from the nvidia drivers page, you won't be given the archive link on the left.

pharazon 01-09-04 06:18 AM

I have A7N266-VM and I also experience the bad performance with the 261 drivers. For additional information it might be caused by bad interrupt handling. While I use scp, vmstat -n 1 says the system uses about 130000 interrupts / s. The idle usage is 100 interrupts/s. The CPU usage is around 50%. The transfer rate is about 1MB/s.

With optimization=1 the interrupts drop to 65k/s and the transfer rate is 3MB/s. CPU utilization is ~55%.

I'm using Debian sarge with 2.4.24 kernel with debian patches.

On the other machine (dual P2 with realtek) there are only about 2500 interrupts /s on the same data rate. It uses 99% of the other CPU.

Next I'll try the 256 drivers.

All times are GMT -5. The time now is 11:39 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.