nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   garbled ascii text on bootup (http://www.nvnews.net/vbulletin/showthread.php?t=13430)

vikool 06-15-03 02:46 PM

garbled ascii text on bootup
 
I just installed the latest drivers and when X starts up, the system hangs wiht soem blinking ASCII characters on the screen. the XFREE86 log has no errors at all. I've looked at the other threads on this problem they dont seem to solve it.
i'm running RH9 with a GF4 ti4200.
i have an Epox 8Rda+ mobo with the latest bios.

I tried changing the bios file ot a previous version ( seemed to work for some people), but i still end up with the junk.

Sephi 06-15-03 06:44 PM

Just the same problem with a Geforce 4 ti 4200 and an Epox 8RDA+

Emoktanar 06-16-03 09:05 AM

problem solved.
 
I had the same problem as you guys and the thread from infernator worked for me.. Basically you have to remove! the Dri Rendering part from 'Character Devices' in your kernel,, etc make menuconfig.. I also did I BIOS update to 5/22/03 but I dont think that was the problem,, just take out DRI-RENDERING,, and if that dont work nvidia has just realeased a new nforce driver that allows for agpgart, and its much better peformance ,, thats what glxgears showed me. Go to nvidia site get the driver for nforce follow the instructions from the readme documentation ,, you will now have an option to compile in NVIDIA drivers for the chipset into kernel.. but really just take out DRI-REndering from the kernel ,, I really believe thats all it is or was for me.. This problem has been documented more then once now and is in this forum.. So either your blind or just didnt look close enuff.

Sephi 06-16-03 09:30 AM

I finaly made it!
I recompiled the kernel with the agpgart patch and updated the bios with the 3609 release and now everything goes great!
Tnx for helping me!

yama 10-16-03 10:31 PM

Well, same here. GF4200-8x 64 Mb, Epox 8RDA+ and RH9, kernel 2.4.20-8. Up to date i tried removing apm support from the bios, as suggested in other threads, disabling it from bios, disabling agp and trying 4363 drivers. The 3xxx series drivers won't compile. Same ascii stuff in every config. I'm gonna try the DRI-Rendering stuff tomorrow morning, hope it works. I did comment out the dri driver in XFree86Config to no avail, though. Until then, just a quick question: Sephi, how did you manage to compile the kernel with the agpgart nVidia patch applied? I tried compiling agpgart both as a module and builtin and it gives some error about a missing structure member, num_masks, i believe. I seem to recall somebody else having the same problem, but he didn't get answered. So if anybody has an idea of what i'm doing wrong, I would greatly appreciate it. Many thanks.


All times are GMT -5. The time now is 04:31 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.