nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Cannot get glx module to load, irq/kernel settings??? (http://www.nvnews.net/vbulletin/showthread.php?t=134375)

ste 06-12-09 06:01 AM

Cannot get glx module to load, irq/kernel settings???
 
The system is a HP HDX16-1000 [Core2 P8400, 82801 ich9, nVidia 9600M GT] on which I'm trying to install a Gentoo amd64 system...

The nVidia kernel driver loads alright:
Code:

[    5.926096] nvidia: module license 'NVIDIA' taints kernel.
[    5.926099] Disabling lock debugging due to kernel taint
[    6.182691] nvidia 0000:01:00.0: power state changed by ACPI to D0
[    6.182714] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    6.182733] nvidia 0000:01:00.0: setting latency timer to 64
[    6.183173] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  180.60  Mon May 11 15:27:42 PDT 2009

But when starting X the following shows in the log!
Code:

(II) Loading /usr/lib64/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        ABI class: X.Org Server Extension, version 1.1
(==) AIGLX enabled
(==) Exporting typical set of GLX visuals
(II) Loading extension GLX

and later...

(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):    log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):    server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):    you continue to encounter problems, Please try
(EE) NVIDIA(0):    reinstalling the NVIDIA driver.

and in dmesg this appears when X loads...

[  813.845928] IRQ 16/nvidia: IRQF_DISABLED is not guaranteed on shared IRQs
[  971.640948] IRQ 16/nvidia: IRQF_DISABLED is not guaranteed on shared IRQs

Which to begin with obviously means that wrong glx module was loaded, effectively causing the (EE) part of the log... Reinstalling does not help.

I've found some discussions about the IRQF_DISABLED issue where nVidia folks seem to believe that it's irrelevant or at least mostly nothing to regard. I cannot avoid thinking it is related since it appears exactly when the module is trying to be loaded... Furthermore, I've been tinkering with kernel settings like sparse irq, numa, etc. trying to fix this, but only accomplished to cause the system to hang, making the main driver module refuse to load as well, flood the dmesg file with io_mmu messages making other hardware (like network card) stop function, etc. Other threads suggest BIOS settings, but laptops in general and this one in particular doesn't have any BIOS setting possibilities to talk about... I have a "reference" Ubuntu 9.04 install, where the glx module works --> It seems it is all about kernel settings --> I need guidance! Anyone?

Thanks in advance!

/ste

adamk75 06-12-09 06:27 AM

Re: Cannot get glx module to load, irq/kernel settings???
 
Did you use the eselect tool to select the nvidia opengl implementation?

Adam

ste 06-12-09 07:21 AM

Re: Cannot get glx module to load, irq/kernel settings???
 
Well, how extremely embarrassing :o:D;) that it was that simple, thanks a lot for opening my eyes... Although I have to say I was slightly misled by
Code:

* Adding module to moduledb.
Switching to nvidia OpenGL interface... done

produced by the ebuild every time you install/upgrade the drivers, and by the fact that I don't remember ever having to do that on my other three Gentoo/nVidia systems (but it was certainly a while ago since I installed them from scratch...). Still, I've got a few io-issues with the system, but that is for another forum...

Once again, thanks Adamk75 for pointing me to what should've been obvious!

/ste


All times are GMT -5. The time now is 07:10 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.