nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   wont install because of kernel (http://www.nvnews.net/vbulletin/showthread.php?t=13588)

hacnslash 06-18-03 06:40 PM

wont install because of kernel
 
I tried installing the last version of the linux drivers, but it keeps tellin me that there are no kernel interface for my current kernel. It then tries to contact the nvidia download area, and says there are no interfaces to be downloaded for my kernel. It then attempts to build one for my kernel but doesn't find any kernel header files. This is all on a suse 8.2 system. I isntalled it over the internet from their ftp server (ftp.suse.com), and that is probably why there are no header files in /usr/src/linux where they are supposed to be. Could someone please instruct me on a workaround or a solution. Any help would be highly appreciated.


*edit* i guess i should add my sys info:
duron1.2ghz
256 ram
tnt2
2.4.20 kernel (with optimizations for the athlon atchitecture...dont ask, thats what the installer said)
*edit*

baskitcaise 06-19-03 01:46 AM

just d/load the kernel sources from the suse ftp site ;)

VoLt3r 06-20-03 12:07 PM

I have the same problem with my SuSe 8.2 version.
Could someone plz tell me where I have to look on that ftp because I don't know exactly what I'm looking for.

TIA

hacnslash 06-20-03 04:07 PM

same prob
 
I got the same problem as Volt3r, I dont know what exact file name it is I am looking for....If someone who has solved this same problem can answer that would be great.

baskitcaise 06-20-03 04:49 PM

ftp.suse.com/pub/suse/i386/update/8.2/kernel/2.4.20 is the place for the source files of the updated kernel, it also contains different versions of the kernel if you want to try new ones

HTH

Hydroxides 06-20-03 10:58 PM

Recently Yast downloaded an updated Athlon optimised kernel and I was presented with the same problems as you have experienced when it came to reinstalling the drivers. I haven't found a permanent solution but this information will help.

The kernel sources from the suse site are correct, despite what the NVIDIA installer reports. The sources are processor generic and the processor specific part only comes in at compile time. Basically (after a lot of messing and investigating) this is what I did:-

Run the nvidia installer but add --kernel-name=2.4.20-4GB-athlon to the command line. This forces the installer to just build a nvidia.o (driver module) without trying to load it. Normally it will try to load it, find an error message and delete it.

The problem is, the installer (and the xserver AFAIK) uses "modprobe nvidia" to load the module. This checks the currently running kernel version with the version used to compile the driver module. Since these aren't the same it throws an error.

The way round this is to use "insmod -f nvidia" which forces the module to be loaded, regardless of the differences in kernel versions. After forcing the installer to build a driver, u can issue the insmod command and then init 5 to go back to the xserver. This is the stage I am at now. The next problem is making the xserver load the nvidia driver the same way, or by loading it as part of the boot sequence.

When I find a proper solution I'll post back here. Chances are, it's not going to be pretty. In the mean time, you can use the k_deflt kernels (binary rpms) from the link given above. The nvidia installer should install correctly with these. Ideally, NVIDIA could pre-build a kernel interface for the optimised athlon kernel and put it on their ftp site for the installer to fetch. This would solve everyone's problems. :rolleyes:

hacnslash 06-21-03 10:40 AM

thanks
 
thanks for the solution. It suits me just fine, since I only need to boot up into suse every other day for a couple of minutes...I use slackware as my main distro and it is workin out just fine.

redhatnoobie 07-09-03 11:07 PM

so has anyone found a permanent solution ie:"
where and what to get from suse and how to install?
i have the same header problem

mhund 07-11-03 04:39 PM

Thanks, after much anguish, this worked for me, too. I've put the insmod command in rc.local, and switched runlevel to 5 in inittab, and I'm starting up OK.

It's great to be back to Linux, thanks!

Hydroxides 07-12-03 02:19 PM

Well, short of being bothered to look for a more elegant and proper solution I just gave in and wrote an init.d script.

http://www.pi-software.org.uk/nvidia

It's not very well written, nor tested and I won't accept liability for any damage caused. Use it at your own risk. Having said that, I trust my own machine to it and it hasn't given me any grief thus far.

As root, you'll need to copy it to /etc/init.d/ and set the executable flag (chmod +x nvidia). Next, start up Yast2 and select System. Now start the Runlevel Editor. Click Runlevel Properties, scroll down to and select "nvidia" in the list and click Set/Reset in the bottom right. Select "Enable this service". Now click Finish and next time you boot you'll see an additional item in your verbose mode listings - "Force loading NVIDIA gfx module ".

This is perhaps a better means of solving the problem than putting the insmod in rc.local since this script will unload the module when you change run levels, saving you memory. Of course, if you rarely/never change runlevels this is somewhat of a moot point. It's also easier this way for people who aren't comfortable with altering scripts and who want to be able to enable/disable the fix from a nice GUI.

baskitcaise 07-13-03 02:08 AM

Another solution is to:-

cp /boot/your-vmlimuz.autoconf.h /usr/src/linux/include/linux/autoconf.h

cp /boot/your-vmlinuz.version.h /usr/src/linux/include/version.h

cp /boot/your-vmlinuz.config /usr/src/linux/.config

this should set your versions right in the src as long as you are not using anything higher than the 2.4.20 kernels.

and now the nvidas should compile correctly and install in the right place and autoload at boot.

( I think that is all that is needed, working from memory at the moment which is a bit fuzzy first thing on a sunday :)

baskitcaise 07-14-03 05:21 PM

Also there is the other way of:-

Execute the following commands as 'root' user at the command line:

cd /usr/src/linux
make cloneconfig
make dep clean

this will give the sources the right id for the installed athlon kernel.

HTH


All times are GMT -5. The time now is 06:41 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.