nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   GF 7300 solaris 10 Xsun (http://www.nvnews.net/vbulletin/showthread.php?t=136213)

mersan 07-22-09 06:24 AM

GF 7300 solaris 10 Xsun
 
Hi all,

I need to install driver for GF 7300 graphics card to my solaris 10 (u7).
But for some reason I have to use openwindows (I know solaris 10 does not come with open windows we are using OWA compatibility ).
How can I make kdmconfig for Xsun notice the newly installed nvidia driver?

Thanks in advance

-mersan

paulgress 07-22-09 09:44 AM

Re: GF 7300 solaris 10 Xsun
 
You cannot get Xsun to see the Nvidia drivers. It needs an Xsun driver. You need to use Xorg not Xsun. I'm running SXCE 117, using Gnome as my desktop and Xorg for Nvidia drivers. When I go into /usr/openwin/bin directory and double click on "xedit", the opemwindows xedit app will run fine. So, if you require something different, I'm not sure what you need, but I can run an openwindows app under gnome using Xorg.

mersan 07-23-09 03:26 PM

Re: GF 7300 solaris 10 Xsun
 
my application is not a simple open win application.
I tried Xorg but I am getting "Server does not support double buffering" although I have "Load deb" in config file :(
I only have binary of the application so no chance to modify the code.
do u think anybody develops Xsun driver for nvidia?

paulgress 07-23-09 11:41 PM

Re: GF 7300 solaris 10 Xsun
 
Sun has just removed XSun from SXCE 118 for X86/64 chips, so no I don't believe anyone there work on it any more other then bug fixes for legacy.

Lets see if we can get Nvidia working properly with Xorg. What Nvidia driver did you download?

According to the drive selection page:

http://www.nvidia.com/Download/index.aspx?lang=en-us

Putting in GeForce 7 series outputs to use:

Version: 185.18.14

Is this the driver you installed?

Have you tried different settings using Nvidias configuration utility "/usr/bin/nvidia-settings" ?

mersan 07-24-09 03:34 AM

Re: GF 7300 solaris 10 Xsun
 
I am using Version: 185.18.14.
I don't think the problem with Xorg is due to nvidia.
X opens without any problem.
but the application can not recognize "Load dbe" extension.
I am thinking of two reasons:
1. My application uses an old call two determine wheteher double buffering enabled which does not exist in Xorg or returns a different value
2. Some config of xorg suppresses the double buffering

I would check nvidia-settings command as soon as possible.

paulgress 07-24-09 11:57 AM

Re: GF 7300 solaris 10 Xsun
 
Just out of curiosity, is your openwindows application a 3D application?

If this were Opensolaris or SXCE, the Sun graphics engineers hang out on the xwin-discuss@opensolaris.org mailing list. It can be accessed here:

http://www.opensolaris.org/jive/forum.jspa?forumID=25

mersan 07-24-09 04:18 PM

Re: GF 7300 solaris 10 Xsun
 
My application (I am not sure if it is correct to say my application don't have source code :P) is not a 3d application.
Receives environmental data and displays accordingly on a map. It has some kinda graphical editor to draw 2d shapes.

paulgress 07-24-09 11:50 PM

Re: GF 7300 solaris 10 Xsun
 
The reason I asked is that double buffering is used only for 3D interfaces. I've never heard it being used for 2D apps. What opensolaris app is it? Is it on the web where I can download it and try?

mersan 07-25-09 02:31 AM

Re: GF 7300 solaris 10 Xsun
 
It is not an standard application. It is just custom developed application.
Unfortunately I can not provide the binaries.
I haven't seen any 3D screens and no idea why does it ask for double buffering.


All times are GMT -5. The time now is 02:07 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.