nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   random Xorg crashes with 185.18.14, 190.16 (http://www.nvnews.net/vbulletin/showthread.php?t=136283)

botio 07-23-09 01:00 PM

random Xorg crashes with 185.18.14, 190.16, 190.18
 
1 Attachment(s)
Hi,

Since 185 series I get some random X.org crashes, mostly when using firefox.
I've just tried 190.16 and got the same crash.
X crashes and restarts to the kdm login prompt.

I's very random, but every time it happend I was using firefox. (that's the software I use the most of the time though).
It's not happening on a specific web page, so I cannot reproduce it.

with 180.60 the system is stable, never had this problem.

I have a 6600GT cart (AGP).

here is what I get in Xorg.0.log.old (not included in the bug report)

Code:

<nothing wrong before>
(**) Logitech USB-PS/2 Optical Mouse: (accel) filter stage 0: 20.00 ms
(**) Logitech USB-PS/2 Optical Mouse: (accel) set acceleration profile 0

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x813128b]
1: /usr/bin/X(xf86SigHandler+0x51) [0x80c5381]
2: [0xb7fc3400]

Fatal server error:
Caught signal 11.  Server aborting


Please consult the The X.Org Foundation support
        at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(II) AT Translated Set 2 keyboard: Close
(II) UnloadModule: "evdev"
(II) Logitech USB-PS/2 Optical Mouse: Close
(II) UnloadModule: "evdev"
<end of file>

Have anybody else had this problem?
Is there a way I could provide more useful information?

thanks

botio 07-23-09 04:46 PM

Re: random Xorg crashes with 185.18.14, 190.16
 
same thing with 190.18 unfortunately

pavlinux 07-23-09 08:01 PM

Re: random Xorg crashes with 185.18.14, 190.16, 190.18
 
Quote:

Originally Posted by botio (Post 2053160)
Hi,
Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x813128b]
1: /usr/bin/X(xf86SigHandler+0x51) [0x80c5381]
2: [0xb7fc3400]

Fatal server error:
Caught signal 11. Server aborting

Please consult the The X.Org Foundation support at http://wiki.x.org for help. :D

botio 07-30-09 03:25 PM

Re: random Xorg crashes with 185.18.14, 190.16
 
no more crashes with 185.18.29 so far

edit: actually it just crashed, back to 180.60

savnn 07-31-09 02:55 AM

Re: random Xorg crashes with 185.18.14, 190.16, 190.18
 
I had similar issue on kubuntu9.04 when used X server from ppa repositories.
I reinstalled xserver-xorg related packages from ubuntu repositories. Now it doesn't crash.

kriko 07-31-09 08:26 AM

Re: random Xorg crashes with 185.18.14, 190.16
 
Interesting, same issue here on 7600GT (AGP).
I've started noticing that with 185.xx version and later.
190.18 is quite ok, but still crashed a minute ago - and the interresting thing is that I can recall using FF at that time when crashes occured.
Unfortunately I can't go back to 180.xx because it won't compile on current running kernel.

All the crashes ends up like this:
Code:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x79) [0x80cbc79]
1: [0xb7f74400]
2: /usr/lib/xorg/modules//drivers/nvidia_drv.so(_nv001711X+0x2b) [0xb627b31b]

I've attached bug report + old xorg log file.

kriko 08-02-09 04:01 AM

Re: random Xorg crashes with 185.18.14, 190.16
 
Happened again - and again I was using firefox. Maybe coincidence?
I was designing a webpage and I had open dolphin, kwrite and firefox.
when I switched to FF and opened firebug, Xorg crashed.
Backtrace again leads too nvidia_drv.so

However this cannot be reproduced reliably - seems it's hard to trigger this bug. Maybe it only happens on AGP cards?

kriko 08-18-09 07:16 AM

Re: random Xorg crashes with 185.18.14, 190.16
 
Happened again, now with 185.18.31.
I was browsing with firefox, viewing larger images (1600x1200).

The bug got triggered after 10 minutes of doing this. I also had gweinview in background (if relevant).

mocharhw 08-21-09 02:47 PM

Re: random Xorg crashes with 185.18.14, 190.16
 
It seems like all you guys with 185.xx/190.xx X server crashes are using KDE, there's another recent thread with similar discussion. I'm about to update a Gnome box from 180.53 to 185.18.31 and will report if I see these same problems.

kriko 08-21-09 03:21 PM

Re: random Xorg crashes with 185.18.14, 190.16
 
Ok, thanks for testing. I also see that this affects users with AGP cards till now...
might be also related...

botio 08-29-09 05:34 AM

Re: random Xorg crashes with 185.18.14, 190.16
 
It seems better with 190.25, no crashes so far.

edit: actually no, it still crashes with 190.25. This time I was using synaptic when it happened.

kriko 08-30-09 05:22 AM

Re: random Xorg crashes with 185.18.14, 190.16
 
Happened again with 190.25 and again I was using firefox.
Web development has become a pain on nvidia workstations :(


All times are GMT -5. The time now is 11:42 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.