nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   185.18.14 on Dell M1730 - SLI hangs (http://www.nvnews.net/vbulletin/showthread.php?t=136630)

wiresquire 07-30-09 07:37 AM

185.x and 190.x on Dell M1730 - SLI hangs
 
2 Attachment(s)
Hi

Turning on SLI on my m1730 results in the machine hanging hard; screen goes black (ie off) where I would usually see the nvidia logo come up when x starts, and cannot switch to consoles/ttys.

I've attached the nvidia-bug-report. This will show the xorg.log from a good boot. I've also attached the xorg log from the previous boot where it hung. It stops right after where it says "NVIDIA SLI enabled" :-(.

SLI has always worked with previous driver versions.

Can anyone help?
ws

wiresquire 07-31-09 02:24 AM

Re: 185.18.14 on Dell M1730 - SLI hangs
 
1 Attachment(s)
FYI, I also tried with a fresh xorg.conf generated by nvidia-xconfig (file attached, but obviously have changed SLI to off). Same result; machine hung hard at where the nvidia splash screen was expected when SLI was turned on.

Also tried with the 185.18.29 drivers; hard hang at same place.

What's going on?

ws

wiresquire 07-31-09 05:45 PM

Re: 185.18.14,29,31 on Dell M1730 - SLI hangs
 
185.18.31 is the same :(

ws

wiresquire 08-22-09 12:24 PM

Re: 185.x on Dell M1730 - SLI hangs
 
185.18.36 is the same :(

This trend is becoming very worrying:
- 180.x increased the default performance level to 1. This increases power usage and temperatures
- 185.x removes SLI

What's next? Drivers don't load on a single GPU?

ws

wiresquire 09-16-09 02:29 AM

Re: 190.32 on Dell M1730 - SLI hangs
 
2 Attachment(s)
I just tried the 190.32 beta drivers hoping against hope that SLI would work in the new series. No dice, exactly the same behaviour.

The machine hangs HARD as X is trying to load, and my only option is to hit the big red switch.
This means I can't generate a 'correct' bug report. I'm still using Ubuntu 9.04 (with all the latest updates).

Attached is a Xorg.log.old file that shows where it hangs. I've also attached a bug report. Note that this bug report was from when I switched SLI off in the hope it gives you some additional info.

ws

wiresquire 09-25-09 09:50 AM

Re: 190.36 on Dell M1730 - SLI hangs
 
1 Attachment(s)
Just tried 190.36. Surprise, surprise - it hangs with SLI enabled! Cannot switch to consoles etc as per above.

Just for fun, here's an xorg log with logverbose 6. Doesn't seem to show anything special that I can see. Except it stops dead....

I swear, the stupidest thing I have ever done in computing is to trust Dell and nvidia and buy an nvidia sli laptop. The 2nd video card may as well have been a rock and be used as a paperweight.

ws

wiresquire 10-20-09 06:41 PM

Re: 190.40 on Dell M1730 - SLI hangs
 
Sigh.

Enabling SLI with 190.40 on my stock Ubuntu 9.04(with all updates) x64 hangs as per all the 185.x and 190.x drivers above.

Machine hangs hard; screen goes black (ie off) where I would usually see the nvidia logo come up when x starts. Cannot switch to consoles/ttys.

Xorg.0.log.old extract after a reboot disabling SLI shows last few lines:
Code:

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "SLI" "On"
(**) Oct 21 10:27:55 NVIDIA(0): Enabling RENDER acceleration
(**) Oct 21 10:27:55 NVIDIA(0): NVIDIA SLI auto-select rendering option.
(II) Oct 21 10:27:55 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Oct 21 10:27:55 NVIDIA(0):    enabled.

And that's where I guess it hangs...

ws

wiresquire 10-27-09 10:40 PM

Re: 190.42 on Dell M1730 - SLI and single GPU hangs
 
1 Attachment(s)
Just tried the 190.42. SLI still causes a hang, but now when SLI is off the machine also hangs hard on a single GPU!
With SLI off, the LCD backlight stays on when it hangs, but with SLI on the backlight is not on when it hangs.

The attached bug report was run by booting into recovery mode (single/root). So some of the info is not actually correct, eg the dmesg, the kernel version uname is an older version than the up to date one I actually run etc.

Have to laugh at my prescient post #4.

ws

wiresquire 11-24-09 02:33 AM

Re: 195.22 on Dell M1730 - no SLI hang !
 
1 Attachment(s)
Just tried the 195.22 beta quickly. SLI no longer hangs (Yay! :D), but:
- when SLI is "On" or "AFR" the entire screen flashes white once some 3D is 'started'. Eg when Compiz 'animation' like the 3D Cube, the entire screen will start flashing white over the desktop and continues to flash white until the compiz 'animation' is finished AND you click somewhere on the desktop with the mouse.
I nearly had an epileptic fit !:bugeyes:
- I did briefly try running the Lightsmark benchmark on AFR, and besides the white flashing, it was reporting SLI equivalent framerates, so it was working. There was a crash at one point, but it was not related to the white white flashing, which is more of a problem at the moment...
- when SLI is "SFR" then the bottom half of the screen 'flashes', but not white like the above, so it is more epileptic friendly :naughty:. Like above, clicking with the mouse stops it.

Log attached, though I don't think it will show anything too interesting....

ws

AaronP 11-24-09 03:25 AM

Re: 185.18.14 on Dell M1730 - SLI hangs
 
That sounds kind of like there is a signal integrity problem with the SLI bridge. Is there any chance you could give Windows a try?

wiresquire 11-24-09 04:54 PM

Re: 185.18.14 on Dell M1730 - SLI hangs
 
Sure - no problem.

Which version(s) of the Windows drivers would you like me to test?

ws

AaronP 11-24-09 06:14 PM

Re: 185.18.14 on Dell M1730 - SLI hangs
 
The most recent version.


All times are GMT -5. The time now is 01:07 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.