nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Newbie - Compiling my own for SuSe 8.0 (http://www.nvnews.net/vbulletin/showthread.php?t=1395)

jocephus19 09-01-02 02:50 AM

Newbie - Compiling my own for SuSe 8.0
 
Can someone give me full instructions of how to compile the soure GLX and Kernel from Nvidia to put on my SuSe box? Any help would be greatly appreciated if SuSe truly is crap I think I just might go back to - - God Save Me - - Slackware. :mad:

Sorry to any slackware fans.

--Jocephus

Norbert 09-01-02 11:35 AM

compiling from source is pretty easy.... dl the tar files... exit x... cd into whichever directory you dled them into. tar -xzf both files. cd into the glx directory, make install. cd into the kernel directory make install. double check your etc/x11/XF86config file to make sure the dri and glcore modules are commented out. add the glx module. change the driver from nv to nvidia. At this point I always have to reboot before restarting x... but then that could be because I am using your hated slackware ;-)

--Norbert

jocephus19 09-01-02 07:48 PM

Well,

I did all that and I saw the Nvidia logo for a fifth of a second and then X shutdown. It said something about glxdatamodule or something like that and then it said something about kdeinit blah blah blah. I'm confrused. This is the ONLY reason I have not used Linux for long term. I just can't get the stupid video drivers to work. Maybe it's suse. My friend Brandon who is Lord Linux said Debian is the better distro for stuff like that because every source file works for it. Where can I go to get Debian and is it really that good and if not which distro is best for compiling my own drivers.:D

jocephus19 09-01-02 07:51 PM

Oh and the only thing i don't like about Slackware is that - - please don't hurt me - - I can't mount drives.:(

Is there an automount application like on apple computers that will do that?

Norbert 09-01-02 09:55 PM

hmmm.... posting your XF86Config file would help, as would posting the full error message you got... sounds like it didn't find the glx extensions tho.... you could try starting X w/ gnome instead of kde and see if that gives you the same error message... that way you rule out kde as the problem. As for other distros you could give mandrake a try... it is by far the easiest I've used.... although a bit bloated. W/ slackware you can use the drivemount tool to mount any drive, but you have to enter it as user mountable in the /etc/fstab file. Mandrake sets that up for you

--Norbert

jocephus19 09-01-02 10:38 PM

I've tried mandrake though and every time It hated my video card. Of course now I'm a tad bit smarter to linux and in the computer world they always say that to every problem in a computer it's most likely the user.

I think Nvidia could make their own distro. That would be awesome. They could set the bar for Linux gaming. It would be the ultimate gaming OS. and best of all...no liscencing restrictions on the drivers with the installation disk.

Maybe because of this post I will start a revolution for Linux users everywhere or just talk out of my @$$.:)


All times are GMT -5. The time now is 04:05 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.