nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   xorg7.4 + nvidia driver: blank tty after killing X or restarting kdm (http://www.nvnews.net/vbulletin/showthread.php?t=139909)

lancelot2 10-11-09 04:17 PM

xorg7.4 + nvidia driver: blank tty after killing X or restarting kdm [SOLVED]
 
1 Attachment(s)
Whenever I kill an X server or restart kdm, my vt1-6 text-mode displays become blank.
To be more precise, my first screen (on which the tty normally displays) becomes blank then goes into powersave. My second screen (which should become inactive) displays a few random green squares.

The tty displays are still active and working, they do accept commands typed from the keyboard, but I can't see anything. I can still switch to vt7 which works normally.

I have tried the old hack NVreg_UseVBios=0 but it doesn't change anything.
This is a horrible bug. Makes it impossible to work in text-mode.

I'm using debian squeeze.
My graphics card is a GeForce 9600 GT.

The problem does not occur with the open-source nv drivers.
The problem does not occur with xorg 7.3.

With xorg 7.4, I have this blank tty issue with the nvidia drivers 180.51, 185.18.31, 185.18.36, and the beta driver 190.36. All of them behave the same.

Thanks for your help.

lancelot2 10-13-09 12:28 AM

Re: xorg7.4 + nvidia driver: blank tty after killing X or restarting kdm [SOLVED]
 
Had some progress on the issue.

It's related to having a double screen with Xinerama.

If I change my xorg.conf to have only a single screen, my tty1-6 don't go blank anymore.

So that I might well have been posting on the wrong forums in fact... Because of course, when I switch to the nv drivers, I don't get the xinerama double screen, which somehow sorts out problem... Then if I use only a single screen with the nvidia drivers, I don't lose my tty displays either.

So far looks more like a xinerama problem.

EDIT: I got this sorted out finally. Using the built-in xinerama from the nvidia driver (TwinView option) solved the issue.


All times are GMT -5. The time now is 09:12 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.