nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SLI on new drivers: freezing when logging into KDE (http://www.nvnews.net/vbulletin/showthread.php?t=140140)

scratchi 10-16-09 09:21 PM

SLI on new drivers: freezing when logging into KDE
 
Hello

I'm running 2 BFG 7900 GTX cards in SLI on an nforce4 chipset using Gentoo with KDE.

My computer hangs during login to KDE with drivers newer then 180.29. This first occured when I upgraded to newer drivers on kde 4.2.2 and the 2.6.29 kernel. Below are the configurations I tried:

Kernel 2.6.29.4, KDE 4.2.2, drivers 185.18.14 - Computer froze during log in
Kernel 2.6.30.9, KDE 4.2.4, drivers 185.18.31 - Computer froze during log in
Kernel 2.6.31.4, KDE 4.3.2, drivers 190.36 - Computer froze during log in

If I disable SLI option in xorg.conf, the above configurations work; the computer doesn't hang during KDE login (by the way, when I say during login, I mean after I enter my username and password and KDE starts to load). I've also tried disabling composite in xorg.conf, but that did not help.

The below configurations work fine with SLI enabled.

Kernel 2.6.29.4, KDE 4.2.2, drivers 180.29 - Works fine
Kernel 2.6.30.9, KDE 4.3.2, drivers 180.29 - Works fine


Basically it seems that a change in all the drivers after 180.29 broke something in SLI for the 7900GTX cards (I couldn't even compile the 180.60 drivers, so I'm not sure if the problem exists there or not). I don't think it's a KDE bug since older drivers are working on older versions; and newer drivers work with SLI disabled.

Here is the result of lspci:

00:00.0 Host bridge: nVidia Corporation Device 0071 (rev a3)
00:00.1 RAM memory: nVidia Corporation Device 007f (rev a1)
00:00.2 RAM memory: nVidia Corporation Device 0075 (rev a1)
00:00.3 RAM memory: nVidia Corporation Device 006f (rev a1)
00:00.4 RAM memory: nVidia Corporation Device 00b4 (rev a1)
00:01.0 RAM memory: nVidia Corporation Device 0076 (rev a1)
00:01.1 RAM memory: nVidia Corporation Device 0078 (rev a1)
00:01.2 RAM memory: nVidia Corporation Device 0079 (rev a1)
00:01.3 RAM memory: nVidia Corporation Device 007a (rev a1)
00:01.4 RAM memory: nVidia Corporation Device 007b (rev a1)
00:01.5 RAM memory: nVidia Corporation Device 007c (rev a1)
00:01.6 RAM memory: nVidia Corporation Device 007d (rev a1)
00:02.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:04.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:05.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:06.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:07.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:09.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a4)
00:0a.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a4)
00:0a.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:0b.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:0b.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a4)
00:0f.0 IDE interface: nVidia Corporation CK804 IDE (rev f3)
00:10.0 RAID bus controller: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:11.0 RAID bus controller: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:12.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:13.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:14.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:16.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:17.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
01:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7900 GTX] (rev a1)
03:00.0 RAID bus controller: Silicon Image, Inc. SiI 3132 Serial ATA Raid II Controller (rev 01)
05:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 22)
06:07.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
06:0b.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
09:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7900 GTX] (rev a1)

Here is my xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder62) Wed May 27 01:58:49 PDT 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"

# Load "freetype"
Load "dbe"
Load "extmod"
# Load "type1"
Load "glx"
EndSection

Section "InputDevice"

# generated from data in "/etc/conf.d/gpm"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "SLI" "on"
SubSection "Display"
Depth 24
Modes "1680x1050"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "1"
EndSection



Please let me know if you require any more information to troubleshoot this.
I hope someone can help so I can continue to use my GPUs to their full capability.

Regards

Slava

scratchi 10-17-09 09:55 AM

Re: SLI on new drivers: freezing when logging into KDE
 
I just tried the 190.40 drivers and still experiencing the same issue. Currently running with SLI disabled

Deanjo 10-17-09 01:13 PM

Re: SLI on new drivers: freezing when logging into KDE
 
Working fine here on a 8800GT sli setup and 190.40 in KDE 4.3.2 on openSUSE 11.2 RC1

scratchi 10-17-09 01:43 PM

Re: SLI on new drivers: freezing when logging into KDE
 
Hmm, opensuse 11.2 RC1 comes with Xorg server 1.7...I'm running xorg 1.6.4. But besides that, I'm wondering if the 7900 GTX cards receive as much love as the 8800 GT during driver testing...considering they're much older and not as popular.

When 1.7 gets unmasked in the Gentoo tree I'll give it a shot, hopefully that'll be the fix.

scratchi 10-17-09 07:34 PM

Re: SLI on new drivers: freezing when logging into KDE
 
I installed xorg-server 1.7.0; the problem still persists, same behavior. It's definitely a problem with the 7900 GTX cards in SLI on the new drivers.

wiresquire 10-18-09 05:02 PM

Re: SLI on new drivers: freezing when logging into KDE
 
I have been reporting a similar problem(?) for my 8700M GTs in my dell xps m1730 running stock Ubuntu 9.04 (with all updates). SLI has caused a complete lockup since the 185.x version of the drivers. 180.x and previous driver versions worked. 185.x and 190.x don't. My thread is here. You will see I have become quite frustrated with the whole situation. I may as well be talking to myself :-/

In my case, I don't get to a log on screen. It crashes where I would expect to see the nvidia logo come up before the logon screen is presented.

It may help if you can run an nvidia-bug-report; even if it's not from the actual crash, it may help someone to help you.

good luck
ws

PS: I haven't tried 190.40 yet, though the changelog/readme suggests there will be no change for this problem, ie it still won't work

scratchi 10-18-09 07:53 PM

Re: SLI on new drivers: freezing when logging into KDE
 
Well...good to know I'm not the only one but kind of disturbing that's it's happening with some 8 series cards. After reading Daenjo's post I assumed that this effects the 7 series and lower chips and maybe be easier to diagnose for Nvidia. Hope they fix it, I have faith... it worked in the 180.x drivers so they just need to back paddle a bit :)

I ran the nvidia-bug-report.sh script but all it logged was my kernel version...which I already stated here.

But here are if it makes things any easier I'll just post it here...



Linux unstable 2.6.31.4 #1 SMP Tue Oct 13 20:33:56 EDT 2009 x86_64 Intel(R) Pentium(R) D CPU 3.00GHz GenuineIntel GNU/Linux

X.Org X Server 1.7.0.901 (1.7.1 RC 1)
Release Date: 2009-10-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.31.4 x86_64
Current Operating System: Linux unstable 2.6.31.4 #1 SMP Tue Oct 13 20:33:56 EDT 2009 x86_64
Kernel command line: root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/mapper/nvidia_afcgiafd4 dodmraid
Build Date: 17 October 2009 05:14:37PM

scratchi 04-03-10 08:34 AM

Re: SLI on new drivers: freezing when logging into KDE
 
Hello

I'm still getting the same problem with the 195.36.15 drivers when SLI is enabled. If I disable SLI, things work great. But when I enable SLI, the PC hangs when launching any 3D applications or when logging into KDE.

Same settings as posted above just updated to kernel 2.6.33.2 and nvidia-drivers 195.36.15.

Please help


Slava

Spyke 04-15-10 06:50 PM

Re: SLI on new drivers: freezing when logging into KDE
 
1 Attachment(s)
I have the exact same problem on SLI GTX 480's. Currently running SLI disabled which is fine.

X takes forever to start up, and any 3D applications or running nvidia-settings causes freezeups. The system unsticks after about 10 seconds until you do it again.

Attached nvidia-bug-report.sh

Spyke 04-16-10 05:41 PM

Re: SLI on new drivers: freezing when logging into KDE
 
Nobody running GTX 480 SLI here? Tsk Tsk.... :P


All times are GMT -5. The time now is 11:09 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.