nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   G210m Blank Laptop Display (http://www.nvnews.net/vbulletin/showthread.php?t=140482)

TaylorT 10-25-09 11:48 AM

G210m Blank Laptop Display
 
I just recently got a Sony Vaio laptop which has a G210M graphics card.

After installing various versions of the driver, both production (185.18.36) and the latest beta I could find (190.42), and setting up X to use the 'nvidia' driver, the laptop display goes blank and actually turns off when X starts.

After a few hours of googling and trying things, I believe that it's incorrectly detecting that no monitors are attached and it's trying to display through the vga port.

Including Option "ConnectedMonitor" "DFP" causes the screen to come on at least, but it's just grey and back lines. I would guess that it's a resolution problem at that point but I'm not sure where to go from there.

I've tried generating some mode lines but I can't even get one for the native resolution (1366x768) and 1280x720 didn't work either.

Any ideas?

AaronP 10-25-09 01:30 PM

Re: G210m Blank Laptop Display
 
Please see the forum sticky posts about how to generate an nvidia-bug-report.log.gz file.

TaylorT 10-25-09 02:30 PM

Re: G210m Blank Laptop Display
 
1 Attachment(s)
The report is now attached. I generated this with the 190.42 driver with the most basic options possible.

xorg.conf is as follows:

Code:

Section "Device"
        Identifier        "Configured Video Device"
        Driver                "nvidia"
EndSection

Section "Monitor"
        Identifier        "Configured Monitor"
EndSection

Section "Screen"
        Identifier        "Default Screen"
        Monitor                "Configured Monitor"
        Device                "Configured Video Device"
EndSection

Oops, I never metnioned my distro. Ubuntu 9.04 64bit, kernel is 2.6.28-16

AaronP 10-25-09 04:07 PM

Re: G210m Blank Laptop Display
 
Hmm, that's very strange. The driver indeed doesn't seem to think that there are any monitors connected. I'll need to see if I can find one of these laptops to reproduce the problem.

TaylorT 10-25-09 05:22 PM

Re: G210m Blank Laptop Display
 
Ok thanks. My laptop is a Sony Vaio VPCCW17FX but I believe most of the VPCC series is similar.

AaronP 10-26-09 06:20 PM

Re: G210m Blank Laptop Display
 
Thank you for reporting this problem. I tracked down the laptop in question, reproduced the problem, and filed a bug.

andrewkoff 11-02-09 03:32 PM

Re: G210m Blank Laptop Display
 
1 Attachment(s)
I have the same problem with Acer Aspire 5739G.
Installing 190.42 on Ubuntu 9.10 causes black screen, caps lock flushing and rebooting in a few minutes.
Aaron, please, see at my nvidia-bug-report. Hope you can help me.

Thank you in advance.
Alex

rohitvis 11-02-09 10:01 PM

Re: G210m Blank Laptop Display
 
I have the same problem. Does anyone have any creative solution?
I have been using the vesa driver but its blurry and does not set the resolution correctly.

My laptop is also a Sony Vaio VPCCW17FX

lakerssuperman 11-02-09 10:53 PM

Re: G210m Blank Laptop Display
 
For the time being I would recommend using the 'nv' driver instead of the vesa driver. I have the same laptop and this will at least provide you with proper resolution. The nv drivers lacks any 3d acceleration so compositing will not function but you will at least you will have a functional machine until the official driver gets sorted out.

rohitvis 11-03-09 08:25 AM

Re: G210m Blank Laptop Display
 
Can you post your xorg.conf file?

I'm having no luck with any of the drivers. I tried using nv but not luck.

When I use nv, the laptop behaves the same way i.e. screen goes black.

Thanks

gnm 11-03-09 10:26 AM

Re: G210m Blank Laptop Display
 
I also have the Sony - same thing - blank screen. The vesa driver works (using mandriva 2009.1) but of course I have no hardware acceleration. Eagerly awating any patches!

-Brian

rohitvis 11-03-09 11:40 AM

Re: G210m Blank Laptop Display
 
What did you have to do to get the vesa driver to work. I'm using Fedora 11 64bit. I logged into runlevel 3 and did an Xorg -configure followed by copying the xorg.conf to the /etc/X11/ dir. Then I updated the Driver string to say "vesa". Also I tried using the system-config-display.

Both of them work fine in that they display a GUI but not at the correct resolution. On Mandriva or any other distro -- what did y'all have to do to get the vesa driver to display at the correct resolution?


All times are GMT -5. The time now is 12:07 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.