nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X-server doesn't start with the nvidia driver "Failed to initialize the NVIDIA ..." (http://www.nvnews.net/vbulletin/showthread.php?t=140563)

DuProfNick 10-27-09 01:24 PM

X-server doesn't start with the nvidia driver "Failed to initialize the NVIDIA ..."
 
2 Attachment(s)
Hi,
I have a problem with my NVIDIA graphic card (Geforce 9300M GS) and X.org. When I start my PC (an AMILO notebook) there is no graphical desktop (This means the PC starts, but at one point it stops for no reason,after that I can change into text mode (with ctrl + alt +3) and then login). After a long research I figured out, what my problem is and I changed in the X.org configuration file the driver in nv instead of nvidia. Now I have my graphical desktop but no 3D functionalities. The nvidia-bug-report is empty (with the nvidia driver enabled), although I have started the X-server with 'startx --logverbose 6'.
In my Xorg logfile are these error lines

'(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
(EE) NVIDIA(0): Please check your system's kernel log for additional error messages and refer to chapter 8 ......'
and
'(EE) NVIDIA(0): Screen(s) found, but none have a usable configuration'

I've checked system kernel log (/var/log/messages?!) and got the message:

NVRM: rm_init_adapter(0) failed
NVRM: loading NVIDIA UNIX x86 Kernel Module 185.18.36

These Errors appears on every system start, even if I've used the nv driver.

I've looked also in my boot log, there is just one line mentioning the NVIDIA driver:

Enabling the nvidia driver: *** glibc detected *** /usr/bin/python: free(): invalid pointer: 0x0012b24a ***

No idea, what this all means, but, I suppose for this reason I'm here.

I have the problem since 3 or 4 weeks, I don't know, whether it was after an update or not, before that, the nvidia driver worked great!

And ... sry for my english I'm from Germany and my school english isn't that well.

I hope, you can help me, so don't disappoint me :D

Fabian

PS
I tried to solve the problem with changing the SELinux mode into permisive, it doesn't help.

PPS

The logs are attached.

PPPS

I have tried both, to compile the driver by myself and to use the driver from my fedora repository ...

AaronP 10-27-09 02:15 PM

Re: X-server doesn't start with the nvidia driver "Failed to initialize the NVIDIA ..
 
Quote:

vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.
This is a common problem with 32-bit systems. Please see the README section on this error.

MetaPhaze 06-25-10 11:35 AM

Re: X-server doesn't start with the nvidia driver "Failed to initialize the NVIDIA ..
 
I just had this problem as well
Turns out i had compiled my kernel with 4k stacks... it's not a 32 bit problem, it's a kernel problem.

Kernel Hacking > Use 4Kb for Kernel stacks instead of 8Kb

disable that in your kernel and you'll be fine ;)

zander 06-25-10 12:17 PM

Re: X-server doesn't start with the nvidia driver "Failed to initialize the NVIDIA ..
 
The vmap() allocation failure is due to kernel virtual memory exhaustion, which is not an uncommon problem on Linux/x86 systems. The size of the kernel stacks is unrelated to this - if you're seeing cases in which the use of 4KB stacks vs. 8KB stacks breaks the NVIDIA driver, please report this separately. The NVIDIA Linux driver is designed to work with 4KB kernel stacks, and there are no known problems with 4KB configurations.

artem 06-25-10 12:30 PM

Re: X-server doesn't start with the nvidia driver "Failed to initialize the NVIDIA ..
 
grep 4K .config
CONFIG_X86_RESERVE_LOW_64K=y
CONFIG_4KSTACKS=y

Everything works nicely here.


All times are GMT -5. The time now is 09:19 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.