nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   A7N8X2.0 Deluxe lock ups (http://www.nvnews.net/vbulletin/showthread.php?t=14058)

silmacil 06-28-03 01:43 PM

A7N8X2.0 Deluxe lock ups
I'm trying to run Mandrake 9.1 on an A7N8X Deluxe Revision 2.0. Everything installs and works fine, but only for limited windows of time. These windows range from 1 minute to as long as 6 hours sometimes. Typically It's about 25-30 minutes. I've tried every configuration I can think of from running with nothing onboard enabled to everything enabled, no PCI cards to all my PCI cards I use. (Audigy2 Plat, Promise UltraTX 100)

In the end, nothing makes a difference, it will still lock up after a period of time. While it's running everything functions properly. I've tried to pay attention to what I was doing at a crash and try that after reboot and so far that has never repeated a crash.

I've called ASUS and we went through some discussion and were unable to come up with anything. I did discover that the revision 2 on this board is suppose to be running an updated nforce2 chipset and it's not just an ASUS revision of the board. So I thinking maybe that is a cause, as if I use my friend's rev 1.06 everything is fine.

The fun twist to this is: this machine will run flawlessly under Windows for as long as I want. Because of this ASUS will not issue me an RMA. Which I can understnad since it shouldn't be a hardware flaw if Windows doesn't reproduce it. SiSoft Sandra completes it's test without fail and MemTest Prot also reports no errors. ASUS also told me they have no received any complaints so far.

I have tried various drivers for the nForce2 chipset. From the default ones Mandrake picks (whatever they are exactly) to teh 256 adn 261 from nVidia as well as the 116 ASUS offers. None make a difference, though the default ones Mandrake 9.1 picks seem the most stable (the system stays up longer).

Now the question .. has this happened to anyone else? Did you ever fix it? Any suggestions? Since teh machien is hard locking I am not getting logs that I know of to check for problems. If someone is able to help me find them and understand them I will gladly post whatever I can.

My board is using BIOS revision 1005 (the latest at time of writing). I'm using an XP 2600+ / 333 with 1GB of Corsair XMS pc3200 memory (2x512 in twin configuration).

I have also tried various memory configurations to see if that made a difference, it didn't. I have also tried an XP 2000+ / 266, same problem.

Any suggestions would be appreciated.

hlprmnky 06-30-03 12:31 PM

Well, I'll be...
I'm having the same problem with my setup:

Asus AN78X-Deluxe 2.0
BIOS 1005 (non-uber)
Barton XP2800+ 333MHz
2 X 512MB Corsair XMS3200
eVGA GeForce FX 5900 Ultra 256MB

Your post causes me great relief, especially the 'runs fine in Windows' bit; I was worried that one or more of my components was bad (all of them are brand new), and that I was doomed to dance the RMA dance for months and months until I had eliminated all possible points of failure.

I'm working on a solution to this problem, but so far I don't have one. I've tried the following kernels:

with various combinations of config options; some are more stable, some less. One thing I have *not* tried, but will attempt tonight, is using the ALSA drivers for sound instead of nvaudio or the kernel i810 driver.

Whatever happens, at least you and I both know there's at least one more out here with the same problem. If I get my box up and running in a stable manner, I will definitely post a step-by-step recipe here.

best of luck!

silmacil 06-30-03 08:06 PM

256MB ?
Anyone else with this board running a 256MB video card and Linux rune stable? I noticed both posts here involve a 256MB card, so I tried an old GeForce2 MX 32MB card ... so far no crashes, but it's only been ~1 hr. Has NVIDIA tested their drivers well enough with teh nForce2 Ultra chip and a 256MB card to assure me that is definitely not the problem?

I'd like to remention that I do not have this problem under Windows. I guess with the cards I have to test this theory I am also forced to run below AGP 8X a well as without Fast Write enabled ... so one of those factors could be contributing.

My main card is a GeForce FX 5600 256MB. If this runs stable all night I am going to pick up a GeForce FX 5200 Ultra 128MB, simply because I cannot afford better at this time. (I'm quite against ATi cards for several years now). I have also noticed that since I started using DVI ports, I can no longer do graphica installs. The system will load into memory then the keyboard lights will blink and the system is hung. Anymore using DVI ports noticed this? I've had 4 differnet DVI cards and they all do it. I'm use to it now and have written it off as poor DVI support under Linux. After installation things seem fine though. Just thought I'd throw that out since it could somehow be contributing to this as well (though I kinda doubt that).

silmacil 06-30-03 08:23 PM

Shortly after I sent that last post the GeForce2 MX crashes as well, so I guess my hope that it was the type of card failed. Somehow that makes me feel better , strange. Anyway, just wanted to clear that up before someone starts this big myth that 256MB cards are crap or something.

hlprmnky 07-01-03 10:13 AM

Let's compare notes
1 Attachment(s)

I'm going to post a full description of my hardware and setup, and I'd like you to do the same. I did a bunch of work to get the ALSA drivers installed, and use the 3c59x driver from the kernel tree. I suspect that I may have solved my earlier lockup problems, but now I'm up against the fact that the 4363 graphics drivers might not have NV35 support yet! :confused:

Tonight, I'm going to do a little surgery and swap in a GF2 GTS I have lying around, see if that clears up my current nastiness. In the meantime, here's what I'm running:

A7N8X-Deluxe (1005-FINAL BIOS)
Barton 2800+ (333 MHz FSB)
2 x 512MB Corsair XMS3200 (running at 333MHz)
ATA/100 HDD (for now)

Debian sid (unstable)
custom kernel 2.4.21

Output of 'XFree86 version':

This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository

XFree86 Version (Debian 4.2.1-8 20030609132746 james@nocrew.org) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 18 October 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.21-rc1-ac1-cryptoloop i686 [ELF]
Module Loader present

attached: kernel config and XFree86Config-4

silmacil 07-02-03 06:32 PM

my setup
1 Attachment(s)
A7N8X2.0 Deluxe
XP2600+ (333)
2x512 Corasir XMS PC3200 (333, non-agressive)
ASYLUM GeForceFX 5600 256MB
Audigy2 Platinum
UltraTX2 Promise IDE controller

Mandraek 9.1 default kernel (2.4.21-0.13mdk)
4.3.0 XFree86

I have the onboard sound disabled as well as the nVidia ethernet.

I run all my drive off the controller card normally, I've tried not using that card at all and runnign everying off the onboard IDE's, no change in stability. I've also tried removing the Audigy2 card and using the onboard, no change in stability. As I mentioned though, I have no problems getting any of the hardware to 'work' though.

hlprmnky 07-04-03 01:45 PM


It turns out that my problem was my video card - eVGA shipped their 5900u's with a tweaked BIOS that was apparently not so hot.

After reflashing my card, and backing my driver version off to 1.0-4191, I'm running at 100%.

I wish you the best of luck in resolving your issue as well!

matthew 07-06-03 01:39 AM

Re: solved!

Originally posted by hlprmnky

It turns out that my problem was my video card - eVGA shipped their 5900u's with a tweaked BIOS that was apparently not so hot.

My board runs fine unless I both load X and the nVidia driver for the the geforce 2MX video card AND burn CDROMS.
Burning a CD will kill the system every time. Under X. Don't run X (and the nVidia driver) and I can burn a CD.
The machine is an office 'test box'. It doesn't run any OS for extended periods of time, although it does run WinXP more than Linux so I have something to test our servers with.
My main 'workstation' is an old PIII/600 machine that no longer has a windows partition :-)

I found my crashes were some sort of failure in the IDE driver while burning CDs. Got kdb going to find that one...

There is some sort of interaction going on between nVidia's graphics driver and the IDE driver...

kgroombr 08-08-03 10:33 PM

I have an Abit NF7-S motherboard based on the same chipset and my system freezes in ten minutes or less under load. When it sits idle, I can run for a few hours, but eventually locks up. And Windows 2000, like on your system, ran for three days straight with two stress test programs running with absolutely no problems at all.

I have been trying everything I know of for the last three weeks to fix this and have found nothing that helped.

hlprmnky 08-09-03 01:50 AM

Well, after the release of 1.0.4496, I thought that I was set. The memory-based lockups went away entirely.

However, I am still seeing random hard locks of my system. At this point, however, they don't seem to be reliably associated with any software component.

At present, I'm planning on investigating an issue that may be peculiar to the A7N8X-Deluxe-2.0, namely a voltage regulator chip that runs very near 100 degrees Celsius (yes - the boiling point of water!) in default configs.

Other than cooling that chip, or chalking my problem up to 'well, uname -a *does* match against [test|pre]...', I'm not sure what else to do. Any suggestions for collaborative, cross-mobo problem solving are welcome. :)

silmacil 08-09-03 11:52 AM

problems solved
I gave Gentoo another try on my machine. I have wanted to run gentoo for quite some time but have alwasy preferred Mandrake. SInce I was getting lock ups all the tiem I figured, no tiem liek the present. Mandrake 9.1 uses kernel 2.4.21 so when I installed Gentoo, I tried 2.4.22_pre2-gss. Thsi kernle contains many patches including the nforce ide and the nvagp. It it reccomended by gentoo for mission critical servers running the latest hardware, so I figured it would be a good lace to start. Low and behold all of my locksup went away. I'l still using nVidia's 4363 videos drivrs, the 256 lan drivrs and the 261 audio drivers. Aside from being stable, this has been the first time I've been able to use the SPDIF on my card and both NIC cards.

I'm not saying to switch to gentoo if you have an A7N8X2.0 Deluxe, but there is definitely a problem with that board and the 2.4.21 kernels without the nforce patches.

If you want further details about what patches are in this kernle, you can see them on gentoo's site or I can get a list to post here.

good luck

All times are GMT -5. The time now is 11:29 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.