nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Xorg 100% CPU with nvidia driver (http://www.nvnews.net/vbulletin/showthread.php?t=140708)

mbreuer 10-30-09 01:42 PM

Xorg 100% CPU with nvidia driver
 
1 Attachment(s)
I've just switched over to the nvidia driver from nouvou. Everything is working, however Xorg CPU utilization is 100% of a single core (fortunately I'm running on an I7 so I can still function).

Some notes that might help...

X utilization starts normal but hits 100% after about one or two minutes (varies).
This happens even when not logged in via X (i.e., Login screen is up - I see the 100% via ssh... and the sound of the cpu fan spooling up).

If I kill X, things go back to normal for a while.
I can kill X and keep it dead and log in remotely (XDMCP) and don't see the utilization.

I've gone through this board and fixed everything I can see (selinux, etc.). I don't have any of the errors I'm told to look for.

I've attached the requisite bug report file that seems to have all requested data.

Meanwhile, I'll probably go to runlevel 3 for a while.

mbreuer 11-01-09 11:42 AM

Re: Xorg 100% CPU with nvidia driver
 
I think I've solved this... after much searching on the web, I found a reference to Device options "UseEvents" "on";

That seems to have done the trick.

Update: spoke too soon... just took a bit longer this time to hit 100% :(
update 2: actually seems to be fixed with UseEvents. Spiked for a bit then settled down. Now seems OK whether logged in or not.

mbreuer 11-23-09 11:23 PM

Re: Xorg 100% CPU with nvidia driver (solved?)
 
Ok - I fell back to the nouveau driver and still had issues. Today I came across this: https://bugzilla.redhat.com/show_bug.cgi?id=475890

Long story short: X was moved from vt7 to vt1. Init is running a tty on tty1. That is what's been causing CPU utilization issues for xorg of late (at least for me).

I've attached a small patch to the above mentioned bug report that solves my issue ... although I haven't tried yet with the proprietary driver (as I moved to 2.6.32rc8 for other reasons).


All times are GMT -5. The time now is 10:35 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.