nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Redhat 9.0 driver installation order (http://www.nvnews.net/vbulletin/showthread.php?t=14073)

Liong 06-28-03 11:15 PM

Redhat 9.0 driver installation order
 
Hello All,

I'm having difficulties with getting Redhat 9.0 activating hme0 which is the integrated NIC in a Shuttle SN41G2. I know there are some issues with Redhat and the integrated NIC's in the Nforce2 MOBO's but I'm wondering if I got the installation order wrong. I'm building this new system to learn Linux so please bear with me:) There are 2 drivers for Redhat 9.0 currently available for 1.0-0261:

NVIDIA_nforce-1.0-0261.rh90up_2.4.20_6.athlon.rpm
NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm

The second one is noted as a kernel upgrade. Does this mean that this particular build will update the kernel as well while the first one does not? Or is it the kernel update which I would need to install prior to installing the first one? I have not updated the base install of the Redhat.

Thanks in advance!

criminala 06-29-03 03:56 AM

i did it like this :

install the NVIDIA_nforce 1.0 rh9up 2.4.20_9_athlon.rpm

then on some site i found the nvnet-1.0_0256-2.athlon.rpm , install that also with the --force option and your ethernet will work .

now if i only could get my sound to work ... :rolleyes:

Liong 06-29-03 12:34 PM

Thanks I'll try that. I have everything else working except for the NIC but even a Netgear F311 would be detected by Kudzu but later cannot be activated since it "cannot be found". I tried installing WinXP on the box and it works like a charm.

criminala 06-29-03 01:02 PM

did you do something special to get your sound to work ?
i mean , my soundcard is recognized and all , but when i press on test sound i don't hear a thing .

did you change something in modules.cfg or so ?
or is it because i connected it with the SPDIF wire maybe :D

Liong 06-29-03 02:13 PM

Everything except the NIC was working after base install of RH9. RH actually detected the name of the devices correctly. The NIC I understand since RH doesn't come with the driver. But after installing the rpm it should work. Well it didn't for both the integrated NIC and the new one I put in. Same error message of the device not found even though kudzu detects them fine during bootup.

criminala 06-29-03 02:16 PM

did you try to install the nvidia driver first , then install these : http://www.pheran.com/nv7linux/nvnet...6-2.athlon.rpm and install them with the --force option ?



my sound is working trough headphones but not trough my SPDIF(optical) output . :angel2:

Liong 06-29-03 02:31 PM

I just finished installing it. Will try the patches right now...

The Nforce driver has a few notes about enabling SPDIF. Have you tried them?

criminala 06-29-03 02:37 PM

where can i find these notes ?? maybe i should read them :angel:

Liong 06-29-03 07:45 PM

Well after reinstalling twice this is what I found:

1) Regardless what driver I use, I could not get the internal Realtek NIC to work.

2) A clean install of RH9 has the Netgear NIC enabled. Installing NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm still has it enabled. The moment I force install the driver for the MOBO NIC, it shows the Netgear as nvnet which is incorrect.


This is the link and the relevant paragraph about SPDIF for the /etc/modules.conf:

spdif_status

The "spdif_status" module parameter is used to enable or disable S/PDIF support in the driver. By default S/PDIF is enabled, but can be disabled by setting spdif_status to 0. The driver can only support 48kHz sample rate when S/PDIF is enabled, so disabling it will increase compatability with applications that make assumptions about what sample rates the driver supports.


http://download.nvidia.com/XFree86/n..._1.0-0261.html

Let me know how it goes.


All times are GMT -5. The time now is 10:17 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.