nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   2nd Monitor on GeForce FX 5700 not detected in Mint 7 (173.14.16 driver) (http://www.nvnews.net/vbulletin/showthread.php?t=141047)

austin_john 11-07-09 02:58 PM

2nd Monitor on GeForce FX 5700 not detected in Mint 7 (173.14.16 driver) [SOLVED]
 
Hi - I recently installed Mint 7 on a PC with a NVIDIA GeForce FX 5700 Ultra, with 2 Dell E171FP monitors. Monitor 0 is attached to the VGA output on the 5700 and Monitor 1 is attached to the DVI output via a DVI/VGA adapter. Monitor 0 is detected properly, but Monitor 1 is not detected properly and only shows as a CRT, with max resolution of 640x480. I have installed and am using the 173.14.16 NVIDIA LINUX drivers and tried running nvidia-settings, but driver still not detecting the second monitor.

Any help is appreciated - John

austin_john 11-14-09 12:57 PM

Re: 2nd Monitor on GeForce FX 5700 not detected in Mint 7 (173.14.16 driver)
 
Still having trouble with this... have tried editing xorg,conf unsuccessfully.

Is there a way to force the definition of CRT-1? There's nothing in my xorg.conf that specifies either CRT-0 or CRT-1, so I can't figure out where CRT-0 is defined.

Thanks.

austin_john 11-16-09 07:44 PM

Re: 2nd Monitor on GeForce FX 5700 not detected in Mint 7 (173.14.16 driver)
 
1 Attachment(s)
Not sure if this will help (if anyone is reading this) :o, but here is the log file:

I see the following in the file:

(WW) NVIDIA(GPU-0): The EDID read for display device CRT-1 is invalid:
(WW) NVIDIA(GPU-0): unrecognized EDID Header.

Will search to see if I can see any fixes to this, but appreciate any pointers in the right direction.

Thanks!

austin_john 11-21-09 07:59 AM

Re: 2nd Monitor on GeForce FX 5700 not detected in Mint 7 (173.14.16 driver)
 
Thanks for all of the help! :beer: Was able to get assistance on Mint forums.

Also, using the NVIDIA driver "readme.txt" and sample xorg.conf (found in: usr/share/doc/nvidia-glx-173/), I edited my xorg.conf to override the EDID settings - or lack thereof - for the second monitor. The final file is attached. I then used the GUI nvidia-settings to adjust the refresh rate (could have manually done this using option "metamodes", but I was tired of spending all my free time trying to fix this), so there are some extraneous lines in the file - but it is working...

Can't upload a "conf" file, so here it is......

Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Sun Feb  1 20:21:04 UTC 2009

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "ServerFlags"
    Option        "DontZap" "False"
    Option        "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Keyboard0"
    Driver        "kbd"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/psaux"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "DELL E171FP"
    HorizSync      30.0 - 80.0
    VertRefresh    56.0 - 76.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "NV AGP TwinView"
    Driver        "nvidia"
    VendorName    "nvidia"
    Option        "TwinView"
#  Option          "CustomEDID" "CRT-1:/etc/X11/edid1.bin"
    Option        "SecondMonitorHorizSync" "31-82"
    Option        "SecondMonitorVertRefresh" "55-120"
    Option        "TwinViewOrientation" "RightOf"
    Option        "MetaModes" "1280x1024,1280x1024; 1024x768,1024x768"
    Option        "ConnectedMonitor" "crt,crt"

EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce FX 5700 Ultra"
EndSection

Section "Screen"

    #Monitor "Dell E171FP 1"
    Identifier    "Screen AGP TwinView"
    Device        "NV AGP TwinView"
    Monitor        "Monitor0"
    DefaultDepth    24
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "1"
    Option        "TwinViewXineramaInfoOrder" "CRT-0"
    Option        "metamodes" "CRT-0: 1280x1024 +0+0, CRT-1: 1280x1024_60 +1280+0; CRT-0: 1024x768 +0+0, CRT-1: 1024x768 +1024+0"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

Goodbye and good luck! :jumping:


All times are GMT -5. The time now is 10:20 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.