nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   display preemption with MPlayer Vdpau (http://www.nvnews.net/vbulletin/showthread.php?t=141210)

blindgeek 11-11-09 04:15 PM

display preemption with MPlayer Vdpau
 
Hello all. Recently I obtained a Clevo W860CU laptop with an GTX280M card. Everything seems to work fine, except for hardware accelerated decoding. I am running a custom compiled CLFS system with Linux lappie 2.6.31.5 #1 SMP Tue Nov 10 01:36:42 EST 2009 x86_64 Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz GenuineIntel GNU/Linux, Xorg-7.5, and the 190.42 drivers. Here is less verbose MPlayer output, as well as more verbose output, with VDPAU_TRACE set to 1, and VDPAU_NVIDIA_DEBUG set to 3. This is the xorg.conf file I am currently using, Vdpauinfo output, and Bug report. Do I need to look into getting a new GTX280 to put in this laptop? Where should I look next to track down the source of this problem? I am fast running out of ideas here. ALso, note that for mplayer_vdpau.txt, the command line I believe was mplayer -vo vdpau -display :0 -fs -vc ffmpeg12vdpau dvd://1. I also tried an X264 file I had laying around with -vc ffh264vdpau, and I got the same log output as linked above. If I can provide any more relevant output that I have not yet provided, please let me know. Thanks!

Stephen Warren 11-12-09 11:01 AM

Re: display preemption with MPlayer Vdpau
 
Do you have MPlayer configured to change the display resolution or refresh rate when playback starts, or when entering fullscreen mode? That might cause your problems.

If not, does removing "-fs" from the command-line change anything?

blindgeek 11-12-09 11:32 AM

Re: display preemption with MPlayer Vdpau
 
Hi Stephen, thanks for the reply. I tried removing -fs while playing a test clip I got from h264info.com last night, and that didn't change anything. I still got Vdpauinfo output that to me looked ok, and the display pre-empted as it did before. ONe thing I did do though is pull new MPlayer SVN for updates, which I do routinely anyway, and that is causing me to receive slightly new output (this is probably old output, but here it is for easy reference):
MPlayer SVN-r29903-4.4.1 (C) 2000-2009 MPlayer Team

Playing The Simpsons Movie - Trailer.mp4.
libavformat file format detected.
[lavf] Video stream found, -vid 0
[lavf] Audio stream found, -aid 1
VIDEO: [H264] 1280x544 24bpp 23.976 fps 4221.4 kbps (515.3 kbyte/s)
Clip info:
major_brand: isom
minor_version: 1
compatible_brands: isomavc1
================================================== ========================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] Trying pixfmt=0.
Unsupported PixelFormat -1

And here is the new output:
[vdpau] Display preemption detected
[vdpau] Failed creating VDPAU decoder: The display was pre-empted, or a fatal error occurred.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
[vdpau] Attempting to recover from preemption.
X11 error: BadDrawable (invalid Pixmap or Window parameter)
X11 error: BadDrawable (invalid Pixmap or Window parameter)
[vdpau] Display preemption detected
[vdpau] Error when calling vdp_presentation_queue_create: The display was pre-empted, or a fatal error occurred.
[vdpau] Recovering from preemption failed
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
Unsupported PixelFormat -1
Unsupported PixelFormat -1
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
I cut out the audio stuff, but more video output:
[h264_vdpau @ 0xd607c0]decoding to PIX_FMT_NONE is not supported.
[h264_vdpau @ 0xd607c0]decode_slice_header error
[h264_vdpau @ 0xd607c0]no frame!
Error while decoding frame!
And I get about two or three more pages of the "error while decoding frame" errors. I read somewhere that someone got it working on their UBuntu system by completely disabling CPU frequency scaling. I have mine turned on, but defaulting to the performance governor, which statically sets the CPU to the highest supported frequency; I did not think this could be it, but one never knows. So after I finish this post, I'm going to boot my new kernel and see if the problem goes away. As far as altering any refresh rates, in an effort to get MPlayer to pass the video bistream exactly as is, I passed in -vf-clr to clear the video filter chain completely, and not even that had any effect. Thanks.

blindgeek 11-12-09 11:49 AM

Re: display preemption with MPlayer Vdpau
 
I am in the new kernel now, and I am still getting the same output; basedon the Pixel formatting errors, perhaps this is a problem with my Xorg.conf? Or could it be something else entirely? Thanks.

blindgeek 11-12-09 10:42 PM

Re: display preemption with MPlayer Vdpau
 
Just a thought, but would it matter if I were running the logged MPlayer commands from a Bash shell, vs Gnome Terminal or similar? I have seen various tutorials and blog posts, where the posters run just -vo vdpau -vc ffh264vdpau <media file>. So unless they are exporting $DISPLAY, they would have to be either running MPlayer within a graphical terminal, or have to pass -display. I won't know whether this is true or not until my Gnome is done building though. Anyway, sorry to bump this post; I just thought I'd put this out there in case anyone had any thuoghts.

Stephen Warren 11-13-09 10:41 AM

Re: display preemption with MPlayer Vdpau
 
CPU scaling and shell/terminal are unlikely to be related to this issue.

the PIX_FMT_NONE message is unexpected. This may just be related to MPlayer having detected the display preemption, and attempting to recover.

It sounds like you've tried a number of different clips. Exactly how many? Do *any* clips work?

blindgeek 11-13-09 11:21 AM

Re: display preemption with MPlayer Vdpau
 
Hi Stephen. I have tried a number of clips, all of which play fine with -vo x11, albeit in a really tiny window, according to some sighted friends whom I have asked to test the setup from time to time; although, I think that the lack of full screen expansion, despite having passed -fs is an entirely different problem. Does my xorg.conf look ok from what you can tell? The reason I ask, is because I made some changes to see if I could get rid of MPlayer's "could not find matching colorspace" messages, since it seems this is what is causing the problem; when I compared logged output from playing the clips via -vo x11 and -vo vdpau, the former did not have any of the colorspace messages. When I added some modes in the display SubSection in Xorg.conf i.e., Modes "1920x1080" "1280x1024" "1280x720" "720x480" "640x480" etc, I got messages in my Xorg.0.log to the effect that the driver could not find any valid modes for 1280x720, and that it was removing them. Regardless, the configuration change did not resolve the colorspace problem. I have since reverted back to mode autoselection, as was the default configuration as generated by NVidia-xconfig. Here is the log of X as is currently running:
http://lava-net.com/xorg_current.log
The two clips I am currently working with, can be found at http://h264info.com/clips.html; specifically, The Simpons trailer, and The Bourne Ultimatum trailer. In case it helps as well, I have a Clevo W860CU laptop, which is where I am trying to get GPU accelerated decoding working. You can find its specs at http://www.xoticpc.com/sager-np8690-...op-p-2659.html. I wil keep looking into this problem, although I am not sure that I will come up with anything much more useful than the above. Also, if I can provide any more information that I have not already, please let me know. ANother reason why I want to make sure hardware accelerated decoding works, is so I can make sure I don't have any defective hardware; while it is under warranty for at least a year, I would like to be able to find out two weeks or so after getting the machine, vs 6 months later :). Thanks.

blindgeek 11-14-09 12:06 PM

Re: display preemption with MPlayer Vdpau
 
I finally got my Gnome installation working, and consequently was able to test the above failing command lines inside Gnome-terminal. I am not sure what actual video output is like; however, the log output suggests that video output is in fact working. The MPlayer output can be found at http://lava-net.com/mplayer_vdpau2.log. Thanks.

Stephen Warren 11-16-09 12:29 PM

Re: display preemption with MPlayer Vdpau
 
blindgeek, I'm afraid I don't know why you're having this issue. Was your "bug report" file created *after* you saw the problem? If not, can you run MPlayer, wait for the preemption problem, and then generate a new bug report? Thanks.

blindgeek 11-16-09 03:55 PM

Re: display preemption with MPlayer Vdpau
 
Hello. The bug report was created after I saw the problem; although, it seems to be fixed if I run MPlayer in Gnome-terminal, instead of from the non-graphical command line interface. IF I see the problem again even while running MPlayer in Gnome-terminal, I will be sure to post about it here. Thanks for your assistance.


All times are GMT -5. The time now is 07:21 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.