nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVIDIA: could not open device file /dev/nvidia0 on FC11, driver version 185.18 (http://www.nvnews.net/vbulletin/showthread.php?t=141284)

redbeard15 11-13-09 01:13 PM

NVIDIA: could not open device file /dev/nvidia0 on FC11, driver version 185.18
 
My system:

GeForce 9500 GT
Fedora Core 11
nVidia driver: 185.18.x

I was originally running FC10 and upgraded to FC11. I installed the latest nVidia driver (185.18.36) and had troubles getting it to work. I was running 180.29 and reinstalled that and ran into problems and re-installed 185.18 and actually got it to work.

However, the FC11 upgrade (from FC10) was a big fail. As I was testing out the new OS, I found many OS items not working. Unfortunately, I had to re-install FC11 from scratch.

Now I'm stuck. I've tried nVidia drivers versions 185.18.36, 185.18.14, 180.29, 180.60, all with no luck.

The basic FC install turns SELinux on by default. I caught that and set it to 'permissive' before I re-installed the drivers. Not sure if having SELinux on during my initial driver installs was a problem...

With 185.18.x I see 'NVIDIA: could not open device file /dev/nvidia0' logged when I 'startx'. The end of the /var/log/messages has the following when I 'startx'.
Code:

vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.
NVRM: RmInitAdapter failed! (0x26:0xffffffff:1092)
NVRM: rm_init_adapter(0) failed

I'm currently in the process of re-installing FC11.....

Ideas?

redbeard15 11-13-09 01:15 PM

Re: NVIDIA: could not open device file /dev/nvidia0 on FC11, driver version 185.18
 
3 Attachment(s)
Oops, forgot the usual attachments. Here they are.

conky 11-13-09 01:43 PM

Re: NVIDIA: could not open device file /dev/nvidia0 on FC11, driver version 185.18
 
Did you increase vmalloc? The driver readme explains how to do this: http://http.download.nvidia.com/XFre...hapter-09.html

redbeard15 11-13-09 02:45 PM

Re: NVIDIA: could not open device file /dev/nvidia0 on FC11, driver version 185.18
 
Quote:

Originally Posted by conky (Post 2123040)
Did you increase vmalloc? The driver readme explains how to do this: http://http.download.nvidia.com/XFre...hapter-09.html

By George, that's it!

Thanks. I had not read that chapter of the doc. I added 'vmalloc=192M' to the kernel command and voila! instant driver load!

Thanks again. problem solved.


All times are GMT -5. The time now is 11:22 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.