nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   fedora 12, 195.22, multiple nvidia cards, lockups + problems (http://www.nvnews.net/vbulletin/showthread.php?t=141881)

fpee 11-26-09 07:27 PM

fedora 12, 195.22, multiple nvidia cards, lockups + problems
 
1 Attachment(s)
Okay, trying to get 3 monitors setup. I have 1, 8800 GT, and a 7800 GTS. The nvidia-settings seams to detect everything, but I can't get this to work.

I've played with this for several hours on 195.22, and 190.42 .

190.42 segfaults often, with 1 display or 3.
195.22 doesn't segfault but it hangs the system if I enable anything but 1 display.

I'm getting the issue where my terminals disappear after I start xorg, I have tried putting
options nvidia NVreg_UseVBios=0
in /etc/modprobe.d/nvidia.conf
as well as appending vga=0x31b to my boot options, and with and without nvidiafb on the modprobe blacklist. None seam to make a difference.

Tried using UseInt10Module on 1 or both cards in the xorg.conf, didn't make a difference.

Tried with noapic kernel option as well, no dice.

Had this same hardware working on fedora core 8 (it was out of date but working).

Any suggestions would be appreciated.

fpee 11-26-09 07:40 PM

Re: fedora 12, 195.22, multiple nvidia cards, lockups + problems
 
I should mention that when I use the UseInt10Module, I get the following in the Xorg.0.log

Code:

(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/lib64/xorg/modules/libint10.so
(II) Module int10: vendor="X.Org Foundation"
        compiled for 1.7.1, module version = 1.0.0
        ABI class: X.Org Video Driver, version 6.0
(EE) NVIDIA(1): Cannot read V_BIOS (3) Input/output error


mbreuer 11-26-09 09:55 PM

Re: fedora 12, 195.22, multiple nvidia cards, lockups + problems
 
[quote=fpee;2131741...
I'm getting the issue where my terminals disappear after I start xorg, I have tried putting
options nvidia NVreg_UseVBios=0 ...
Any suggestions would be appreciated.[/QUOTE]

Could you have hit this: https://bugzilla.redhat.com/show_bug.cgi?id=475890

Long story short - mingetty & X clashing over tty1/vt1. Manifests using Nouveau as 100% cpu.

fpee 11-27-09 12:41 AM

Re: fedora 12, 195.22, multiple nvidia cards, lockups + problems
 
Quote:

Originally Posted by mbreuer (Post 2131779)
Could you have hit this: https://bugzilla.redhat.com/show_bug.cgi?id=475890

Long story short - mingetty & X clashing over tty1/vt1. Manifests using Nouveau as 100% cpu.

Thank you for the reply.

I don't think so, I uninstalled nouveau, and created a new initrd with no nouveau drivers, and for good measure I added nouveau to the /etc/modprobe.d/blacklist . Nouveau was segfaulting like crazy and causing random elements all over my screen when it did work + random lock ups. I will double check any cpu spikes and look into the tty1/vt1 just in case though.

Take it easy.

fpee 11-27-09 04:27 PM

Re: fedora 12, 195.22, multiple nvidia cards, lockups + problems
 
I just tried ubuntu 9.10, with the Nvidia 185 drivers. Same results. I updated to 195.22, same results.

The UseInt10Module gives the same cannot read V_BIOS (3) Input/output error, and without the UseInt10Module, it's a hard lockup with all of the above.

miltbos 12-04-09 05:06 PM

Re: fedora 12, 195.22, multiple nvidia cards, lockups + problems
 
Haven't tried any drivers newer than 190.42, but I have been messing with this for days. Had a suggestion to delete a bunch of lines from my xorg.conf as a solution, but it did nothing. Running Fedora 12 as well.

If I generate the xorg.conf from the "nvidia-settings" application, the cursor will lock at some point during bootup. Have tried everything I used to do in Fedora 11, and can't get there.

I would also appreciate some help from anyone.

miltbos 12-05-09 01:54 PM

Re: fedora 12, 195.22, multiple nvidia cards, lockups + problems
 
I am seeing something in the nvidia-settings application that doesn't look correct. It seems that both displays are identified as DFP-0, even though I have two GPU's identified. Should the DFP's be identified uniquely or does that mean it is the first flat-panel for that particular GPU?

jcook5376 12-14-09 06:55 AM

Re: fedora 12, 195.22, multiple nvidia cards, lockups + problems
 
1 Attachment(s)
The DFP-0 should be fine as 0 for both GPUs. I'm running into this problem as well with two Quadro cards. Tried two VMS 450s and two FX 1700s

I think it's a problem with the vga arbiter that is new in Xorg server 1.7. I'm getting this message in /var/log/messages constantly:

vgaarb: this pci device is not a vga device

When the X server hangs, I get this call trace:

[<c0450f78>] ? add_wait_queue+0x30/0x35
Dec 11 14:47:57 localhost kernel: [<c062f6bc>] vga_get+0xef/0x113
Dec 11 14:47:57 localhost kernel: [<c04396c8>] ? default_wake_function+0x0/0x12
Dec 11 14:47:57 localhost kernel: [<c062f7d1>] vga_arb_write+0xa6/0x3c4
Dec 11 14:47:57 localhost kernel: [<c04c89ee>] ? rw_verify_area+0x9d/0xc0
Dec 11 14:47:57 localhost kernel: [<c062f72b>] ? vga_arb_write+0x0/0x3c4
Dec 11 14:47:57 localhost kernel: [<c04c8dc8>] vfs_write+0x85/0xe4
Dec 11 14:47:57 localhost kernel: [<c04cf4e6>] ? path_put+0x1a/0x1d
Dec 11 14:47:57 localhost kernel: [<c04c8ec5>] sys_write+0x40/0x62
Dec 11 14:47:57 localhost kernel: [<c0408f7b>] sysenter_do_call+0x12/0x28

I get the problem using the Nouveau driver, or nVidia's 190.42 driver.


All times are GMT -5. The time now is 12:11 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.