nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem with vdpau and mplayer/smplayer (not showing video) (http://www.nvnews.net/vbulletin/showthread.php?t=142215)

Ringie 12-06-09 07:50 AM

Problem with vdpau and mplayer/smplayer (not showing video)
 
1 Attachment(s)
Hi,
I'm new here and also new in the linux scene but i try to give you as much information as i can get.
Example clip: http://www.dvdloc8.com/clip.php?movieid=12167&clipid=2

Code:

mplayer -vo vdpau -vc ffh264vdpau simpsons.mp4
- working great
Code:

mplayer -vo vdpau -vc ffh264 simpsons.mp4
- also working

But: I cant choose vdpau in smplayer as a driver. Also, wenn i only Use mplayer there is an Error:
Code:

/home/andreas/mplayer/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo vdpau -ao alsa -nokeepaspect -framedrop -nodr -double -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 71303183 -monitorpixelaspect 1 -noass -subfont-autoscale 1 -subfont-text-scale 5 -subcp ISO-8859-1 -vid 0 -aid 1 -subpos 100 -volume 40 -cache 2000 -osdlevel 0 -slices -channels 2 -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau, /home/andreas/mplayer/simpsons.mp4

MPlayer SVN-r29976-4.4.1 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Terminal type `unknown' is not defined.

Playing /home/andreas/mplayer/simpsons.mp4.

libavformat file format detected.
ID_VIDEO_ID=0
[lavf] Video stream found, -vid 0
ID_AUDIO_ID=1
[lavf] Audio stream found, -aid 1
ID_AID_1_LANG=und
VIDEO:  [H264]  1920x800  24bpp  23.976 fps  7234.8 kbps (883.1 kbyte/s)
Clip info:
 major_brand: isom
ID_CLIP_INFO_NAME0=major_brand
ID_CLIP_INFO_VALUE0=isom
 minor_version: 1
ID_CLIP_INFO_NAME1=minor_version
ID_CLIP_INFO_VALUE1=1
 compatible_brands: isomavc1
ID_CLIP_INFO_NAME2=compatible_brands
ID_CLIP_INFO_VALUE2=isomavc1
 author: 20th Century Fox
ID_CLIP_INFO_NAME3=author
ID_CLIP_INFO_VALUE3=20th Century Fox
 title: The Simpsons Movie - Trailer
ID_CLIP_INFO_NAME4=title
ID_CLIP_INFO_VALUE4=The Simpsons Movie - Trailer
 year: 2007
ID_CLIP_INFO_NAME5=year
ID_CLIP_INFO_VALUE5=2007
ID_CLIP_INFO_N=6
ID_FILENAME=/home/andreas/mplayer/simpsons.mp4
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=H264
ID_VIDEO_BITRATE=7234752
ID_VIDEO_WIDTH=1920
ID_VIDEO_HEIGHT=800
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=MP4A
ID_AUDIO_BITRATE=128072
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
ID_LENGTH=137.25
ID_SEEKABLE=1
ID_CHAPTERS=0
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
AUDIO: 44100 Hz, 2 ch, s16le, 128.1 kbit/9.08% (ratio: 16009->176400)
ID_AUDIO_BITRATE=128072
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [alsa] 44100Hz 2ch floatle (4 bytes per sample)
ID_AUDIO_CODEC=faad
[Mixer] No hardware mixing, inserting volume filter.
Video: no video
Starting playback...

Exiting... (Quit)
ID_EXIT=QUIT

I hope that this information is enough to help me. In the past, i was able to choose vdpau as driver in smplayer. but now its gone :( I dont know why.

edit: when i remove the "-wid" option, it works. how can i do that in smplayer?


All times are GMT -5. The time now is 03:51 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.