nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   2.6.32 - Missing .nv_gvi.o.d (http://www.nvnews.net/vbulletin/showthread.php?t=142231)

Paul73 12-06-09 03:54 PM

2.6.32 - Missing .nv_gvi.o.d
 
I recently upgraded my server to 2.6.32. Before 2.6.32 I was running 2.6.32-rc5, and using the NVIDIA drivers.

I downloaded 192.22, and ran the installer. It is failing to build the modules, there are a bunch of warnings about a pointer of type void used in arithmetic, but I think the error that looks significant is
"fixdep: /tmp/selfgz9688/NVIDIA-Linux-x86-195.22-pkg1/usr/src/nv/.nv_gvi.o.d: No such file or directory"

This is also happening with the older installers I had downloaded - 190.42 and 190.25.

Is this specific to the 2.6.32 kernel, or is there something I have not set in my kernel build options? The missing file looks to be a file that the NVIDIA installer would have created, so I'm guessing it is an installer problem. It is a little suspicious, however, that the older installers worked fine on 2.6.32-rc5, so I'd have to guess I've done something to break it.

Thanks,

Paul73 12-09-09 01:23 PM

Re: 2.6.32 - Missing .nv_gvi.o.d
 
I'm still getting this problem. Any tips on what may be causing it?

Paul73 12-12-09 07:55 PM

Re: 2.6.32 - Missing .nv_gvi.o.d
 
Still no idea why this happens, but I have found a solution to it.

I create a file called links.sh, in it I put:
ln -s .tmp_nv_gvi.d .nv_gvi.o.d
ln -s .tmp_nv-vm.d .nv-vm.o.d
ln -s .tmp_os-agp.d .os-agp.o.d
ln -s .tmp_os-interface.d .os-interface.o.d
ln -s .tmp_os-registry.d .os-registry.o.d
ln -s .tmp_nv-i2c.d .nv-i2c.o.d
ln -s .tmp_nvacpi.d .nvacpi.o.d
ln -s .nvidia.mod.o.tmp .nvidia.mod.o.d

I run the installer, and accept the license agreement. Whilst it is on the "there appears to be a driver installed" screen, I go to /tmp/self......./usr/src/nv, and run my script from above.

Everything then works.

My assumption is that someone has renamed what these files are expected to be called, without changing the actual names of them. So it is failing to compile. No idea why it just started happening now, and why it happens on the older installers as well. But it does happen on older kernel versions as well. I'm still guessing something on my machine has changed, or there would be lots of people with this problem, but I can't put my finger on what it is.

pavlinuxx 12-13-09 02:29 PM

Re: 2.6.32 - Missing .nv_gvi.o.d
 
Quote:

Originally Posted by Paul73 (Post 2137810)
"fixdep: /tmp/selfgz9688/NVIDIA-Linux-x86-195.22-pkg1/usr/src/nv/.nv_gvi.o.d: No such file or directory"


# sh NVIDIA-Linux-x86-195.22-pkg1.run -x
# cd NVIDIA-Linux-x86-195.22-pkg1
# ./nvidia-installer -a -n -N -b -q --no-abi-note --no-kernel-module

# cd usr/src/nv
# make
# make -f Makefile.kbuild


All times are GMT -5. The time now is 01:23 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.