nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GTX 275 only shows blank, black screen under Linux 2.6.30 on Gigabyte GA-EX58-UD5 (http://www.nvnews.net/vbulletin/showthread.php?t=142299)

jsharkey 12-08-09 02:15 AM

GTX 275 only shows blank, black screen under Linux 2.6.30 on Gigabyte GA-EX58-UD5
3 Attachment(s)
I'm running into some issues getting my GTX 275 card working under Gentoo Linux.

I'm running a 2.6.30-gentoo-r5 x86_64 kernel and X.Org The underlying hardware is a Gigabyte GA-EX58-UD5 and Core i7 860, and the card works great under Windows 7 with the 191.07 drivers.

Specifically, when trying to test the server using "Xorg -config" my DFP flashes off briefly, and then lights up again, but shows a blank, black screen. Keys like NumLock continue working, and I can Ctrl+Alt+F1/F7 to switch between virtual consoles, but Ctrl+Alt+Backspace doesn't kill the server. (I end up using Ctrl+C or SysRq+RE to kill the server.)

There doesn't appear to be anything useful in the log files, and it appears that it should be working:


(II) Dec 07 22:38:57 NVIDIA(0): Using built-in logo image.
(II) Dec 07 22:38:57 NVIDIA(0): Screen initialization complete

From various searches online, the best I can guess is that something isn't right with my MTRR:


reg00: base=0x000000000 (    0MB), size= 4096MB, count=1: write-back
reg01: base=0x0e0000000 ( 3584MB), size=  512MB, count=1: uncachable
reg03: base=0x100000000 ( 4096MB), size= 4096MB, count=1: write-back
reg04: base=0x200000000 ( 8192MB), size= 8192MB, count=1: write-back
reg05: base=0x300000000 (12288MB), size= 1024MB, count=1: write-back
reg06: base=0x330000000 (13056MB), size=  256MB, count=1: uncachable


mtrr: base(0xf7000000) is not aligned on a size(0xe00000) boundary
I poked around my BIOS, but there doesn't seem to be anything MTRR related. I tried enabling CONFIG_MTRR_SANITIZER, which docs mention should allow X drivers to add writeback entries. No luck. I also tried disabling CONFIG_X86_PAT, which docs mention to disable if running into video driver issues. Still no luck. Even though UVESAFB is compiled into the kernel, it's not enabled my grub boot line.

I've tested using both the stable 190.42 and beta 195.22 Unix drivers with the same results. Attached is my kernel .config and the output of nvidia-bug-report with -logverbose 6 under each of the driver versions.

I also tried the "nv" and "vesa" drivers with similar results.

I've been playing with various settings for a few evenings now without luck, so any ideas or help would be appreciated.

Thanks! :)

AaronP 12-08-09 10:09 AM

Re: GTX 275 only shows blank, black screen under Linux 2.6.30 on Gigabyte GA-EX58-UD5
What exactly is the command line you're using? If you're just starting X, the expected behavior of modern X servers is to show a black screen with no cursor until a client connects and tells it to do something. Also, Ctrl-Alt-Backspace was disabled in recent X releases. It sounds like the X server is operating as designed.

All times are GMT -5. The time now is 07:37 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.