nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Two TV cards breaks Nvidia driver (http://www.nvnews.net/vbulletin/showthread.php?t=142442)

jpterj 12-11-09 06:23 AM

Two TV cards breaks Nvidia driver
 
Hi.

I have a HTPC with a Nvidia 9500GT card and using the stable 190.42 driver from the OpenSUSE repository.

I have had this running for nearly a year with one Hauppauge HVR-4000 TV/SAT card without any problems.

Yesterday I tried to install a second HVR-4000 but I am not able to get the Nvidia driver to load with both cards in the HTPC. The only information in the xorg log is that it was not able to initialize the module, no information in the system log.

This behaviour is reproducable. If I take either of the cards out it works, and if I use the nv driver then X starts as normal.

Does anyone have an idea about how to troubleshoot or solve this?

This is on OpenSUSE 11.2 with kernel 2.6.31.

AaronP 12-11-09 01:04 PM

Re: Two TV cards breaks Nvidia driver
 
Please see the forum sticky posts about how to generate a bug report log file.

jpterj 12-11-09 02:42 PM

Re: Two TV cards breaks Nvidia driver
 
1 Attachment(s)
Hi, here is the bug report.

Some additional info:
1. I also tried with the beta 195.22 compiled from the package in the sticky on this forum with the same result.
2. I also tried with my Twinhan VP-1030A in addition to one HVR-4000. At first try the startup halted quite early with a message about some ACPI conflict. After disabling ACPI in BIOS the startup went fine, including the Nvidia driver.
3. I had a simmilar problem a few years ago when I installed the second HVR-4000 in my older PC, but then the PC stopped even before the BIOS POST was finished. I solved this by trying different versions of BIOS for the MB, and/or possibly some changes in the BIOS setup. In light of this I have installed the latest BIOS for this new MB which is an ASUS M4N78.

Oh I realized that I did not use startx -- -logverbose 6. I will do that and then attach a new log.

jpterj 12-11-09 03:16 PM

Re: Two TV cards breaks Nvidia driver
 
How do I enable startx -- -logverbose 6 on OpenSUSE 11.2 with KDE?

I have tried to find where startx is called from but not found it.

AaronP 12-11-09 04:47 PM

Re: Two TV cards breaks Nvidia driver
 
Code:

[  15.863906] vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.
[  15.874731] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1119)
[  15.874744] NVRM: rm_init_adapter(0) failed

Your kernel is running out of vmap space. Please see the README entry that discusses this problem.

jpterj 12-12-09 05:43 AM

Re: Two TV cards breaks Nvidia driver
 
Quote:

Originally Posted by AaronP (Post 2141367)
Code:

[  15.863906] vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.
[  15.874731] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1119)
[  15.874744] NVRM: rm_init_adapter(0) failed

Your kernel is running out of vmap space. Please see the README entry that discusses this problem.

Yes setting vmalloc=256M seems to have solved the problem.

I found a thread on this on an Ubuntu forum yesterday and did try it before posting on this forum, but I must have done something wrong yesterday.

Anyway the problem is solved now. Again thank you for a quick response to this.


All times are GMT -5. The time now is 02:22 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.