nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   id Tech 3 "polygonOffset" bug on Quadro FX3800 (http://www.nvnews.net/vbulletin/showthread.php?t=142560)

Rambetter 12-13-09 02:37 PM

id Tech 3 "polygonOffset" bug on Quadro FX3800
 
I make maps and play a video game which is based on the id Tech 3 engine (ioquake3). There is one thing you can do in maps for this engine, it's called a "decal", and there is a shader keyword "polygonOffset". This "polygonOffset" basically renders a surface an infinitesimal amount "in front" of other surfaces in the same plane that don't have the "polygonOffset" keyword. Anyhow, "decals" used to render fine for my with other graphics cards based on the NV25 and NV28 chips. I recently purchased a workstation with a Quadro FX3800 graphics card (the really expensive kind), and I've tried many different versions of the drivers (185.18, 190.32 through 190.42, and 195.22 beta) and I always get an occasional flickering effect when I look at decals that have "polygonOffset".

To better explain the situation, have a look at this video I made on my workstation:

http://www.icyjumps.com/world/youtube/NoobyDropin.html

Near the end of this short video you will see a flickering "Detour Phinish" decal on the wall. It looks like some z-fighting is going on. Could this be due to the extreme precision of my graphics card (number of bits used for calculations)?

I'm wondering if anyone can shed some light on this matter.


All times are GMT -5. The time now is 04:20 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.