nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   amd64 and 195.22 driver (http://www.nvnews.net/vbulletin/showthread.php?t=142776)

tigner 12-18-09 11:07 AM

amd64 and 195.22 driver
 
I have 2 systems with different PCI-e nvidia graphics cards, both running updated versions
of FreeBSD 8.0 Release AMD64 .

system 1: Video card is PCIe , nvidia0: <GeForce 8400 GS> on vgapci0
Everything works great, stable as a rock. Quad core cpu, 4GB DDR2 .

system 2: Video card is PCIe, GeForce 210
Seems to run X with no problem, however when I startkde (KDE4) the system
will either panic within 1 to 2 minutes, or it will panic when I exit KDE4. Both
panics force a reboot. Dual core cpu, 2GB DDR2.

Both systems use gpt and boot directly to ZFS.

The 2nd system seems to run Xorg just fine, I can email, browse, run apps just fine. It
seems to panic only when I start KDE4. Perhaps it is a combination of high memory
usage caused by the combination of 64bit OS, ZFS, and Nvidia driver ? I will have to
buy more memory to test this, and I haven't done so as yet.

zander 12-18-09 11:42 AM

Re: amd64 and 195.22 driver
 
There currently are two reported, but as-yet unresolved stability problems with the FreeBSD/amd64 BETA graphics driver:
  • Upon shutting down X, the system may crash with a kernel panic outside of NVIDIA graphics driver code; it's unclear if this is due to memory corruption, a driver/kernel interaction or a kernel bug.
  • When powerd is enabled, the system may hang some time after starting X.
I doubt that high memory usage is a problem in your case. I'd be curious what the panics look like on your system. If you could capture them with DDB, that would be very useful. Please also generate/attach an nvidia-bug-report.log file.

mlobo 12-20-09 07:37 PM

Re: amd64 and 195.22 driver
 
Please see:

http://www.nvnews.net/vbulletin/showthread.php?t=142331

tigner 12-22-09 12:29 AM

Re: amd64 and 195.22 driver
 
I've tried to run either the ddb or nvidia-bug-report.sh script with no success. The
system seems to either lock up completely or respond only to pings when I try
to exit Xorg normally.

The lockup appears to be random. It happens whether KDE is running or not and it
happens when exiting Xorg when running under the root or user account. It does seem
to happen much more consistently when running under a user account.
Sometimes , I can still ping the system, but the ping responses go from 0.080 mS
to varying from 0.080 to over 2000 mS. I ssh'd to the problem pc from an adjacent
machine , and ran "systat -vmstat 1" in 2 logins to monitor the problem system.
What I noticed is that the page faults go from (0-200) to (10K - 20K) and the window
freezes when the problem system locks up. The keyboard and mouse stop responding,
even from the ssh login on the good machine. What could be the reason why the page faults
go astronomical when exiting Xorg ? I will send a copy of nvidia-bug-report.log.gz
that was taken while I was typing this message, to freebsd-gfx-bugs@nvidia.com
since it is too long to post here. The next thing I am going to try is to kill the Xorg
to exit X and see if I get a panic that way. Any suggestions are welcome, and I
am very willing to stick with this until it is solved. Hopefully, the nvidia log file
will shed some light on this.

miwi 12-23-09 01:22 PM

Re: amd64 and 195.22 driver
 
Quote:

Originally Posted by tigner (Post 2148675)
I've tried to run either the ddb or nvidia-bug-report.sh script with no success. The
system seems to either lock up completely or respond only to pings when I try
to exit Xorg normally.

The lockup appears to be random. It happens whether KDE is running or not and it
happens when exiting Xorg when running under the root or user account. It does seem
to happen much more consistently when running under a user account.
Sometimes , I can still ping the system, but the ping responses go from 0.080 mS
to varying from 0.080 to over 2000 mS. I ssh'd to the problem pc from an adjacent
machine , and ran "systat -vmstat 1" in 2 logins to monitor the problem system.
What I noticed is that the page faults go from (0-200) to (10K - 20K) and the window
freezes when the problem system locks up. The keyboard and mouse stop responding,
even from the ssh login on the good machine. What could be the reason why the page faults
go astronomical when exiting Xorg ? I will send a copy of nvidia-bug-report.log.gz
that was taken while I was typing this message, to freebsd-gfx-bugs@nvidia.com
since it is too long to post here. The next thing I am going to try is to kill the Xorg
to exit X and see if I get a panic that way. Any suggestions are welcome, and I
am very willing to stick with this until it is solved. Hopefully, the nvidia log file
will shed some light on this.

sounds like exactly what i have, i already send a mail to the freebsd-gfx... adress but without any respond. Hopefully i'll get one.
intressing would be know which FreeBSD version you use.

miwi 12-27-09 07:40 AM

Re: amd64 and 195.22 driver
 
for the record,

setting kern.smp.disabled=1in loader.conf solved the deadlock. xorg with nvidia starts then without problems....


All times are GMT -5. The time now is 09:50 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.