nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   Microsoft Windows 7 (http://www.nvnews.net/vbulletin/forumdisplay.php?f=62)
-   -   working with a bad EDID (http://www.nvnews.net/vbulletin/showthread.php?t=142808)

directedition 12-18-09 08:32 PM

working with a bad EDID
 
I have a monitor (Sony GDM-FW900) that produces a bad EDID. Ubuntu sees its max as 800x600@60hz and Windows 7 sees the max as 1600x1200@85hz (this is with the latest drivers for my Geforce 9800GT). Windows XP had no problem forcing it to 1920x1200@85hz (and higher, but that's where I like it), but it doesn't seem to work in 7.

Using the NVIDIA Control Panel, I go to 'change resolution' and click 'add resolutions...'. From there I add 1920x1200@85hz, select it from the list, and click 'apply'. Nothing changes, or even flickers, and I get the confirmation "Your desktop configuration has been changed, etc etc" but it hasn't.

Has anyone had this problem?

nekrosoft13 12-18-09 08:44 PM

Re: working with a bad EDID
 
never ran into a monitor with EDID issues, you could try this utility http://entechtaiwan.com/util/ps.shtm

directedition 12-18-09 09:14 PM

Re: working with a bad EDID
 
Thanks. Hmm, the GUI has provisions for forcing a resolution, but all it does is turn my monitor off. No "mode unsupported" error message or anything. I have to into the windows resolution settings to turn it back on.

When I try "Read data directly from monitor", I get a DDC error:

"DDC communication with the monitor failed or is not supported.

Reverting to EDID data provided by Windows and the display driver, if available."

When I try "Read data from stored EDID", I get another DDC error:

"Valid EDID data could not be obtained from Windows or the display driver.

DDC is not supported."

directedition 12-19-09 09:36 PM

Re: working with a bad EDID
 
Well, with PowerStrip I was finally able to run run at 1920x1080@60hz, but that's not very useful (hertz hurts!). I was then able to get 1920x1200, which both PowerStrip and the monitor's diagnostics agree to be 85hz, but it looks more like 30hz or some crap. It's very painful to look at. I don't get why it's having such problems all of a sudden.

directedition 12-19-09 11:07 PM

Re: working with a bad EDID
 
Hmm, what's even more odd is that OSX detects all of the monitor's valid modes just fine.

[Edit]Well, seems its not detecting anything. OSX is just kind enough to give you all the options you could want. Why won't Windows 7 give me such freedom?[/Edit]

directedition 12-20-09 12:09 AM

Re: working with a bad EDID
 
Well, I decided to give the beta drivers a try and now adding the resolution through the control panel works.

Thanks. Hopefully this fix will show up in a stable release soon.


All times are GMT -5. The time now is 02:15 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.