nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   Reboot on X start with FreeBSD 4.8 and 1.0-4365 (http://www.nvnews.net/vbulletin/showthread.php?t=14284)

kevryn 07-02-03 11:46 PM

Reboot on X start with FreeBSD 4.8 and 1.0-4365
 
I just installed the new driver for FreeBSD, install went fine using make setup with no arguments or flags, but when now when I try to start X, the screen flickers like X is going to start, but then my system becomes unresponsive for a few seconds, then reboots.

Logs, X and kernel config files here

(edit: more info)
Motherboard is MSI K7T Turbo2 with VIA KT133 chipset
Card is TNT2 with 32MB of RAM
Using FreeBSD 4.8-STABLE
X version is 4.3.0_1.

I also run Slackware 8.1 with the generic kernel and version 1.0-4363 of the nVidia driver, and Windows 98 SE with the latest driver for that platform on this system, no problems.

The nv driver works fine, but I had some problems with the 1.0-3203 version of the nvidia driver that I'd hoped the new release would fix. I could run one GL application, but if I didn't restart X before running another one my system would become totally unresponsive and I could not log in remotely to shut down. I was also experiencing problems compiling apps that used the GL libs.

auge 07-03-03 04:25 PM

BusID "PCI:1:0:0"
Option "NvAgp" "1"

try this as i think you want to use nvidias agp.
the READMEs are your friend.

auge

kevryn 07-03-03 04:33 PM

Quote:

Originally posted by auge
BusID "PCI:1:0:0"
Option "NvAgp" "1"

try this as i think you want to use nvidias agp.
the READMEs are your friend.

auge

Oops. Forgot I had changed that setting to fix stability problems I had with the old driver (Locked up on X startup unless I started with just 'X', then any attemt to start an application caused a lockup, but switching to the FreeBSD agp fixed it)

kevryn 07-03-03 05:41 PM

Well, that didn't fix it. I also tried starting with just 'X' and got the same problem. I'm going to try getting a verbose log this time and see if there's anything more informative there.

mspgs2 07-03-03 06:24 PM

same problem but a tad different.
 
the old driver release works flawlessly, i can even play RtCW with better performance than Windows.

I upgraded to 4365 and on startup I get a kernel panic.

Fatal trap 12: page fault while in kernel mode
fault virtual address = 0xb1
fault code = supervisor read, page not present
instruction pointer = 0x8:0xc02c3c97
stack pointer = 0x10:0xe48b88f4
frame pointer = 0x10:0xe48b88f8
code segment = base 0x0, limit 0xfffff, type 0x1b
= DPL 0, pres 1, def32 1, gran 1
processor eflags = interrupt enabled, resume, IOPL = 3
current process = 215 (XFree86)
interrupt mask = none
trap number = 12
panic: page fault

running 4.8-STABLE
nvidia GeForce4 MX 420

did a make reinstall on the old driver (in ports), rebooted and it works flawlessly.

kevryn 07-03-03 08:42 PM

Out of curiosity I just tried recompiling the drivers with support for the FreeBSD AGP since that sort of fixed my problems with the old driver, but no change.

Then, after recompiling again back to the default settings, I tried setting the NvAgp option in my XF86Config to 0. Still no change.

I'm at my wit's end here. Nothing I do seems to make any difference, and it just dies without giving me any indication of what might possibly be going wrong! No messages, nothing in the logs, nothing! I don't want to have to go back to the old drivers, which worked horribly for me, but it's looking like I may have to, working horribly is better than not working at all :(

kevryn 07-07-03 06:54 PM

Fixed!
 
Well, somehow installing from ports fixed the problem I was having. It works beautifully now, no more horrible stability problems from GL :D Must have been a patch I was missing or something.

mspgs2 07-07-03 08:14 PM

port didnt work either
 
and in fact after trying to port i cant even get the previous version to work. I've now removed xfree and reinstalled the latest version but so far no luck.

at this point i'm fscked, literally! Hard panics. I might nuke and pave just for giggles.

mspgs2 07-08-03 10:13 AM

UPDATE: its kinda working now
 
well after having to live with the nv driver for a few hours I did the following.

cvsup'd 4.8-Stable from my April source to July 8th source
build/installed world & kernel
nv driver still works
tried latest nvidia kernel driver
locks up hard still
unload new nvidia kernel module and loaded old kernel module and that works fine now.

no idea why new driver panics the kernel. I've tried every option I can think of.

mspgs2 07-14-03 09:37 PM

FIXED!!!
 
After a good deal of research I fixed my nvidia issues, thanks to the above replys too. In short the damn port has

WITH_FREEBSD_AGP= yes

in the Makefile which i never noticed. Even if I didnt load AGP via the loader.conf I would get errors in XFree initilizing the driver, duh.

Somehow I thought the nvidia driver would need the agp driver and built its own version. I was wrong.

Oddly the source I downloaded directly from NVidia didnt work the first time around but that might have been my methodology.

Anyway, a summary?

I have a NVIDIA MX 420 on a P4-2.5ghz box running FBSD 4.8-Stable cvsup'd on July 8th and a fresh install of XFree86 4.3.0.

I commented out in /boot/loader.conf agp_load="YES".

I removed all nvidia driver stuff
I went into the freebsd port for the nvidia driver.
I edited the makefile to set WITH_FREEBSD_AGP=NO
I did a make deinstall to make sure
I did a rm /dev/nvidia*
I did a make clean && make && make install
I did a kldload nvidia

worked like a charm, so far.

It is still very very odd the fbsd agp worked fine in the previous version.


All times are GMT -5. The time now is 05:51 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.